aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /science
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
Notes
Diffstat (limited to 'science')
-rw-r--r--science/chemtool-devel/Makefile18
-rw-r--r--science/chemtool/Makefile17
-rw-r--r--science/chemtool/files/patch-Makefile.in2
-rw-r--r--science/gsmc/Makefile7
-rw-r--r--science/medit/files/patch-makefile2
5 files changed, 21 insertions, 25 deletions
diff --git a/science/chemtool-devel/Makefile b/science/chemtool-devel/Makefile
index dd33f7af783c..4cbee98e48c4 100644
--- a/science/chemtool-devel/Makefile
+++ b/science/chemtool-devel/Makefile
@@ -17,26 +17,22 @@ RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
WRKSRC= ${WRKDIR}/${PORTNAME}-1.7alpha15/
USE_GNOME= gtk20
-#USE_AUTOTOOLS= autoconf213
+USE_XORG= x11
GNU_CONFIGURE= yes
USES= gettext gmake pkgconfig tar:tgz
CONFIGURE_ARGS= --enable-emf=yes
PKGNAMESUFFIX= -devel
MAKE_ARGS+= MAKE=${MAKE_CMD}
MAKE_JOBS_UNSAFE= yes
-#to include emf
-CFLAGS+= -I${LOCALBASE}/include/libEMF
-CXXFLAGS+= -I${LOCALBASE}/include/libEMF
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libEMF
+LIBS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/configure.in
- @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's/-lstdc++//' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^SYS_LIBRARIES =/s/$$/ -lX11/' ${WRKSRC}/Makefile.in
post-install:
- @(cd ${WRKSRC}; \
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/examples/chemtool/; \
- cd ${WRKSRC}/examples/; \
- ${INSTALL_DATA} * ${STAGEDIR}${PREFIX}/share/examples/chemtool; \
- )
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/science/chemtool/Makefile b/science/chemtool/Makefile
index 0e5550b72b1d..823de2da6598 100644
--- a/science/chemtool/Makefile
+++ b/science/chemtool/Makefile
@@ -10,22 +10,21 @@ MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
MAINTAINER= maho@FreeBSD.org
COMMENT= Draw organic molecules easily and store them
+LIB_DEPENDS= libEMF.so:${PORTSDIR}/graphics/libemf
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
-USE_GNOME= gtk20
USES= gmake pkgconfig
+USE_GNOME= gtk20
+USE_XORG= x11
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libEMF
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-emf=yes --with-localedir=${PREFIX}
OPTIONS_DEFINE= EXAMPLES
-.include <bsd.port.pre.mk>
-
-#isolate libEMF stuff
-LIB_DEPENDS+= libEMF.so:${PORTSDIR}/graphics/libemf
-CFLAGS+= -I${LOCALBASE}/include/libEMF
+post-patch:
+ @${REINPLACE_CMD} 's/-lstdc++//' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/chemtool ${STAGEDIR}${PREFIX}/bin
@@ -36,4 +35,4 @@ do-install:
cd ${WRKSRC}/examples && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/chemtool/files/patch-Makefile.in b/science/chemtool/files/patch-Makefile.in
index bcdf12b98d33..305e49ef1e77 100644
--- a/science/chemtool/files/patch-Makefile.in
+++ b/science/chemtool/files/patch-Makefile.in
@@ -5,7 +5,7 @@
# Link time dependencies.
-LDADD = @LIBINTL@ @GTK_LIBS@
-+LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@
++LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@ -lX11
# Additional files to be distributed.
EXTRA_DIST = autogen.sh autoclean.sh
diff --git a/science/gsmc/Makefile b/science/gsmc/Makefile
index 5740c556fea8..c66ad25f2d7b 100644
--- a/science/gsmc/Makefile
+++ b/science/gsmc/Makefile
@@ -12,10 +12,11 @@ COMMENT= Smith chart program for impedance matching
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
USES= gmake pkgconfig
USE_AUTOTOOLS= aclocal automake autoconf
-AUTOMAKE_ARGS= -i --add-missing --foreign --copy
+AUTOMAKE_ARGS= -i --add-missing --foreign --copy --force
+
+post-patch:
+ @${REINPLACE_CMD} '/^LIBS=/s/$$/ -lm/' ${WRKSRC}/Makefile.am
.include <bsd.port.mk>
diff --git a/science/medit/files/patch-makefile b/science/medit/files/patch-makefile
index d6b50ce84e8a..a6694bea59a1 100644
--- a/science/medit/files/patch-makefile
+++ b/science/medit/files/patch-makefile
@@ -16,7 +16,7 @@
+ $(MAKE) $(MFLAGS) -f Makefile.arch \
+ "prog = medit" \
+ "INCDIR = -I. -I$(WRKSRC)/sources -I$(LOCALBASE)/include" \
-+ "XLIBS = -L$(LOCALBASE)/lib -lXmu -lXext -lX11 -lpmc" \
++ "XLIBS = -L$(LOCALBASE)/lib -lXmu -lXext -lX11 -lpmc -pthread" \
+ "GL_LIB = -lGL" \
+ "GLU_LIB = -lGLU" \
+ "GLUT_LIB = -lglut" \