aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2016-11-29 21:15:41 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2016-11-29 21:15:41 +0000
commit7f186fd63397c9402a294e0dd799000599dc9bef (patch)
tree9d76152b03314965cbd109ebd3cb20182563261c /science
parentd35fefab1beb287a816c1111b60ff6662179038e (diff)
downloadports-7f186fd63397c9402a294e0dd799000599dc9bef.tar.gz
ports-7f186fd63397c9402a294e0dd799000599dc9bef.zip
science/afni: Use BUILD_DEPENDS/RUN_DEPENDS instead of LIB_DEPENDS for
math/R, because R may be configured without libR. While here, fix some stage-qa warnings about indirect dependencies. Reviewed by: AMDmi3 Approved by: bacon4000@gmail.com (maintainer) swills (mentor) Differential Revision: https://reviews.freebsd.org/D8649
Notes
Notes: svn path=/head/; revision=427397
Diffstat (limited to 'science')
-rw-r--r--science/afni/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/science/afni/Makefile b/science/afni/Makefile
index f9bfdb597308..cabb4159c8bc 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -11,6 +11,7 @@
PORTNAME= afni
PORTVERSION= 2015.11.13
+PORTREVISION= 1
CATEGORIES= science biology graphics
MASTER_SITES= http://www.acadix.biz/Ports/distfiles/
@@ -19,17 +20,19 @@ COMMENT= Advanced Functional Neuro Imaging
LICENSE= GPLv2
-BUILD_DEPENDS= gm4:devel/m4
-LIB_DEPENDS= libXm.so:x11-toolkits/open-motif \
- libR.so:math/R \
+BUILD_DEPENDS= gm4:devel/m4 \
+ R:math/R
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libf2c.so:lang/f2c \
libgsl.so:math/gsl \
libnetcdff.so:science/netcdf-fortran \
libxml2.so:textproc/libxml2 \
- libf2c.so:lang/f2c
-RUN_DEPENDS= mpeg_encode:multimedia/mpeg_encode \
+ libXm.so:x11-toolkits/open-motif
+RUN_DEPENDS= endian:sysutils/endian \
+ mpeg_encode:multimedia/mpeg_encode \
ppmtogif:graphics/netpbm \
- endian:sysutils/endian \
- qhull:math/qhull5
+ qhull:math/qhull5 \
+ R:math/R
CONFLICTS= im-[0-9]* \
nifticlib-[0-9]* \
@@ -47,8 +50,8 @@ USE_GNOME= glib20
BROKEN_sparc64= Does not compile: "undefined reference to '_mcount'"
-USE_GL= glw glu
-USE_XORG= xi
+USE_GL= gl glu glw
+USE_XORG= x11 xext xi xmu xp xt
MAKE_ENV= CC="${CC}" R_SHARE_DIR=${LOCALBASE}/lib/R/share
MAKE_JOBS_UNSAFE=yes