aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-05-09 16:42:27 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-05-09 16:42:27 +0000
commit4fd0a4b1c1c3f2cb1454e156e26774835885d347 (patch)
tree1b932c4555183e30779ab5f4c3093442aaa0b57e /science
parent99d5a24eca4a0194ff773fff20b5400c62b0fd8d (diff)
Notes
Diffstat (limited to 'science')
-rw-r--r--science/abinit/Makefile4
-rw-r--r--science/getdp/Makefile4
-rw-r--r--science/gnudatalanguage/Makefile3
-rw-r--r--science/gromacs/Makefile3
-rw-r--r--science/kst/Makefile4
-rw-r--r--science/kst2/Makefile3
-rw-r--r--science/py-mlpy/Makefile3
7 files changed, 14 insertions, 10 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 1609cd8515ae..e060c59a385c 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= abinit
PORTVERSION= 5.7.3
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= science
MASTER_SITES= ftp://ftp.abinit.org/pub/abinitio/ABINIT_v${PORTVERSION}/
@@ -16,7 +16,7 @@ COMMENT= Abinit calculates electronic structure of systems
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
LIB_DEPENDS= netcdff.4:${PORTSDIR}/science/netcdf3-ftn \
- gsl.15:${PORTSDIR}/math/gsl
+ gsl.16:${PORTSDIR}/math/gsl
USE_FORTRAN= yes
USE_GMAKE= yes
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index f1d563fef856..13cbf00aec91 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= getdp
PORTVERSION= 1.2.1
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= stephen@missouri.edu
COMMENT= A rather general finite element solver using mixed finite elements
-LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl \
lapack.4:${PORTSDIR}/math/lapack
USE_FORTRAN= yes
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 49054c4b63e6..4abb6023fb63 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
@@ -30,7 +31,7 @@ COMMENT?= GDL, a free IDL compatible incremental compiler
#---------------------------------------------------------------------------
LIB_DEPENDS+= plplotd.10:${PORTSDIR}/math/plplot \
- gsl.15:${PORTSDIR}/math/gsl \
+ gsl.16:${PORTSDIR}/math/gsl \
dps.0:${PORTSDIR}/x11/dgs
USE_GCC= 4.4+
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 19e45dd75f03..1494be563913 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gromacs
PORTVERSION= 4.5.4
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
@@ -70,7 +71,7 @@ CONFIGURE_ARGS+= --with-fft=fftpack
.if !defined(WITHOUT_GSL)
CONFIGURE_ARGS+= --with-gsl
-LIB_DEPENDS+= gsl.15:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.16:${PORTSDIR}/math/gsl
.else
CONFIGURE_ARGS+= --without-gsl
.endif
diff --git a/science/kst/Makefile b/science/kst/Makefile
index 960c4f277be9..fbd87194ecb1 100644
--- a/science/kst/Makefile
+++ b/science/kst/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kst
PORTVERSION= 1.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/apps/KDE3.x/scientific
@@ -16,7 +16,7 @@ COMMENT= Data viewing program for KDE
BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser
LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
- gsl.15:${PORTSDIR}/math/gsl
+ gsl.16:${PORTSDIR}/math/gsl
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index c81bea5862d1..f7ead6ec2bf0 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -6,13 +6,14 @@
PORTNAME= kst
DISTVERSION= 2.0.3
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
MAINTAINER= makc@FreeBSD.org
COMMENT= Data viewing and plotting tool
-LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
LATEST_LINK= kst2
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
index 12f0bc1fad8c..dfed3c900c48 100644
--- a/science/py-mlpy/Makefile
+++ b/science/py-mlpy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mlpy
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= science python
MASTER_SITES= https://mlpy.fbk.eu/download/src/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +19,7 @@ COMMENT= High performance Python package for predictive modeling
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
cython>0:${PORTSDIR}/lang/cython
RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= gsl.15:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
CFLAGS+= -I${LOCALBASE}/include -I${PYTHON_SITELIBDIR}/numpy/core
LDFLAGS+= -L${LOCALBASE}/lib