aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
commit109269205e521bb1d2d87678a391e5adefff88d6 (patch)
tree93f1f9278a9a48902904b7ff4a5ce711c10efe08 /science
parentad7295cafd0e46ece6fcbf594ef39a767c296d0e (diff)
downloadports-109269205e521bb1d2d87678a391e5adefff88d6.tar.gz
ports-109269205e521bb1d2d87678a391e5adefff88d6.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/hs-bio/Makefile6
-rw-r--r--science/hs-bio/files/patch-Bio__GFF3__FeatureHierSequences.hs19
2 files changed, 21 insertions, 4 deletions
diff --git a/science/hs-bio/Makefile b/science/hs-bio/Makefile
index 09b6caf80e80..2d685b87f086 100644
--- a/science/hs-bio/Makefile
+++ b/science/hs-bio/Makefile
@@ -3,16 +3,14 @@
PORTNAME= bio
PORTVERSION= 0.5.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A bioinformatics library
+COMMENT= Bioinformatics library
LICENSE= LGPL21
-CABAL_SETUP= Setup.hs
-
USE_CABAL= mtl parallel parsec QuickCheck>=2 tagsoup>=0.8
EXECUTABLE= fastout flowclip flx frecover frename orf rselect-pe
diff --git a/science/hs-bio/files/patch-Bio__GFF3__FeatureHierSequences.hs b/science/hs-bio/files/patch-Bio__GFF3__FeatureHierSequences.hs
new file mode 100644
index 000000000000..6f83130df055
--- /dev/null
+++ b/science/hs-bio/files/patch-Bio__GFF3__FeatureHierSequences.hs
@@ -0,0 +1,19 @@
+--- ./Bio/GFF3/FeatureHierSequences.hs.orig 2012-02-23 14:45:38.000000000 +0100
++++ ./Bio/GFF3/FeatureHierSequences.hs 2013-05-01 00:28:58.000000000 +0200
+@@ -15,6 +15,7 @@
+ import qualified Data.Map as M
+ import Data.Maybe
+ import qualified Data.Set as S
++import System.IO.Error (catchIOError)
+
+ import Bio.Sequence.SeqData
+ import Bio.Sequence.Fasta
+@@ -72,7 +73,7 @@
+ return $ Seq seqname sequ Nothing
+
+ catchIOErrors :: IO a -> ErrorT String IO a
+-catchIOErrors m = ErrorT { runErrorT = liftM Right m `catch` (return . Left . show) }
++catchIOErrors m = ErrorT { runErrorT = liftM Right m `catchIOError` (return . Left . show) }
+
+ runGFF :: FilePath -> (ErrorT String (Reader FeatureHierSequences) a) -> ErrorT String IO a
+ runGFF gffname m = do gff <- catchIOErrors $ LBS.readFile gffname