aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-10-26 02:55:56 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-10-26 02:55:56 +0000
commit94e7e8c9c39758fccbab33f790761db8624f2576 (patch)
treed339bd742b2860b4d1d2fbf85e54d0f8c21d2e81 /science
parentc4a59c6c56d481a480636eebdc97068da9343c22 (diff)
downloadports-94e7e8c9c39758fccbab33f790761db8624f2576.tar.gz
ports-94e7e8c9c39758fccbab33f790761db8624f2576.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/cdo/Makefile2
-rw-r--r--science/cdo/distinfo6
-rw-r--r--science/cdo/files/patch-src-cdo_pthread.c4
-rw-r--r--science/cdo/files/patch-src-config.h.in10
-rw-r--r--science/cdo/files/patch-src-pthread_debug.c4
-rw-r--r--science/cdo/files/patch-src-pthread_debug.h4
6 files changed, 10 insertions, 20 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index fd4ab1e8ab83..4e9281e010c6 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= cdo
-PORTVERSION= 1.0.8
+PORTVERSION= 1.0.9
CATEGORIES= science
MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
http://sunpoet.net/distfiles/
diff --git a/science/cdo/distinfo b/science/cdo/distinfo
index c5bfe8b54e85..c9b8dbdd25a3 100644
--- a/science/cdo/distinfo
+++ b/science/cdo/distinfo
@@ -1,3 +1,3 @@
-MD5 (cdo-1.0.8.tar.gz) = 7d6a10374ee844df5882a8c9b3c16feb
-SHA256 (cdo-1.0.8.tar.gz) = 5796a6639f128b3d255cdd65dbfeb91a66c5478a37b7e05bc2d8f9573480a6b4
-SIZE (cdo-1.0.8.tar.gz) = 2372654
+MD5 (cdo-1.0.9.tar.gz) = daec09bb72336a6838f624d56bc57beb
+SHA256 (cdo-1.0.9.tar.gz) = 2d9df55c50caa7e7a8d8245c772b2242b79c4e770c272f78dcf9ba95b380946f
+SIZE (cdo-1.0.9.tar.gz) = 2383922
diff --git a/science/cdo/files/patch-src-cdo_pthread.c b/science/cdo/files/patch-src-cdo_pthread.c
index f19dfa3ab61e..62c65884d54b 100644
--- a/science/cdo/files/patch-src-cdo_pthread.c
+++ b/science/cdo/files/patch-src-cdo_pthread.c
@@ -1,5 +1,5 @@
---- src/cdo_pthread.c.orig Wed Mar 22 22:04:18 2006
-+++ src/cdo_pthread.c Fri Jun 29 00:18:34 2007
+--- src/cdo_pthread.c.orig 2007-08-29 17:15:32.000000000 +0800
++++ src/cdo_pthread.c 2007-10-25 16:30:35.000000000 +0800
@@ -32,8 +32,10 @@
{
#if defined (HAVE_LIBPTHREAD)
diff --git a/science/cdo/files/patch-src-config.h.in b/science/cdo/files/patch-src-config.h.in
deleted file mode 100644
index 99883663e4c3..000000000000
--- a/science/cdo/files/patch-src-config.h.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/config.h.in.orig Wed Apr 18 16:24:45 2007
-+++ src/config.h.in Fri Jun 29 00:18:34 2007
-@@ -107,3 +107,7 @@
-
- /* Define for large files, on AIX-style hosts. */
- #undef _LARGE_FILES
-+
-+#if defined (HAVE_UNISTD_H)
-+#include <unistd.h>
-+#endif
diff --git a/science/cdo/files/patch-src-pthread_debug.c b/science/cdo/files/patch-src-pthread_debug.c
index 73561eaedd61..b5e5c9a018e7 100644
--- a/science/cdo/files/patch-src-pthread_debug.c
+++ b/science/cdo/files/patch-src-pthread_debug.c
@@ -1,5 +1,5 @@
---- src/pthread_debug.c.orig Mon May 14 14:30:15 2007
-+++ src/pthread_debug.c Fri Jun 29 00:24:12 2007
+--- src/pthread_debug.c.orig 2007-05-14 14:30:15.000000000 +0800
++++ src/pthread_debug.c 2007-10-25 16:30:35.000000000 +0800
@@ -77,6 +77,7 @@
}
diff --git a/science/cdo/files/patch-src-pthread_debug.h b/science/cdo/files/patch-src-pthread_debug.h
index 94cfd2e67089..f4ea67d9892e 100644
--- a/science/cdo/files/patch-src-pthread_debug.h
+++ b/science/cdo/files/patch-src-pthread_debug.h
@@ -1,5 +1,5 @@
---- src/pthread_debug.h.orig Wed Feb 15 21:22:38 2006
-+++ src/pthread_debug.h Fri Jun 29 00:18:34 2007
+--- src/pthread_debug.h.orig 2006-02-15 21:22:38.000000000 +0800
++++ src/pthread_debug.h 2007-10-25 16:30:35.000000000 +0800
@@ -15,8 +15,10 @@
void Pthread_cond_wait(const char *caller, pthread_cond_t *cond, pthread_mutex_t *mutex);