aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-06-15 21:49:52 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-06-15 21:49:52 +0000
commit8abcfe50b78fe5bcb3d875ebf4cd1f90c4b2d3dd (patch)
treea31fd8191f701d728343930164a4265eb30f59f9 /science
parent7a5ece0d9a4de3acf36d6b708cc234ac91284131 (diff)
Notes
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/files/patch-CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/science/avogadro/files/patch-CMakeLists.txt b/science/avogadro/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..afc08f2eb271
--- /dev/null
+++ b/science/avogadro/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+Explicitly look for X11 when using it.
+
+This fixes the build with CMake 3.2, whose FindOpenGL.cmake stopped
+calling find_package(X11).
+
+Instead, do that ourselves when Q_WS_X11 is true, since that is when we
+already try to link against libX11.
+
+Sent upstream: https://github.com/cryos/avogadro/pull/13
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -230,6 +230,10 @@ if(NOT Linguist_FOUND)
+ message(WARNING " Qt4 Linguist not found, please install it if you want Avogadro translations")
+ endif()
+
++if(Q_WS_X11)
++ find_package(X11 REQUIRED) # avogadro/src/main.cpp calls XInitThread().
++endif()
++
+ find_package(Eigen3) # find and setup Eigen3 if available
+ if(NOT EIGEN3_FOUND)
+ message(STATUS "Cannot find Eigen3, trying Eigen2")