aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-09-12 23:32:38 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-09-12 23:32:38 +0000
commitd5bc5b5493aa731d8b56abf25bffc7782fedf580 (patch)
tree37f4dcf818f98fe563871634626be5715fc0bbd3 /science
parent6559855145a439fd3b697fb582522f2856d80365 (diff)
downloadports-d5bc5b5493aa731d8b56abf25bffc7782fedf580.tar.gz
ports-d5bc5b5493aa731d8b56abf25bffc7782fedf580.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/silo/Makefile36
-rw-r--r--science/silo/distinfo4
-rw-r--r--science/silo/pkg-descr2
-rw-r--r--science/silo/pkg-plist3
4 files changed, 20 insertions, 25 deletions
diff --git a/science/silo/Makefile b/science/silo/Makefile
index 1ab765131555..a6bc89d10c9c 100644
--- a/science/silo/Makefile
+++ b/science/silo/Makefile
@@ -2,57 +2,49 @@
# $FreeBSD$
PORTNAME= silo
-PORTVERSION= 4.9.1
+PORTVERSION= 4.10
DISTVERSIONSUFFIX= -bsd
-PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= https://wci.llnl.gov/codes/${PORTNAME}/silo-${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Mesh and field I/O library and scientific database
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-OPTIONS_DEFINE= HDF5 PYTHON
-OPTIONS_RADIO= EXCLUSIVE
-OPTIONS_RADIO_EXCLUSIVE= FORTRAN QT4
-OPTIONS_DEFAULT= QT4
-
-OPTIONS_SUB= yes
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --disable-static
INSTALL_TARGET= install-strip
USES= gmake libtool readline
USE_LDCONFIG= yes
+OPTIONS_DEFINE= FORTRAN HDF5 PYTHON QT4
+OPTIONS_DEFAULT= HDF5
+OPTIONS_SUB= yes
+
FORTRAN_CONFIGURE_ENABLE= fortran
-FORTRAN_USE= FORTRAN=yes
+FORTRAN_USES= fortran
+
+HDF5_LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
+HDF5_CONFIGURE_ON= --with-hdf5=${LOCALBASE}/include,${LOCALBASE}/lib
+HDF5_PLIST_SUB= SUFX_HDF5="h5"
+HDF5_PLIST_SUB_OFF= SUFX_HDF5=""
PYTHON_CONFIGURE_ENABLE= pythonmodule
-PYTHON_USE= PYTHON=yes
+PYTHON_USES= python:2
QT4_USE= XORG=xext,xi,xmu,xt \
QT4=gui,linguist_build,moc_build,uic_build
QT4_CONFIGURE_ON= --with-Qt-dir=${QT_PREFIX} \
--with-Qt-lib="QtGui -lQtCore"
+QT4_CONFIGURE_ENABLE= silex
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MHDF5}
-LIB_DEPENDS+= libhdf5.so:${PORTSDIR}/science/hdf5
-CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}/include,${LOCALBASE}/lib
-PLIST_SUB+= SUFX_HDF5="h5"
-.else
-PLIST_SUB+= SUFX_HDF5=""
-.endif
-
.if ${PORT_OPTIONS:MQT4}
QT_NONSTANDARD= yes
DESKTOP_ENTRIES="Silex" "Silex browser for Silo files" "" "silex" "" true
-.else
-CONFIGURE_ARGS+= --disable-silex
.endif
post-extract:
diff --git a/science/silo/distinfo b/science/silo/distinfo
index 1cd1d332aea8..20ccf8986d89 100644
--- a/science/silo/distinfo
+++ b/science/silo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (silo-4.9.1-bsd.tar.gz) = 7d19f570309d0c235171e39f5b726abc77a3093227db900a59473b1762e82313
-SIZE (silo-4.9.1-bsd.tar.gz) = 11994742
+SHA256 (silo-4.10-bsd.tar.gz) = e801f2c86de8e42059c09b2a274285ad8d30da1fff4134e359fadf70fd07aca0
+SIZE (silo-4.10-bsd.tar.gz) = 13067090
diff --git a/science/silo/pkg-descr b/science/silo/pkg-descr
index 833db3d95ee5..f31a1c06b2d6 100644
--- a/science/silo/pkg-descr
+++ b/science/silo/pkg-descr
@@ -5,4 +5,4 @@ developed applications running on disparate computing platforms.
Consequently, Silo facilitates the development of general purpose tools
for processing scientific data.
-WWW: https://wci.llnl.gov/codes/silo/
+WWW: https://wci.llnl.gov/simulation/computer-codes/silo
diff --git a/science/silo/pkg-plist b/science/silo/pkg-plist
index 45d9d2763fa2..61a0d7db20ff 100644
--- a/science/silo/pkg-plist
+++ b/science/silo/pkg-plist
@@ -6,6 +6,9 @@ bin/silofile
include/ioperf.h
include/pmpio.h
include/silo.h
+include/silo_exports.h
+include/silo_f77.inc
+include/silo_f9x.inc
include/silo.inc
%%PYTHON%%%%PYTHON_SITELIBDIR%%/Silo.so
lib/libsilo%%SUFX_HDF5%%.so