aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-06-16 16:05:28 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-06-16 16:05:28 +0000
commite19903f0aea4d3e3b020dfeb7917e5da969abe6f (patch)
treeaf3dcd22e084ce9821b354f102726fb6b290181e /science
parenta8386f0b2645ad78a65832daf838a5a141c4e907 (diff)
downloadports-e19903f0aea4d3e3b020dfeb7917e5da969abe6f.tar.gz
ports-e19903f0aea4d3e3b020dfeb7917e5da969abe6f.zip
Clean up LIB_DEPENDS
Notes
Notes: svn path=/head/; revision=504353
Diffstat (limited to 'science')
-rw-r--r--science/coot/Makefile2
-rw-r--r--science/lammps/Makefile2
-rw-r--r--science/liggghts/Makefile2
-rw-r--r--science/molscript/Makefile2
-rw-r--r--science/octopus/Makefile2
-rw-r--r--science/teem/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/science/coot/Makefile b/science/coot/Makefile
index 8c7264176e12..5f18ccd6b5d8 100644
--- a/science/coot/Makefile
+++ b/science/coot/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libccp4c.so:science/libccp4 \
libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libgsl.so:math/gsl \
libmmdb2.so:science/mmdb2 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsfftw.so:math/fftw-float \
libssm.so:science/libssm
RUN_DEPENDS= bash:shells/bash
diff --git a/science/lammps/Makefile b/science/lammps/Makefile
index 6c9434298b43..bc6cdd95bff1 100644
--- a/science/lammps/Makefile
+++ b/science/lammps/Makefile
@@ -42,7 +42,7 @@ JPEG_CMAKE_BOOL= WITH_JPEG
JPEG_USES= jpeg
PNG_CMAKE_BOOL= WITH_PNG
-PNG_LIB_DEPENDS= libpng16.so:graphics/png
+PNG_LIB_DEPENDS= libpng.so:graphics/png
GZIP_CMAKE_BOOL= WITH_GZIP
diff --git a/science/liggghts/Makefile b/science/liggghts/Makefile
index b6eb633e7b38..c9bbce6aa1a4 100644
--- a/science/liggghts/Makefile
+++ b/science/liggghts/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= gsed:textproc/gsed
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
libmpi.so:net/openmpi \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libvtkViewsCore-8.1.so:math/vtk8
diff --git a/science/molscript/Makefile b/science/molscript/Makefile
index 6ed86f2e41db..15c2d11aa609 100644
--- a/science/molscript/Makefile
+++ b/science/molscript/Makefile
@@ -10,7 +10,7 @@ COMMENT= Display 3D molecules in schematic and detailed representations
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
-LIB_DEPENDS= libpng16.so:graphics/png
+LIB_DEPENDS= libpng.so:graphics/png
RUN_DEPENDS= render:graphics/raster3d # molscript use requires the executable 'render' to be present
USES= gl gmake jpeg localbase:ldflags
diff --git a/science/octopus/Makefile b/science/octopus/Makefile
index 3a4440b0d04c..b303ebccddd6 100644
--- a/science/octopus/Makefile
+++ b/science/octopus/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libarpack.so:math/arpack-ng \
libgsl.so:math/gsl \
liblapack.so:math/lapack \
libnlopt.so:math/nlopt \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsymspg.so:science/spglib \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp \
diff --git a/science/teem/Makefile b/science/teem/Makefile
index 8859e9b50e6a..961f8e6be805 100644
--- a/science/teem/Makefile
+++ b/science/teem/Makefile
@@ -12,7 +12,7 @@ COMMENT= Libraries for representing, processing and visualizing scientific data
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libpng16.so:graphics/png
+LIB_DEPENDS= libpng.so:graphics/png
USES= cmake
USE_LDCONFIG= yes