aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-09-28 10:56:15 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-09-28 10:56:15 +0000
commit5dc807943762020fbd9c3774c997a7e492d1ff0f (patch)
treea6c324228aa096d4606a4eb57325f3090d103edc /science
parentdcb57b76438d6abc8037ba07c4937349a719372d (diff)
downloadports-5dc807943762020fbd9c3774c997a7e492d1ff0f.tar.gz
ports-5dc807943762020fbd9c3774c997a7e492d1ff0f.zip
science/afni: Remove dependency on libXp
Remove dependency on libXp from science/afni, it is not needed, and libXp is being deprecated. Remove deprecation from science/afni
Notes
Notes: svn path=/head/; revision=513115
Diffstat (limited to 'science')
-rw-r--r--science/afni/Makefile6
-rw-r--r--science/afni/files/Makefile4
2 files changed, 4 insertions, 6 deletions
diff --git a/science/afni/Makefile b/science/afni/Makefile
index deb2013893d4..ea801377e0ad 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -3,14 +3,12 @@
PORTNAME= afni
DISTVERSIONPREFIX= AFNI_
DISTVERSION= 19.1.20
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science biology graphics perl5 python
MAINTAINER= jwb@FreeBSD.org
COMMENT= Advanced Functional Neuro Imaging
-DEPRECATED= Depends on deprecated libXp
-
LICENSE= GPLv2
BROKEN_sparc64= Does not compile: "undefined reference to '_mcount'"
@@ -47,7 +45,7 @@ SHEBANG_FILES= scripts_install/* \
pkundu/meica.libs/*/*/*.py
USE_GL= gl glu
-USE_XORG= x11 xext xi xmu xp xt
+USE_XORG= x11 xext xi xmu xt
MAKE_ENV= CC="${CC}" R_SHARE_DIR=${LOCALBASE}/lib/R/share
MAKE_JOBS_UNSAFE=yes
diff --git a/science/afni/files/Makefile b/science/afni/files/Makefile
index 9c6e28e2e4d4..1a413bdff40c 100644
--- a/science/afni/files/Makefile
+++ b/science/afni/files/Makefile
@@ -96,7 +96,7 @@ LIBDIR = ${INSTALLDIR}
# for dynamic linking
-LLIBS = -lmri -lf2c -lXm -lXp -lXpm -lXext -lXmu -lXt -lX11 -lm $(LZLIB) $(LGIFTI)
+LLIBS = -lmri -lf2c -lXm -lXpm -lXext -lXmu -lXt -lX11 -lm $(LZLIB) $(LGIFTI)
# vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
# For suma (NO STATIC LINKING OF GL libs)
@@ -108,7 +108,7 @@ SUMA_INCLUDE_PATH = -IGLw_local -I${LOCALBASE}/include/glib-2.0 -I${LOCALBASE}/l
SUMA_LINK_PATH = -L/usr/lib -L${LOCALBASE}/lib -L../
#use -lGLw if you have libGLw.a or libGLw.so* or
# -lMesaGLw if you have Mesa's version (libMesaGLw*) of libGLw
-SUMA_LINK_LIB = -lXm -lGLws -lGLU -lGL -lXmu -lXp -lXt -lXext -lX11 -lm $(LZLIB) -lxml2 -lexpat
+SUMA_LINK_LIB = -lXm -lGLws -lGLU -lGL -lXmu -lXt -lXext -lX11 -lm $(LZLIB) -lxml2 -lexpat
SUMA_MAKEFILE_NAME = SUMA_Makefile
SUMA_BIN_ARCHIVE = SUMA_FreeBSD.tar
SUMA_GLIB_VER = -2.0