aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-09-30 11:32:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-09-30 11:32:04 +0000
commita7fb56684cfb4762ba9cc3f680f1ccd131939cd3 (patch)
treef724e31062211382105c2e5dc699fb519ed23ef7 /science
parentb7e4d9a7c2cf6de507725ccb0925e56c93123471 (diff)
downloadports-a7fb56684cfb4762ba9cc3f680f1ccd131939cd3.tar.gz
ports-a7fb56684cfb4762ba9cc3f680f1ccd131939cd3.zip
Add PARALLEL option
PR: 237751 Submitted by: yuri
Notes
Notes: svn path=/head/; revision=513366
Diffstat (limited to 'science')
-rw-r--r--science/hdf5/Makefile12
-rw-r--r--science/hdf5/pkg-plist95
2 files changed, 58 insertions, 49 deletions
diff --git a/science/hdf5/Makefile b/science/hdf5/Makefile
index 6773dfc3b9bc..b55aebd5567a 100644
--- a/science/hdf5/Makefile
+++ b/science/hdf5/Makefile
@@ -17,13 +17,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_INSTALL= hdf-4.[0-9]* hdf5-1.6.[0-9]*
OPTIONS_DEFINE= DEBUG EXAMPLES FORTRAN SZIP
-OPTIONS_DEFAULT=SZIP
+OPTIONS_RADIO= SUPPORT
+OPTIONS_RADIO_SUPPORT= CXX PARALLEL
+OPTIONS_DEFAULT=CXX SZIP
OPTIONS_SUB= yes
+PARALLEL_DESC= Parallel support
USES= compiler:c11 libtool localbase tar:bzip2
-CONFIGURE_ARGS= --enable-cxx \
- --enable-hl \
+CONFIGURE_ARGS= --enable-hl \
--enable-instrument \
--enable-strict-format-checks
GNU_CONFIGURE= yes
@@ -34,11 +36,15 @@ USE_LDCONFIG= yes
PORTEXAMPLES= *
+CXX_CONFIGURE_ENABLE= cxx
DEBUG_CONFIGURE_OFF= --enable-build-mode=production
DEBUG_CONFIGURE_ON= --enable-build-mode=debug
FORTRAN_CONFIGURE_ENABLE= fortran
FORTRAN_CONFIGURE_ENV= F9X=${FC}
FORTRAN_USES= fortran
+PARALLEL_CONFIGURE_ENABLE= parallel
+PARALLEL_LDFLAGS= -L${LOCALBASE}/lib -lmpi
+PARALLEL_LIB_DEPENDS= libmpi.so:net/mpich
SZIP_CONFIGURE_ON= --with-szlib=${LOCALBASE}
SZIP_LIB_DEPENDS= libsz.so:science/szip
diff --git a/science/hdf5/pkg-plist b/science/hdf5/pkg-plist
index 9c895672624f..92effeed59b0 100644
--- a/science/hdf5/pkg-plist
+++ b/science/hdf5/pkg-plist
@@ -1,7 +1,7 @@
bin/gif2h5
bin/h52gif
-bin/h5c++
-bin/h5cc
+%%CXX%%bin/h5c++
+%%CXX%%bin/h5cc
bin/h5clear
bin/h5copy
bin/h5debug
@@ -13,6 +13,8 @@ bin/h5import
bin/h5jam
bin/h5ls
bin/h5mkgrp
+%%PARALLEL%%bin/h5pcc
+%%PARALLEL%%bin/h5perf
bin/h5perf_serial
bin/h5redeploy
bin/h5repack
@@ -20,31 +22,32 @@ bin/h5repart
bin/h5stat
bin/h5unjam
bin/h5watch
+%%PARALLEL%%bin/ph5diff
include/H5ACpublic.h
-include/H5AbstractDs.h
+%%CXX%%include/H5AbstractDs.h
include/H5Apublic.h
-include/H5ArrayType.h
-include/H5AtomType.h
-include/H5Attribute.h
-include/H5Classes.h
-include/H5CommonFG.h
-include/H5CompType.h
-include/H5Cpp.h
-include/H5CppDoc.h
+%%CXX%%include/H5ArrayType.h
+%%CXX%%include/H5AtomType.h
+%%CXX%%include/H5Attribute.h
+%%CXX%%include/H5Classes.h
+%%CXX%%include/H5CommonFG.h
+%%CXX%%include/H5CompType.h
+%%CXX%%include/H5Cpp.h
+%%CXX%%include/H5CppDoc.h
include/H5Cpublic.h
include/H5DOpublic.h
include/H5DSpublic.h
-include/H5DaccProp.h
-include/H5DataSet.h
-include/H5DataSpace.h
-include/H5DataType.h
-include/H5DcreatProp.h
+%%CXX%%include/H5DaccProp.h
+%%CXX%%include/H5DataSet.h
+%%CXX%%include/H5DataSpace.h
+%%CXX%%include/H5DataType.h
+%%CXX%%include/H5DcreatProp.h
include/H5Dpublic.h
-include/H5DxferProp.h
-include/H5EnumType.h
+%%CXX%%include/H5DxferProp.h
+%%CXX%%include/H5EnumType.h
include/H5Epubgen.h
include/H5Epublic.h
-include/H5Exception.h
+%%CXX%%include/H5Exception.h
include/H5FDcore.h
include/H5FDdirect.h
include/H5FDfamily.h
@@ -56,42 +59,42 @@ include/H5FDpublic.h
include/H5FDsec2.h
include/H5FDstdio.h
include/H5FDwindows.h
-include/H5FaccProp.h
-include/H5FcreatProp.h
-include/H5File.h
-include/H5FloatType.h
+%%CXX%%include/H5FaccProp.h
+%%CXX%%include/H5FcreatProp.h
+%%CXX%%include/H5File.h
+%%CXX%%include/H5FloatType.h
include/H5Fpublic.h
include/H5Gpublic.h
-include/H5Group.h
+%%CXX%%include/H5Group.h
include/H5IMpublic.h
-include/H5IdComponent.h
-include/H5Include.h
-include/H5IntType.h
+%%CXX%%include/H5IdComponent.h
+%%CXX%%include/H5Include.h
+%%CXX%%include/H5IntType.h
include/H5Ipublic.h
include/H5LDpublic.h
include/H5LTpublic.h
-include/H5LaccProp.h
-include/H5LcreatProp.h
-include/H5Library.h
-include/H5Location.h
+%%CXX%%include/H5LaccProp.h
+%%CXX%%include/H5LcreatProp.h
+%%CXX%%include/H5Library.h
+%%CXX%%include/H5Location.h
include/H5Lpublic.h
include/H5MMpublic.h
-include/H5Object.h
-include/H5OcreatProp.h
+%%CXX%%include/H5Object.h
+%%CXX%%include/H5OcreatProp.h
include/H5Opublic.h
include/H5PLextern.h
include/H5PLpublic.h
include/H5PTpublic.h
-include/H5PacketTable.h
+%%CXX%%include/H5PacketTable.h
include/H5Ppublic.h
-include/H5PredType.h
-include/H5PropList.h
+%%CXX%%include/H5PredType.h
+%%CXX%%include/H5PropList.h
include/H5Rpublic.h
include/H5Spublic.h
-include/H5StrType.h
+%%CXX%%include/H5StrType.h
include/H5TBpublic.h
include/H5Tpublic.h
-include/H5VarLenType.h
+%%CXX%%include/H5VarLenType.h
include/H5Zpublic.h
include/H5api_adpt.h
%%FORTRAN%%include/H5f90i.h
@@ -132,10 +135,10 @@ lib/libhdf5.settings
lib/libhdf5.so
lib/libhdf5.so.103
lib/libhdf5.so.103.1.0
-lib/libhdf5_cpp.a
-lib/libhdf5_cpp.so
-lib/libhdf5_cpp.so.103
-lib/libhdf5_cpp.so.103.1.0
+%%CXX%%lib/libhdf5_cpp.a
+%%CXX%%lib/libhdf5_cpp.so
+%%CXX%%lib/libhdf5_cpp.so.103
+%%CXX%%lib/libhdf5_cpp.so.103.1.0
%%FORTRAN%%lib/libhdf5_fortran.a
%%FORTRAN%%lib/libhdf5_fortran.so
%%FORTRAN%%lib/libhdf5_fortran.so.102
@@ -144,10 +147,10 @@ lib/libhdf5_hl.a
lib/libhdf5_hl.so
lib/libhdf5_hl.so.100
lib/libhdf5_hl.so.100.1.2
-lib/libhdf5_hl_cpp.a
-lib/libhdf5_hl_cpp.so
-lib/libhdf5_hl_cpp.so.100
-lib/libhdf5_hl_cpp.so.100.1.3
+%%CXX%%lib/libhdf5_hl_cpp.a
+%%CXX%%lib/libhdf5_hl_cpp.so
+%%CXX%%lib/libhdf5_hl_cpp.so.100
+%%CXX%%lib/libhdf5_hl_cpp.so.100.1.3
%%FORTRAN%%lib/libhdf5_hl_fortran.a
%%FORTRAN%%lib/libhdf5_hl_fortran.so
%%FORTRAN%%lib/libhdf5hl_fortran.a