aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 14:15:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 14:15:03 +0000
commit44e9f64a275cdae1f2dd4bd1a517f48f9e075a81 (patch)
treec4ea42245d0b053c1a31462b408d6990c18047e0 /science
parent9c8b302188158c6ba8db4af427c7bcb6b2c9452c (diff)
downloadports-44e9f64a275cdae1f2dd4bd1a517f48f9e075a81.tar.gz
ports-44e9f64a275cdae1f2dd4bd1a517f48f9e075a81.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/Makefile4
-rw-r--r--science/bddsolve/Makefile4
-rw-r--r--science/peekabot/Makefile6
3 files changed, 7 insertions, 7 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 25a034313c5a..89a007eaf224 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -13,7 +13,7 @@ COMMENT= Advanced molecular editor and viewer
LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
-LIB_DEPENDS= openbabel:${PORTSDIR}/science/openbabel
+LIB_DEPENDS= libopenbabel.so:${PORTSDIR}/science/openbabel
OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT=PYTHON
@@ -40,7 +40,7 @@ CMAKE_ARGS+= -DENABLE_PYTHON=ON
USE_PYTHON= -2.7
BUILD_DEPENDS+= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:${PORTSDIR}/devel/py-sip
-LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
RUN_DEPENDS+= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:${PORTSDIR}/devel/py-sip
PLIST_SUB+= PYTHON=""
diff --git a/science/bddsolve/Makefile b/science/bddsolve/Makefile
index f011c4f65661..0d8724045fcc 100644
--- a/science/bddsolve/Makefile
+++ b/science/bddsolve/Makefile
@@ -10,8 +10,8 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= ed@FreeBSD.org
COMMENT= BDD-based satisfiability and reachability solver
-LIB_DEPENDS+= bdd:${PORTSDIR}/science/buddy \
- boost_program_options:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS+= libbdd.so:${PORTSDIR}/science/buddy \
+ libboost_program_options.so:${PORTSDIR}/devel/boost-libs
USE_ZIP= yes
NO_WRKSUBDIR= yes
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index 1321a139e025..625af659ae07 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -15,9 +15,9 @@ LICENSE_COMB= multi
BROKEN= Does not build
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs \
- xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
- gtkglextmm-x11-1.2:${PORTSDIR}/x11-toolkits/gtkglextmm
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3 \
+ libgtkglextmm-x11-1.2.so:${PORTSDIR}/x11-toolkits/gtkglextmm
USE_BZIP2= yes
USES= pathfix gmake