aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-02 19:08:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-02 19:08:02 +0000
commit15b3b340c0315180d271b847d5893ea2aeeb263a (patch)
tree5a3b65d592305d6600800da2b9ab4bdf052c9fee /science
parent15dfbde9788981c09ece41b6a11e6a046b2746f7 (diff)
downloadports-15b3b340c0315180d271b847d5893ea2aeeb263a.tar.gz
ports-15b3b340c0315180d271b847d5893ea2aeeb263a.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/vis5d+/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index 48c9142c22dc..f14a04619f82 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= stephen@math.missouri.edu
COMMENT= OpenGL-based volumetric visualization program for scientific datasets
BUILD_DEPENDS= ${LOCALBASE}/lib/libmix.a:${PORTSDIR}/graphics/qslim \
- convert:${PORTSDIR}/graphics/ImageMagick
+ convert:${PORTSDIR}/graphics/ImageMagick \
+ ${LOCALBASE}/include/gfx/gfx.h:${PORTSDIR}/graphics/libgfx
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf \
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
@@ -28,16 +29,14 @@ USE_GL= yes
USE_GNOME= gnometarget gtk12
USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" F77="${F77}" FFLAGS="-fno-range-check"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" F77="${F77}" FFLAGS="-fno-range-check" LIBS="-lgfx"
CONFIGURE_ARGS= --enable-gtk --enable-threads --with-netcdf \
--with-mixkit=${LOCALBASE}/lib/libmix.a --with-x
USE_LDCONFIG= yes
-BROKEN= Does not compile
-
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CFLAGS+= -DMIX_ANSI_IOSTREAMS -fpermissive
+CFLAGS+= -DMIX_ANSI_IOSTREAMS -fPIC -fpermissive
.include <bsd.port.mk>