aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-22 03:38:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-22 03:38:47 +0000
commita941f3b092e9ba36e657e28ac53ee731a55bf2c2 (patch)
treebe97f414dc3638213a68dc0585d30b5df0dc4df0 /science
parentd9e357b6eccda4cb41fd84758d0e6b423b8dcc95 (diff)
downloadports-a941f3b092e9ba36e657e28ac53ee731a55bf2c2.tar.gz
ports-a941f3b092e9ba36e657e28ac53ee731a55bf2c2.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/linsmith/Makefile29
-rw-r--r--science/linsmith/distinfo3
-rw-r--r--science/linsmith/files/carg.c20
-rw-r--r--science/linsmith/files/patch-src-Makefile.in11
-rw-r--r--science/linsmith/pkg-descr21
-rw-r--r--science/linsmith/pkg-plist22
7 files changed, 107 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 9333cffe82b0..55145aa84d6d 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -59,6 +59,7 @@
SUBDIR += libghemical
SUBDIR += libsvm
SUBDIR += libsvm-python
+ SUBDIR += linsmith
SUBDIR += mayavi
SUBDIR += mbdyn
SUBDIR += mcstas
diff --git a/science/linsmith/Makefile b/science/linsmith/Makefile
new file mode 100644
index 000000000000..5d5fee9bb73c
--- /dev/null
+++ b/science/linsmith/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection Makefile for: linsmith
+# Date created: Dec 22, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= linsmith
+PORTVERSION= 0.99.3
+CATEGORIES= science
+MASTER_SITES= SF
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Smith charting program
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+USE_GNOME= pkgconfig libgnomeprint libgnomeui libxml2
+USE_ICONV= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${CP} ${FILESDIR}/carg.c ${WRKSRC}/src
+
+.include <bsd.port.mk>
diff --git a/science/linsmith/distinfo b/science/linsmith/distinfo
new file mode 100644
index 000000000000..406fd45b6b78
--- /dev/null
+++ b/science/linsmith/distinfo
@@ -0,0 +1,3 @@
+MD5 (linsmith-0.99.3.tar.gz) = 27fa723af8c8cfc3337904afcf54fbdf
+SHA256 (linsmith-0.99.3.tar.gz) = 978b39819d3f0bd2f2c88201082f5bcce39574bf339f1d025797ae2ccb3409ff
+SIZE (linsmith-0.99.3.tar.gz) = 957032
diff --git a/science/linsmith/files/carg.c b/science/linsmith/files/carg.c
new file mode 100644
index 000000000000..0e021032c0dd
--- /dev/null
+++ b/science/linsmith/files/carg.c
@@ -0,0 +1,20 @@
+/* carg.f -- translated by f2c (version 20000817).
+*/
+#include <math.h>
+#include <complex.h>
+
+double carg(complex z__)
+{
+ /* System generated locals */
+ double ret_val;
+
+/* april 1977 version. w. fullerton, c3, los alamos scientific lab. */
+
+ ret_val = (float)0.;
+ if (creal(z__) != (float)0. || cimag(z__) != (float)0.) {
+ ret_val = atan2(cimag(z__), creal(z__));
+ }
+
+ return ret_val;
+} /* carg */
+
diff --git a/science/linsmith/files/patch-src-Makefile.in b/science/linsmith/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..16f5bb63355e
--- /dev/null
+++ b/science/linsmith/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Tue Nov 7 03:27:23 2006
++++ src/Makefile.in Fri Dec 22 11:33:11 2006
+@@ -52,7 +52,7 @@
+ element.$(OBJEXT) remote.$(OBJEXT) load.$(OBJEXT) \
+ load_rx.$(OBJEXT) load_nb.$(OBJEXT) log.$(OBJEXT) \
+ support.$(OBJEXT) printer.$(OBJEXT) interface.$(OBJEXT) \
+- callbacks.$(OBJEXT)
++ callbacks.$(OBJEXT) carg.$(OBJEXT)
+ linsmith_OBJECTS = $(am_linsmith_OBJECTS)
+ am__DEPENDENCIES_1 =
+ linsmith_DEPENDENCIES = $(am__DEPENDENCIES_1)
diff --git a/science/linsmith/pkg-descr b/science/linsmith/pkg-descr
new file mode 100644
index 000000000000..89647d3f4783
--- /dev/null
+++ b/science/linsmith/pkg-descr
@@ -0,0 +1,21 @@
+linSmith is a Smith Charting program, mainly designed for educational use.
+As such, there is an emphasis on capabilities that improve the 'showing the
+effect of'-style of operation.
+
+It's main features are:
+ * Definition of multiple load impedances (at different frequencies)
+ * Addition of discrete (L, C, parallel and series LC, and transformer) and
+ line components (open and closed stubs, line segments)
+ * Connection in series and parallel
+ * Easy experimentation with values using scrollbars
+ * A 'virtual' component switches from impedance to admittance to help
+ explaining (or understanding) parallel components
+ * The chart works in real impedances (not normalized ones)
+ * Direct view of the result on the screen
+ * Ability to generate publication quality Postscript output
+ * A 'log' file with textual results at each intermediate step
+ * Load and circuit configuration is stored separately, permitting several
+ solutions without re-defining the other (this may actually change to
+ single files - I'm not quite convinced here)
+
+WWW: http://linsmith.sourceforge.net/
diff --git a/science/linsmith/pkg-plist b/science/linsmith/pkg-plist
new file mode 100644
index 000000000000..a6a89d191dae
--- /dev/null
+++ b/science/linsmith/pkg-plist
@@ -0,0 +1,22 @@
+bin/linsmith
+share/locale/de/LC_MESSAGES/linsmith.mo
+share/locale/es/LC_MESSAGES/linsmith.mo
+share/locale/hu/LC_MESSAGES/linsmith.mo
+share/locale/it/LC_MESSAGES/linsmith.mo
+share/locale/sv/LC_MESSAGES/linsmith.mo
+share/locale/zh/LC_MESSAGES/linsmith.mo
+share/pixmaps/linsmith/Makefile.am~
+share/pixmaps/linsmith/smith4.png
+share/pixmaps/linsmith/smithent.png
+@dirrm share/pixmaps/linsmith
+%%DATADIR%%/6-1.circ
+%%DATADIR%%/6-1.load
+%%DATADIR%%/6-4.circ
+%%DATADIR%%/6-4.load
+%%DATADIR%%/6-5.circ
+%%DATADIR%%/6-5.load
+%%DATADIR%%/6-6.circ
+%%DATADIR%%/6-6.load
+%%DATADIR%%/conv0809
+%%DATADIR%%/nb_40.load
+@dirrm %%DATADIR%%