aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-05-18 15:08:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-05-18 15:08:58 +0000
commitd0f33fd4a70e4465865a1979380d756a52970f1d (patch)
tree1016f50d3bc25c3967030195050b0600296ebbe4 /science
parent55af5f30cd2f08aa4cf23f924f03434f134b6a52 (diff)
downloadports-d0f33fd4a70e4465865a1979380d756a52970f1d.tar.gz
ports-d0f33fd4a70e4465865a1979380d756a52970f1d.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/gromacs/Makefile5
-rw-r--r--science/gwyddion/Makefile4
3 files changed, 7 insertions, 6 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index e35e5435f3f6..9c533191a248 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -97,8 +97,8 @@ CONFIGURE_ARGS+=--with-python=no
WITH_FFTW3= yes
.endif
.if defined(WITH_FFTW3)
-LIB_DEPENDS+= fftw3.4:${PORTSDIR}/math/fftw3 \
- fftw3f.4:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS+= fftw3.5:${PORTSDIR}/math/fftw3 \
+ fftw3f.5:${PORTSDIR}/math/fftw3-float
CONFIGURE_ARGS+=--with-fftw=${LOCALBASE}
.endif
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index e75c6b880b27..326c53c28a9e 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gromacs
PORTVERSION= 4.0.3
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
@@ -47,9 +48,9 @@ IGNORE= Cannot build with MPICH and OpenMPI support. Run 'make config' again an
.if !defined(WITHOUT_FFTW3)
CONFIGURE_ARGS+= --with-fft=fftw3
. if defined(WITH_FLOAT)
-LIB_DEPENDS+= fftw3f.4:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS+= fftw3f.5:${PORTSDIR}/math/fftw3-float
. else
-LIB_DEPENDS+= fftw3.4:${PORTSDIR}/math/fftw3
+LIB_DEPENDS+= fftw3.5:${PORTSDIR}/math/fftw3
. endif
.else
. if defined(WITH_FFTW2)
diff --git a/science/gwyddion/Makefile b/science/gwyddion/Makefile
index e508a4c0d123..3b860b5af8ef 100644
--- a/science/gwyddion/Makefile
+++ b/science/gwyddion/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gwyddion
PORTVERSION= 2.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +20,7 @@ COMMENT= A gtk2 based SPM data visualization and analysis tool
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext \
- fftw3.4:${PORTSDIR}/math/fftw3
+ fftw3.5:${PORTSDIR}/math/fftw3
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \