aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2017-12-13 03:34:37 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2017-12-13 03:34:37 +0000
commitda78f03134b243f4527b1429b588516c08aa8f6c (patch)
treebb8cac74ff2973badc8005a25c5c3e64ad769d96 /science
parentd01583d309c489224b9405759813a6f041e39ccc (diff)
downloadports-da78f03134b243f4527b1429b588516c08aa8f6c.tar.gz
ports-da78f03134b243f4527b1429b588516c08aa8f6c.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/paraview/Makefile19
-rw-r--r--science/paraview/files/patch-Plugins_CDIReader_cdilib.c2
-rw-r--r--science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_ncvalues.h20
-rw-r--r--science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_netcdfcpp.h70
-rw-r--r--science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfDsmComm.cxx20
5 files changed, 121 insertions, 10 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index b08794248b46..b348124c0086 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= paraview
-PORTVERSION= 5.2.0
-PORTREVISION= 2
+DISTVERSION= 5.2.0
+PORTREVISION= 3
CATEGORIES= science graphics
MASTER_SITES= http://www.paraview.org/files/v${VERMAJORMINOR}/
DISTNAME= ParaView-v${PORTVERSION}
@@ -16,7 +16,7 @@ LICENSE_NAME= ParaView_License
LICENSE_FILE= ${PATCH_WRKSRC}/License_v1.2.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:math/py-matplotlib
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:math/py-matplotlib@${PY_FLAVOR}
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
@@ -29,20 +29,21 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libdrm.so:graphics/libdrm \
libfontconfig.so:x11-fonts/fontconfig
RUN_DEPENDS= bash:shells/bash \
- ${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:math/py-matplotlib
+ ${PYTHON_SITELIBDIR}/matplotlib/pyplot.py:math/py-matplotlib@${PY_FLAVOR}
CONFLICTS_BUILD= protobuf*
+USES= alias desktop-file-utils cmake:outsource jpeg python:2.7 shebangfix
USE_QT4= qmake_build moc_build rcc_build uic_build \
linguisttools_build assistant_run qt3support \
corelib dbus designer gui help-tools network script \
sql svg xml webkit assistantclient clucene \
xmlpatterns xmlpatterns-tool help
-USE_GL= gl
-USE_XORG= x11 xt xext ice xdmcp xau xcb xfixes xdamage xxf86vm xrender sm
+USE_GL= gl glu
+USE_XORG= x11 xt xext ice xdmcp xau xcb xfixes xdamage xxf86vm xrender sm dri3proto
USE_LDCONFIG= yes
USE_GSTREAMER= yes
-USES= alias desktop-file-utils cmake:outsource jpeg python:2.7 shebangfix
+
INSTALLS_ICONS= yes
CMAKE_ARGS+= -DBUILD_SHARED_LIBS="ON" \
@@ -104,9 +105,9 @@ CMAKE2INST= ParaViewConfig.cmake \
LIB_INSTDIR= ${PREFIX}/lib/${PORTNAME}-${VERMAJORMINOR}
pre-configure:
- ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
${PATCH_WRKSRC}/VTK/IO/Image/vtkPNGReader.cxx
- ${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
${PATCH_WRKSRC}/VTK/Utilities/Maintenance/vtk_site_history.py
post-install:
diff --git a/science/paraview/files/patch-Plugins_CDIReader_cdilib.c b/science/paraview/files/patch-Plugins_CDIReader_cdilib.c
index 4a22d79d1e68..d2788fc12d43 100644
--- a/science/paraview/files/patch-Plugins_CDIReader_cdilib.c
+++ b/science/paraview/files/patch-Plugins_CDIReader_cdilib.c
@@ -1,4 +1,4 @@
---- Plugins/CDIReader/cdilib.c.orig 2016-11-19 09:40:46 UTC
+--- Plugins/CDIReader/cdilib.c.orig 2016-11-14 15:41:57 UTC
+++ Plugins/CDIReader/cdilib.c
@@ -47,7 +47,7 @@
#define _XOPEN_SOURCE 600
diff --git a/science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_ncvalues.h b/science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_ncvalues.h
new file mode 100644
index 000000000000..d45fc3dee545
--- /dev/null
+++ b/science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_ncvalues.h
@@ -0,0 +1,20 @@
+--- VTK/ThirdParty/netcdf/vtknetcdf/cxx/ncvalues.h.orig 2016-11-14 15:41:57 UTC
++++ VTK/ThirdParty/netcdf/vtknetcdf/cxx/ncvalues.h
+@@ -65,7 +65,7 @@ static const double ncBad_double = NC_FI
+ #define NcVal(TYPE) makename2(NcValues_,TYPE)
+
+ #define NcValuesdeclare(TYPE) \
+-class MSCPP_EXTRA NcVal(TYPE) : public NcValues \
++class NcVal(TYPE) : public NcValues \
+ { \
+ public: \
+ NcVal(TYPE)( void ); \
+@@ -237,7 +237,7 @@ char* NcVal(TYPE)::as_string( long n ) c
+ return s; \
+ }
+
+-class MSCPP_EXTRA NcValues // ABC for value blocks
++class NcValues // ABC for value blocks
+ {
+ public:
+ NcValues( void );
diff --git a/science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_netcdfcpp.h b/science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_netcdfcpp.h
new file mode 100644
index 000000000000..46f4695faeda
--- /dev/null
+++ b/science/paraview/files/patch-VTK_ThirdParty_netcdf_vtknetcdf_cxx_netcdfcpp.h
@@ -0,0 +1,70 @@
+--- VTK/ThirdParty/netcdf/vtknetcdf/cxx/netcdfcpp.h.orig 2016-11-14 15:41:57 UTC
++++ VTK/ThirdParty/netcdf/vtknetcdf/cxx/netcdfcpp.h
+@@ -21,17 +21,17 @@
+ typedef const char* NcToken; // names for netCDF objects
+ typedef unsigned int NcBool; // many members return 0 on failure
+
+-class MSCPP_EXTRA NcDim; // dimensions
+-class MSCPP_EXTRA NcVar; // variables
+-class MSCPP_EXTRA NcAtt; // attributes
+-class MSCPP_EXTRA NcError;
++class NcDim; // dimensions
++class NcVar; // variables
++class NcAtt; // attributes
++class NcError;
+
+ /*
+ * ***********************************************************************
+ * A netCDF file.
+ * ***********************************************************************
+ */
+-class MSCPP_EXTRA NcFile
++class NcFile
+ {
+ public:
+
+@@ -146,7 +146,7 @@ class MSCPP_EXTRA NcFile
+ * of an open netCDF file.
+ * **********************************************************************
+ */
+-class MSCPP_EXTRA NcDim
++class NcDim
+ {
+ public:
+ NcToken name( void ) const;
+@@ -178,7 +178,7 @@ class MSCPP_EXTRA NcDim
+ * components of an open netCDF file.
+ * **********************************************************************
+ */
+-class MSCPP_EXTRA NcTypedComponent
++class NcTypedComponent
+ {
+ public:
+ virtual ~NcTypedComponent( void ) {}
+@@ -216,7 +216,7 @@ class MSCPP_EXTRA NcTypedComponent
+ * a shape, given by a list of dimensions
+ * **********************************************************************
+ */
+-class MSCPP_EXTRA NcVar : public NcTypedComponent
++class NcVar : public NcTypedComponent
+ {
+ public:
+ virtual ~NcVar( void );
+@@ -414,7 +414,7 @@ class MSCPP_EXTRA NcVar : public NcTyped
+ * associated with a specific variable, or are global to the file.
+ * **********************************************************************
+ */
+-class MSCPP_EXTRA NcAtt : public NcTypedComponent
++class NcAtt : public NcTypedComponent
+ {
+ public:
+ virtual ~NcAtt( void );
+@@ -447,7 +447,7 @@ class MSCPP_EXTRA NcAtt : public NcTyped
+ * which time the previous error-handling behavior is restored.
+ * **********************************************************************
+ */
+-class MSCPP_EXTRA NcError {
++class NcError {
+ public:
+ enum Behavior {
+ silent_nonfatal = 0,
diff --git a/science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfDsmComm.cxx b/science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfDsmComm.cxx
new file mode 100644
index 000000000000..e4e4b5e63d82
--- /dev/null
+++ b/science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfDsmComm.cxx
@@ -0,0 +1,20 @@
+--- VTK/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfDsmComm.cxx.orig 2016-11-14 15:41:57 UTC
++++ VTK/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfDsmComm.cxx
+@@ -52,7 +52,7 @@ XdmfDsmComm::Receive(XdmfDsmMsg *Msg){
+ XdmfErrorMessage("Cannot Receive Message of Length = " << Msg->Length);
+ return(XDMF_FAIL);
+ }
+- if(Msg->Data <= 0 ){
++ if(Msg->Data == 0 ){
+ XdmfErrorMessage("Cannot Receive Message into Data Buffer = " << Msg->Length);
+ return(XDMF_FAIL);
+ }
+@@ -66,7 +66,7 @@ XdmfDsmComm::Send(XdmfDsmMsg *Msg){
+ XdmfErrorMessage("Cannot Send Message of Length = " << Msg->Length);
+ return(XDMF_FAIL);
+ }
+- if(Msg->Data <= 0 ){
++ if(Msg->Data == 0 ){
+ XdmfErrorMessage("Cannot Send Message from Data Buffer = " << Msg->Length);
+ return(XDMF_FAIL);
+ }