aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-02 00:39:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-02 00:39:14 +0000
commit5135538c0caa3e1e8152a718ed54ca3c1bea9891 (patch)
tree33cb91700c7baa2e734f729da3169ba36358b26b /science
parent7f5104db92521999244fbc6eba5e51944d6604da (diff)
downloadports-5135538c0caa3e1e8152a718ed54ca3c1bea9891.tar.gz
ports-5135538c0caa3e1e8152a718ed54ca3c1bea9891.zip
science/wannier90: Rename the shared library libwannier90.so -> libwannier.so to match the static library name that it creates
Project makefiles have LIBRARY=libwannier.a
Notes
Notes: svn path=/head/; revision=559899
Diffstat (limited to 'science')
-rw-r--r--science/wannier90/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/science/wannier90/Makefile b/science/wannier90/Makefile
index 15017a7baea7..4e6354c08ffe 100644
--- a/science/wannier90/Makefile
+++ b/science/wannier90/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wannier90
DISTVERSIONPREFIX= v
DISTVERSION= 3.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -29,8 +29,8 @@ TEST_TARGET= tests # most tests using --numprocs=4 fail: https://github.com/wann
PLIST_FILES= bin/postw90.x \
bin/w90chk2chk.x \
bin/wannier90.x \
- lib/libwannier90.so \
- lib/libwannier90.so.0
+ lib/libwannier.so \
+ lib/libwannier.so.0
post-patch:
@${REINPLACE_CMD} 's|F90 = gfortran|&${GCC_DEFAULT}|' ${WRKSRC}/config/make.inc.gfort
@@ -41,7 +41,7 @@ do-install:
.for p in wannier90.x postw90.x w90chk2chk.x
${INSTALL_PROGRAM} ${WRKSRC}/${p} ${STAGEDIR}${PREFIX}/bin/${p}
.endfor
- ${INSTALL_LIB} ${WRKSRC}/src/obj/libwannier.so ${STAGEDIR}${PREFIX}/lib/libwannier90.so.0
- ${LN} -sf libwannier90.so.0 ${STAGEDIR}${PREFIX}/lib/libwannier90.so
+ ${INSTALL_LIB} ${WRKSRC}/src/obj/libwannier.so ${STAGEDIR}${PREFIX}/lib/libwannier.so.0
+ ${LN} -sf libwannier.so.0 ${STAGEDIR}${PREFIX}/lib/libwannier.so
.include <bsd.port.mk>