aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
commitaa7a6c429ea62d972467d6755fa7a6f52256b452 (patch)
tree3c451883d3bd4d2ffe401b2b6aee58825505d145 /science
parentc3b3e6a10d663bc2672cdd4bf46943046d03ecba (diff)
downloadports-aa7a6c429ea62d972467d6755fa7a6f52256b452.tar.gz
ports-aa7a6c429ea62d972467d6755fa7a6f52256b452.zip
Drop python 2.7 support from a few ports
With hat: portmgr
Notes
Notes: svn path=/head/; revision=559531
Diffstat (limited to 'science')
-rw-r--r--science/py-DendroPy/Makefile2
-rw-r--r--science/py-cdo/Makefile2
-rw-r--r--science/py-chainer/Makefile2
-rw-r--r--science/py-coards/Makefile2
-rw-r--r--science/py-dlib/Makefile2
-rw-r--r--science/py-geolinks/Makefile2
-rw-r--r--science/py-geomet/Makefile2
-rw-r--r--science/py-gsd/Makefile2
-rw-r--r--science/py-h5json/Makefile2
-rw-r--r--science/py-h5py/Makefile2
-rw-r--r--science/py-kim-query/Makefile2
-rw-r--r--science/py-kinematics/Makefile2
-rw-r--r--science/py-liac-arff/Makefile2
-rw-r--r--science/py-mdp/Makefile2
-rw-r--r--science/py-mmtf-python/Makefile2
-rw-r--r--science/py-molmod/Makefile2
-rw-r--r--science/py-moltemplate/Makefile2
-rw-r--r--science/py-netCDF4/Makefile2
-rw-r--r--science/py-netcdf-flattener/Makefile2
-rw-r--r--science/py-paida/Makefile2
-rw-r--r--science/py-pupynere/Makefile2
-rw-r--r--science/py-pyaixi/Makefile2
-rw-r--r--science/py-pygeodesy/Makefile2
-rw-r--r--science/py-pygeometa/Makefile2
-rw-r--r--science/py-pyosf/Makefile2
-rw-r--r--science/py-quantities/Makefile2
-rw-r--r--science/py-rmf/Makefile2
-rw-r--r--science/py-ruffus/Makefile2
-rw-r--r--science/py-segyio/Makefile2
-rw-r--r--science/py-spglib/Makefile2
-rw-r--r--science/pynn/Makefile2
31 files changed, 31 insertions, 31 deletions
diff --git a/science/py-DendroPy/Makefile b/science/py-DendroPy/Makefile
index a7bae2471f98..d32254c84dd3 100644
--- a/science/py-DendroPy/Makefile
+++ b/science/py-DendroPy/Makefile
@@ -12,7 +12,7 @@ COMMENT= Phylogenetic computing library
LICENSE= BSD3CLAUSE
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils py3kplist
.include <bsd.port.mk>
diff --git a/science/py-cdo/Makefile b/science/py-cdo/Makefile
index a34fc69ef02e..a368ac0e9aae 100644
--- a/science/py-cdo/Makefile
+++ b/science/py-cdo/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= cdo:science/cdo \
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-chainer/Makefile b/science/py-chainer/Makefile
index e12b447c0e87..2ac1a5d9bef3 100644
--- a/science/py-chainer/Makefile
+++ b/science/py-chainer/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PY_TYPING} \
${PYTHON_PKGNAMEPREFIX}typing-extensions>0:devel/py-typing-extensions@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-coards/Makefile b/science/py-coards/Makefile
index 3b49feb1d9f5..ed97897a5373 100644
--- a/science/py-coards/Makefile
+++ b/science/py-coards/Makefile
@@ -14,7 +14,7 @@ COMMENT= COARDS compliant time parser
LICENSE= MIT
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/science/py-dlib/Makefile b/science/py-dlib/Makefile
index b56702836b8b..dcf91932c195 100644
--- a/science/py-dlib/Makefile
+++ b/science/py-dlib/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= cmake:devel/cmake
LIB_DEPENDS= ${PY_BOOST} \
libpng.so:graphics/png
-USES= compiler:c++11-lang pkgconfig python shebangfix \
+USES= compiler:c++11-lang pkgconfig python:3.6+ shebangfix \
tar:bzip2
USE_PYTHON= autoplist distutils
SHEBANG_FILES= python_examples/*.py
diff --git a/science/py-geolinks/Makefile b/science/py-geolinks/Makefile
index 8db623da7459..fdf9154abab0 100644
--- a/science/py-geolinks/Makefile
+++ b/science/py-geolinks/Makefile
@@ -12,7 +12,7 @@ COMMENT= Utilities to deal with geospatial links
LICENSE= MIT
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-geomet/Makefile b/science/py-geomet/Makefile
index 7a530fa80798..57e742fe3793 100644
--- a/science/py-geomet/Makefile
+++ b/science/py-geomet/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-gsd/Makefile b/science/py-gsd/Makefile
index 3508aba73b95..01278ad61d4a 100644
--- a/science/py-gsd/Makefile
+++ b/science/py-gsd/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils cython autoplist
.include <bsd.port.mk>
diff --git a/science/py-h5json/Makefile b/science/py-h5json/Makefile
index 150b23e170a5..cb474cbb928b 100644
--- a/science/py-h5json/Makefile
+++ b/science/py-h5json/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pkgconfig>0:devel/py-pkgconfig@${PY_FLAVOR
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index 2268df7e20c8..934b7a7ed0e4 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
-USES= pkgconfig python
+USES= pkgconfig python:3.6+
USE_PYTHON= autoplist concurrent cython distutils
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/science/py-kim-query/Makefile b/science/py-kim-query/Makefile
index a23226fc60e6..2e368106f8d2 100644
--- a/science/py-kim-query/Makefile
+++ b/science/py-kim-query/Makefile
@@ -13,7 +13,7 @@ LICENSE= CDDL
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-kinematics/Makefile b/science/py-kinematics/Makefile
index ea327b60e322..2de0b31ad207 100644
--- a/science/py-kinematics/Makefile
+++ b/science/py-kinematics/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-liac-arff/Makefile b/science/py-liac-arff/Makefile
index be02f1c7d24a..eb40bc107b31 100644
--- a/science/py-liac-arff/Makefile
+++ b/science/py-liac-arff/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-mdp/Makefile b/science/py-mdp/Makefile
index 8585f1e25aa0..f8066beb8a1c 100644
--- a/science/py-mdp/Makefile
+++ b/science/py-mdp/Makefile
@@ -16,7 +16,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYNUMPY}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= LIBSVM SCIPY
diff --git a/science/py-mmtf-python/Makefile b/science/py-mmtf-python/Makefile
index 7f6ed8e6c4ee..9232e86fdeb9 100644
--- a/science/py-mmtf-python/Makefile
+++ b/science/py-mmtf-python/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>0:devel/py-msgpack@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= rcsb
USE_PYTHON= distutils autoplist
diff --git a/science/py-molmod/Makefile b/science/py-molmod/Makefile
index 5e54a366a961..0679ce28de4e 100644
--- a/science/py-molmod/Makefile
+++ b/science/py-molmod/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:3.6+ shebangfix
SHEBANG_GLOB= *.py
USE_PYTHON= distutils cython cython_run autoplist
diff --git a/science/py-moltemplate/Makefile b/science/py-moltemplate/Makefile
index 5c670986f0b8..f9687748a12b 100644
--- a/science/py-moltemplate/Makefile
+++ b/science/py-moltemplate/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYNUMPY} \
bash:shells/bash
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:3.6+ shebangfix
SHEBANG_FILES= moltemplate/scripts/molc.sh
USE_PYTHON= distutils concurrent autoplist
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
index efa96d851608..a9ac3039acfb 100644
--- a/science/py-netCDF4/Makefile
+++ b/science/py-netCDF4/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYNUMPY}
OPTIONS_DEFINE= DOCS EXAMPLES
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils cython cython_run
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
diff --git a/science/py-netcdf-flattener/Makefile b/science/py-netcdf-flattener/Makefile
index 6b6596ba676e..0159d57a7941 100644
--- a/science/py-netcdf-flattener/Makefile
+++ b/science/py-netcdf-flattener/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netCDF4>=0:science/py-netCDF4@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-paida/Makefile b/science/py-paida/Makefile
index eae7b5d523a9..64672222e48a 100644
--- a/science/py-paida/Makefile
+++ b/science/py-paida/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLA
MAINTAINER= ports@FreeBSD.org
COMMENT= Pure Python scientific analysis package
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-pupynere/Makefile b/science/py-pupynere/Makefile
index f238949abb86..83299e4f3633 100644
--- a/science/py-pupynere/Makefile
+++ b/science/py-pupynere/Makefile
@@ -16,7 +16,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYNUMPY}
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/science/py-pyaixi/Makefile b/science/py-pyaixi/Makefile
index 172b6e034ad6..1341759fe2de 100644
--- a/science/py-pyaixi/Makefile
+++ b/science/py-pyaixi/Makefile
@@ -15,7 +15,7 @@ COMMENT= Implementation of the MC-AIXI-CTW AI algorithm
LICENSE= CC-BY-SA-3.0
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= dos2unix python
+USES= dos2unix python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-pygeodesy/Makefile b/science/py-pygeodesy/Makefile
index dccfb518b48a..32b88636ac6b 100644
--- a/science/py-pygeodesy/Makefile
+++ b/science/py-pygeodesy/Makefile
@@ -13,7 +13,7 @@ COMMENT= Pure Python geodesy tools
LICENSE= MIT
-USES= python zip
+USES= python:3.6+ zip
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-pygeometa/Makefile b/science/py-pygeometa/Makefile
index 0a3b55f82971..cb3d07501f17 100644
--- a/science/py-pygeometa/Makefile
+++ b/science/py-pygeometa/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-pyosf/Makefile b/science/py-pyosf/Makefile
index a5a70b8b14ea..809651edeafa 100644
--- a/science/py-pyosf/Makefile
+++ b/science/py-pyosf/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= psychopy
USE_PYTHON= distutils autoplist
diff --git a/science/py-quantities/Makefile b/science/py-quantities/Makefile
index 1f533dbaba94..982c4e6278b1 100644
--- a/science/py-quantities/Makefile
+++ b/science/py-quantities/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYNUMPY}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-rmf/Makefile b/science/py-rmf/Makefile
index bf9b16e0e431..9e518ad56c09 100644
--- a/science/py-rmf/Makefile
+++ b/science/py-rmf/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= swig:devel/swig
LIB_DEPENDS= libRMF.so:science/rmf
-USES= cmake compiler:c++11-lang python shebangfix
+USES= cmake compiler:c++11-lang python:3.6+ shebangfix
USE_GITHUB= yes
GH_ACCOUNT= salilab
GH_TAGNAME= f917cf2
diff --git a/science/py-ruffus/Makefile b/science/py-ruffus/Makefile
index 800881517811..5b21891b3d54 100644
--- a/science/py-ruffus/Makefile
+++ b/science/py-ruffus/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:3.6+ shebangfix
USE_PYTHON= distutils autoplist
SHEBANG_FILES= ${WRKSRC}/ruffus/test/*.py
diff --git a/science/py-segyio/Makefile b/science/py-segyio/Makefile
index e119c5e85ad9..d5f8367a175b 100644
--- a/science/py-segyio/Makefile
+++ b/science/py-segyio/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= cmake:devel/cmake \
LIB_DEPENDS= libsegyio.so:science/segyio
RUN_DEPENDS= ${PYNUMPY}
-USES= compiler:c++11-lang python
+USES= compiler:c++11-lang python:3.6+
USE_PYTHON= distutils autoplist
post-install:
diff --git a/science/py-spglib/Makefile b/science/py-spglib/Makefile
index a608b11192c3..28deadcee3f6 100644
--- a/science/py-spglib/Makefile
+++ b/science/py-spglib/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
post-install:
diff --git a/science/pynn/Makefile b/science/pynn/Makefile
index 260c9df1f41c..5fcea0027874 100644
--- a/science/pynn/Makefile
+++ b/science/pynn/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYNUMPY}
NO_ARCH= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
PYDISTUTILS_PKGNAME= PyNN