aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-20 23:47:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-20 23:47:52 +0000
commit10ac60bce76241ca3e14f9f4bea0863b43aec769 (patch)
tree702913f7d4e2379d44400f2d97778b5eacad1e9f /science
parent4ca93fcde750e167a09b67f33f23cb3cc9a1615b (diff)
downloadports-10ac60bce76241ca3e14f9f4bea0863b43aec769.tar.gz
ports-10ac60bce76241ca3e14f9f4bea0863b43aec769.zip
science/dakota: Add GSL option
Notes
Notes: svn path=/head/; revision=566198
Diffstat (limited to 'science')
-rw-r--r--science/dakota/Makefile9
-rw-r--r--science/dakota/pkg-plist1
2 files changed, 10 insertions, 0 deletions
diff --git a/science/dakota/Makefile b/science/dakota/Makefile
index 90dbb9bc9ae0..5d671b24adc1 100644
--- a/science/dakota/Makefile
+++ b/science/dakota/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dakota
DISTVERSION= 6.13.0
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= https://dakota.sandia.gov/sites/default/files/distributions/public/
@@ -34,6 +35,7 @@ CMAKE_ARGS= -DDakota_VERSION_SRC:STRING=${DISTVERSION} -DDakota_GIT_REVL:STRING=
FFLAGS+= -fallow-argument-mismatch
LDFLAGS+= -lexecinfo
+CONFLICTS_BUILD= dakota # self: picks up some bundled packages from the pre-installed dakota package and then fails to install them
CONFLICTS_INSTALL= openblas
USES_GIT= no
@@ -63,6 +65,13 @@ do-fetch:
DISTNAME= ${PORTNAME}-${DISTVERSION}-release-public.src-UI
.endif
+OPTIONS_DEFINE= GSL
+OPTIONS_DEFAULT= GSL
+
+GSL_DESC= GSL support
+GSL_CMAKE_BOOL= DAKOTA_HAVE_GSL HAVE_QUESO # QUESO requires GSL
+GSL_LIB_DEPENDS= libgsl.so:math/gsl
+
post-extract:
@${FIND} ${WRKSRC} -name "*.orig" -delete
@${ECHO} ${DISTVERSION} > ${WRKSRC}/VERSION # expected by the 'install' target
diff --git a/science/dakota/pkg-plist b/science/dakota/pkg-plist
index 3c24db6bcc37..2e381fcd1e1c 100644
--- a/science/dakota/pkg-plist
+++ b/science/dakota/pkg-plist
@@ -2518,6 +2518,7 @@ lib/libpebbl.so
lib/libpecos_src.so
lib/libpecos_util.so
lib/libpsuade.so
+lib/libqueso.so
lib/librol.so
lib/librol.so.13
lib/librol.so.13.0