aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-05-31 04:51:46 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-05-31 04:51:46 +0000
commit2d79bef410bd3a30222e0717650785dcf41ad335 (patch)
tree16d63baa098ca0851efa25f01caf8a883b2fc77f /science
parent16b610b5a7200a3f9050a023e1dafc0a2c0a5834 (diff)
downloadports-2d79bef410bd3a30222e0717650785dcf41ad335.tar.gz
ports-2d79bef410bd3a30222e0717650785dcf41ad335.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/elmer-fem/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/science/elmer-fem/Makefile b/science/elmer-fem/Makefile
index caafaef05332..6c539913b40d 100644
--- a/science/elmer-fem/Makefile
+++ b/science/elmer-fem/Makefile
@@ -29,9 +29,13 @@ WITH_FORTRAN= yes
FC= ${LOCALBASE}/bin/gfortran41
F77= ${FC}
+.ifdef WITH_OPTIMIZED_FLAGS
+FCFLAGS+= -O3 -ffast-math -funroll-loops
+.endif
+
USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS=${FCFLAGS}
+CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS="${FCFLAGS}"
USE_GMAKE= yes
ALL_TARGET=
INSTALLS_SHLIB= yes