aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 02:24:29 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 02:24:29 +0000
commit52d564a55281a0e508af246fff0da98dc47c91f7 (patch)
tree3f8a80ef119467b0186ce4ffff223c0d0120ca4e /science
parent2f5fd33d0b48f766e2722a601367b2d51c9e82a8 (diff)
downloadports-52d564a55281a0e508af246fff0da98dc47c91f7.tar.gz
ports-52d564a55281a0e508af246fff0da98dc47c91f7.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/gsystem/Makefile8
-rw-r--r--science/kst/Makefile6
-rw-r--r--science/kst2/Makefile6
-rw-r--r--science/lamprop/Makefile10
-rw-r--r--science/mbdyn/Makefile4
-rw-r--r--science/medit/Makefile2
-rw-r--r--science/psi3/Makefile4
-rw-r--r--science/qcl/Makefile8
-rw-r--r--science/x11iraf/Makefile10
9 files changed, 8 insertions, 50 deletions
diff --git a/science/gsystem/Makefile b/science/gsystem/Makefile
index 8e548e4296d2..0a303e7ab1e0 100644
--- a/science/gsystem/Makefile
+++ b/science/gsystem/Makefile
@@ -26,12 +26,6 @@ INSTALLS_SHLIB= yes
QTDIR= ${QT_PREFIX}
QMAKESPEC= freebsd-g++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "does not compile with gcc 2.95"
-.endif
-
do-configure:
cd ${WRKSRC}; \
export QTDIR=${QTDIR}; \
@@ -53,4 +47,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE};
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/kst/Makefile b/science/kst/Makefile
index 2cc30abdcb86..65c0b0f688e3 100644
--- a/science/kst/Makefile
+++ b/science/kst/Makefile
@@ -32,11 +32,7 @@ MAN1= kst.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not build
-.endif
-
-.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 2cc30abdcb86..65c0b0f688e3 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -32,11 +32,7 @@ MAN1= kst.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not build
-.endif
-
-.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
diff --git a/science/lamprop/Makefile b/science/lamprop/Makefile
index 325ca5965991..d5361e614659 100644
--- a/science/lamprop/Makefile
+++ b/science/lamprop/Makefile
@@ -25,17 +25,9 @@ MAKE_ENV= NOPORTDOCS=yes
PORTDOCS= LICENSE README NEWS
.endif
-.include <bsd.port.pre.mk>
-
REP= 's|-pipe||; s|-fmerge-constants||; s|--fast-math||'
-.if ${OSVERSION} < 500000
-REP2+= 's|-fno-unit-at-a-time||;'
-.endif
post-patch:
@${REINPLACE_CMD} -e ${REP} ${WRKSRC}/Makefile
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e ${REP2} ${WRKSRC}/Makefile
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 88f695820802..97ce5da3fe50 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -97,8 +97,4 @@ CONFIGURE_ARGS+= --with-tcl=no
BROKEN= Does not compile
.endif
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
.include <bsd.port.post.mk>
diff --git a/science/medit/Makefile b/science/medit/Makefile
index 0e27b931b642..8f607c16b51a 100644
--- a/science/medit/Makefile
+++ b/science/medit/Makefile
@@ -57,9 +57,7 @@ USE_GL= yes
. if ${OSVERSION} < 601000
. if ${ARCH} == i386
DISTVER= 4.11
-. if ${OSVERSION} >= 500000
LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-. endif
. else
BROKEN= no binary available for your platform x version at the moment
. endif
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index 9a1f99663c41..52bd0db51755 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -54,10 +54,6 @@ CONFIGURE_ARGS= --with-cc=${CC} \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on FreeBSD 4.x
-.endif
-
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
diff --git a/science/qcl/Makefile b/science/qcl/Makefile
index ca4ec25ab4aa..d794d1f5ed45 100644
--- a/science/qcl/Makefile
+++ b/science/qcl/Makefile
@@ -16,14 +16,8 @@ COMMENT= A quantum computer simulator
USE_GETOPT_LONG=yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
do-configure:
echo 'PREFIX=${PREFIX}' >>${WRKSRC}/Makefile
cd ${WRKSRC} && make dep
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/x11iraf/Makefile b/science/x11iraf/Makefile
index 64685008852d..5ffdd466eedf 100644
--- a/science/x11iraf/Makefile
+++ b/science/x11iraf/Makefile
@@ -14,6 +14,8 @@ DISTNAME= x11iraf-v${PORTVERSION}-bin.freebsd
MAINTAINER= dsyphers@u.washington.edu
COMMENT= Provides graphical tools to work with IRAF
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
NO_BUILD= yes
USE_XLIB= yes
@@ -29,12 +31,6 @@ MAN1= obmsh.1 \
ximtool.1 \
xtapemon.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-
do-install:
@${ECHO_MSG} "===> Installing binaries"
@${INSTALL_PROGRAM} ${BINS:S|^|${WRKDIR}/bin.freebsd/|} ${PREFIX}/bin/
@@ -45,4 +41,4 @@ do-install:
@${INSTALL_DATA} ${WRKDIR}/include/* ${PREFIX}/include/
@${INSTALL_DATA} ${WRKDIR}/lib.freebsd/libcdl.a ${PREFIX}/lib/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>