aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:53:14 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:53:14 +0000
commit66268ff733dd8b2fc2b39582c73a9b5da25bb93a (patch)
tree2dd86d76601d6be612fc7a6f6f9f89e40489bd16 /science
parent8315488dab26d67980b5f81f8f3ad88eec59097d (diff)
downloadports-66268ff733dd8b2fc2b39582c73a9b5da25bb93a.tar.gz
ports-66268ff733dd8b2fc2b39582c73a9b5da25bb93a.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/elmer-hutiter/Makefile43
-rw-r--r--science/elmer-hutiter/distinfo3
-rw-r--r--science/elmer-hutiter/pkg-descr9
4 files changed, 56 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 85520c0f9240..64d1edd5b51b 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -18,6 +18,7 @@
SUBDIR += devisor
SUBDIR += dft++
SUBDIR += elmer-eio
+ SUBDIR += elmer-hutiter
SUBDIR += elmer-matc
SUBDIR += elmer-meshgen2d
SUBDIR += elmergrid
diff --git a/science/elmer-hutiter/Makefile b/science/elmer-hutiter/Makefile
new file mode 100644
index 000000000000..ed0db13a07ff
--- /dev/null
+++ b/science/elmer-hutiter/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: hutiter
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hutiter
+PORTVERSION= 5.0.0
+CATEGORIES= science
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+PKGNAMEPREFIX= elmer-
+
+MAINTAINER= giffunip@asme.org
+COMMENT= HUTIter library for use in the ELMER FEM package
+
+BUILD_DEPENDS= ${FC}:${PORTSDIR}/lang/gfortran \
+ ${LOCALBASE}/lib/libblas.a:${PORTSDIR}/math/elmer-mathlibs \
+ ${LOCALBASE}/lib/liblapack.a:${PORTSDIR}/math/elmer-mathlibs \
+ ${LOCALBASE}/lib/libarpack.a:${PORTSDIR}/math/elmer-mathlibs
+
+USE_GCC= 4.1+
+
+FC= ${LOCALBASE}/bin/gfortran41
+F77= ${FC}
+WITH_FORTRAN= yes
+CONFIGURE_ENV+= FC=${FC} F77=${FC}
+GNU_CONFIGURE= yes
+ALL_TARGET=
+
+PLIST_FILES= include/huti_defs.h include/huti_fdefs.h lib/libhuti.a
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+FFLAGS+= -fPIC
+post-configure:
+ @${REINPLACE_CMD} -e 's+-O +-O -fPIC+g;' ${WRKSRC}/src/Makefile
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/elmer-hutiter/distinfo b/science/elmer-hutiter/distinfo
new file mode 100644
index 000000000000..0cebefe2e54b
--- /dev/null
+++ b/science/elmer-hutiter/distinfo
@@ -0,0 +1,3 @@
+MD5 (hutiter-5.0.0.tar.gz) = 3c6b67da8e08acd3b972a125064f5865
+SHA256 (hutiter-5.0.0.tar.gz) = aaff2448af442a4ea00528ce55929c38fe8ba43ab7bfc1f28ff2a87c2dade71d
+SIZE (hutiter-5.0.0.tar.gz) = 156702
diff --git a/science/elmer-hutiter/pkg-descr b/science/elmer-hutiter/pkg-descr
new file mode 100644
index 000000000000..bc46c7011c51
--- /dev/null
+++ b/science/elmer-hutiter/pkg-descr
@@ -0,0 +1,9 @@
+HUTIter library for use in the Elmer FEM package.
+
+Elmer is an open-source computational tool for multi-physics problems.
+
+Elmer includes physical models of fluid dynamics, structural mechanics,
+electromagnetics and heat transfer. These are described by partial
+differential equations which Elmer solves by the Finite Element Method (FEM).
+
+WWW: http://www.csc.fi/elmer/