aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-29 01:21:24 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-29 01:21:24 +0000
commitcc351d3c3cfe7145176447afa00a30b7fabc66aa (patch)
tree6d87554cf948b15ae94dd51f3d5b568266d15528 /science
parent1ae56474b4da3a30fbd0eb1d8ea2e4162c4050db (diff)
downloadports-cc351d3c3cfe7145176447afa00a30b7fabc66aa.tar.gz
ports-cc351d3c3cfe7145176447afa00a30b7fabc66aa.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/netcdf4/Makefile25
-rw-r--r--science/netcdf4/distinfo4
-rw-r--r--science/netcdf4/pkg-plist15
3 files changed, 14 insertions, 30 deletions
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index 011c71eab2a9..db6985e132d3 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netcdf
-PORTVERSION= 4.1.2
+PORTVERSION= 4.1.3
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -19,12 +19,18 @@ CONFLICTS= hdf-4.* netcdf-3.*
LATEST_LINK?= netcdf4
PORTSCOUT= limit:^4\.
+OPTIONS= DAP "Build DAP client and remote testing" off \
+ FORTRAN "Build library for Fortran" off \
+ SZIP "SZIP support (required if HDF5 was built with SZIP)" off
+
CONFIGURE_ARGS= --enable-cxx --enable-cxx-4 --enable-netcdf-4 --enable-shared \
--with-hdf5=${LOCALBASE} --with-zlib=/usr
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CPPFLAGS+= -I${LOCALBASE}/include -fPIC -DPIC
GNU_CONFIGURE= yes
-LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18
-MAKE_ENV= MAKEINFOFLAGS="--no-split" INFODIR="${PREFIX}/${INFO_PATH}"
+LDFLAGS+= -L${LOCALBASE}/lib
+LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18
+MAKE_ENV= INFODIR="${PREFIX}/${INFO_PATH}" MAKEINFOFLAGS="--no-split"
USE_GNOME= gnomehack
USE_LDCONFIG= yes
@@ -33,10 +39,6 @@ INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
MAN1= nccopy.1 ncdump.1 ncgen.1 ncgen3.1
MAN3= netcdf.3
-OPTIONS= DAP "Build DAP client and remote testing" off \
- FORTRAN "Build library for Fortran" off \
- SZIP "SZIP support (required if HDF5 was built with SZIP)" off
-
.include <bsd.port.options.mk>
.if defined(WITH_DAP)
@@ -65,11 +67,6 @@ CONFIGURE_ARGS+=--with-szlib=${LOCALBASE}
LIB_DEPENDS+= sz.2:${PORTSDIR}/science/szip
.endif
-#post-patch:
-# @${REINPLACE_CMD} -e \
-# 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
-# ${WRKSRC}/Makefile.in
-
post-configure:
@cd ${WRKSRC}/man4 && ${SETENV} ${MAKE_ENV} ${MAKE} maintainer-clean-aminfo
.for i in ${INFO}
@@ -78,8 +75,8 @@ post-configure:
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/
- @cd ${WRKSRC}/man4 && ${INSTALL_DATA} *.html *.info *.pdf *.ps *.txt ${DOCSDIR}/
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/man4 && ${INSTALL_DATA} *.html *.pdf *.txt ${DOCSDIR}/
.endif
regression-test: build
diff --git a/science/netcdf4/distinfo b/science/netcdf4/distinfo
index 8c2ea030c696..b3f24d39d626 100644
--- a/science/netcdf4/distinfo
+++ b/science/netcdf4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netcdf-4.1.2.tar.gz) = 0c8df55f5967be2cd6ede1a1e8a4a96a69d6b716ec649b3eba9640dbbcda16b9
-SIZE (netcdf-4.1.2.tar.gz) = 11021527
+SHA256 (netcdf-4.1.3.tar.gz) = 44447a72711e2b75cb91c5a235dd6bcf2a6bddd0206614ccac83c1f47af02253
+SIZE (netcdf-4.1.3.tar.gz) = 11095305
diff --git a/science/netcdf4/pkg-plist b/science/netcdf4/pkg-plist
index 54768c557f93..41151deda640 100644
--- a/science/netcdf4/pkg-plist
+++ b/science/netcdf4/pkg-plist
@@ -54,44 +54,31 @@ lib/libnetcdf_c++4.so.1
%%FORTRAN%%lib/libnetcdff.so
%%FORTRAN%%lib/libnetcdff.so.5
libdata/pkgconfig/netcdf.pc
+%%PORTDOCS%%%%DOCSDIR%%/nccopy-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncdump-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/ncgen3-man-1.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf-man-3.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf.info
%%PORTDOCS%%%%DOCSDIR%%/netcdf.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf.ps
%%PORTDOCS%%%%DOCSDIR%%/netcdf.txt
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f77-man.html
%%PORTDOCS%%%%DOCSDIR%%/netcdf_f90-man.html