aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-05 21:09:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-05 21:09:25 +0000
commit25d0762558595a5ca9e0b70a1e361a7680768429 (patch)
treeb05622f130f9693a69ae0d79f7b5db90919e83b8 /science
parent4cf47dec540f352c5fd6dc22c02c61abbea45179 (diff)
downloadports-25d0762558595a5ca9e0b70a1e361a7680768429.tar.gz
ports-25d0762558595a5ca9e0b70a1e361a7680768429.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/mbdyn/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index e8dd0e62b97a..4afb76549d35 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mbdyn
PORTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.aero.polimi.it/~masarati/Download/mbdyn/
@@ -34,6 +35,7 @@ MAN1= mbdyn.1
OPTIONS= MPI "Enable mpich-support" off \
METIS "Enable metis-support" off \
+ CHACO "Enable chaco-support" off \
GINAC "Enable GiNaC-support (not implemented yet)" off \
TCL "Enable tcl-support (not implemented yet)" off
@@ -64,7 +66,6 @@ CONFIGURE_ARGS+= --with-mpi=no
.endif
.if defined(WITH_METIS)
-BROKEN= Does not compile with metis enabled
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
CONFIGURE_ARGS+= --with-metis=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
@@ -72,6 +73,13 @@ CPPFLAGS+= -I${LOCALBASE}/include/metis
CONFIGURE_ARGS+= --with-metis=no
.endif
+.if defined(WITH_CHACO)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libchaco.a:${PORTSDIR}/math/chaco
+CONFIGURE_ARGS+= --with-chaco=yes
+.else
+CONFIGURE_ARGS+= --with-chaco=no
+.endif
+
.if defined(WITH_GINAC)
IGNORE= you enabled GiNaC-support, which is not implemented yet
#BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
@@ -94,8 +102,4 @@ CONFIGURE_ARGS+= --with-tcl=no
BROKEN= Does not compile
.endif
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
.include <bsd.port.post.mk>