aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
commit564a799c7173c288d4d3a9be78ac3d2db983d512 (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /science
parentaf1790bfbbcd5831281907db9c04f3776b8d601c (diff)
downloadports-564a799c7173c288d4d3a9be78ac3d2db983d512.tar.gz
ports-564a799c7173c288d4d3a9be78ac3d2db983d512.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/2dhf/Makefile6
-rw-r--r--science/abinit/Makefile26
-rw-r--r--science/cdf/Makefile2
-rw-r--r--science/cgnslib/Makefile2
-rw-r--r--science/dcl/Makefile3
-rw-r--r--science/dlpoly-classic/Makefile3
-rw-r--r--science/elmer-eio/Makefile2
-rw-r--r--science/elmer-hutiter/Makefile2
-rw-r--r--science/fvcom/Makefile2
-rw-r--r--science/gamess/Makefile4
-rw-r--r--science/getdp/Makefile6
-rw-r--r--science/ghemical/Makefile4
-rw-r--r--science/harminv/Makefile3
-rw-r--r--science/hdf5-18/Makefile2
-rw-r--r--science/hdf5/Makefile2
-rw-r--r--science/libctl/Makefile2
-rw-r--r--science/libghemical/Makefile6
-rw-r--r--science/mbdyn/Makefile3
-rw-r--r--science/meep/Makefile4
-rw-r--r--science/mpqc/Makefile22
-rw-r--r--science/ncs/Makefile4
-rw-r--r--science/netcdf/Makefile4
-rw-r--r--science/netcdf4/Makefile4
-rw-r--r--science/netcdf4/files/patch-cxx4-ncGroup.cpp29
-rw-r--r--science/pnetcdf/Makefile3
-rw-r--r--science/psi3/Makefile7
-rw-r--r--science/psi3/files/patch-src-bin-clag-clag.cc10
-rw-r--r--science/psi3/files/patch-src-bin-geom-geom.cc10
-rw-r--r--science/psi3/files/patch-src-bin-nonbonded-nonbonded.cc10
-rw-r--r--science/psi3/files/patch-src-bin-transqt2-transqt.cc10
-rw-r--r--science/psi3/files/patch-src-lib-libbasis-combinate.cc12
-rw-r--r--science/psi3/files/patch-src-lib-libipv1-ip_read.cc20
-rw-r--r--science/psi3/files/patch-src-lib-libpsio-psio.hpp17
-rw-r--r--science/py-obspy/Makefile2
-rw-r--r--science/py-scikit-learn/Makefile2
-rw-r--r--science/py-scipy/Makefile2
-rw-r--r--science/v_sim/Makefile3
37 files changed, 182 insertions, 73 deletions
diff --git a/science/2dhf/Makefile b/science/2dhf/Makefile
index c576446368ea..e187cb7a287e 100644
--- a/science/2dhf/Makefile
+++ b/science/2dhf/Makefile
@@ -14,8 +14,10 @@ COMMENT= A Numerical Hartree-Fock Program for Diatomic Molecules
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
.if defined(WITH_INTEL)
-USE_FORTRAN= ifort
+USES+= fortran:ifort
BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
+.else
+USES+= fortran
.endif
.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
@@ -30,8 +32,6 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
.endif
-USE_FORTRAN= yes
-
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
.if (${MACHINE_ARCH} == "i386")
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index cc247aa1912a..b6f2ce0a1f18 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -15,8 +15,7 @@ BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
LIB_DEPENDS= netcdff.4:${PORTSDIR}/science/netcdf3-ftn \
gsl:${PORTSDIR}/math/gsl
-USES= gmake perl5
-USE_FORTRAN= yes
+USES= fortran gmake perl5
USE_PYTHON= yes
USE_PERL5= build
USE_AUTOTOOLS= autoconf automake
@@ -26,18 +25,21 @@ CONFIGURE_ARGS= --disable-wannier90 --disable-bigdft --disable-etsf-io \
--with-netcdf-includes="-I${LOCALBASE}/include" \
--enable-bindings --enable-gsl \
--with-netcdf-libs="-L${LOCALBASE}/lib -lnetcdff -lnetcdf"
-ALL_TARGET= all libabinit
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
USE_TEX= latex:build dvipsk:build
BUILD_DEPENDS+= gm4:${PORTSDIR}/devel/m4 \
markdown:${PORTSDIR}/textproc/markdown
USE_GHOSTSCRIPT_BUILD= yes
.endif
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
MANUAL_PACKAGE_BUILD= takes a tremendous amount of time to build on pointyhat nodes
.endif
@@ -57,15 +59,19 @@ LAPACK= -llapack
.endif
pre-configure:
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/^abinit_top_subdirs =/s| doc||' ${WRKSRC}/config/specs/other.cf
.endif
-.if defined(NOPORTEXAMPLES)
+.if ! ${PORT_OPTIONS:MEXAMPLES}
${REINPLACE_CMD} -e '/^abinit_top_subdirs =/s| tests||' ${WRKSRC}/config/specs/other.cf
.endif
(cd ${WRKSRC} && ./config/scripts/makemake)
${CHMOD} a+x ${WRKSRC}/bindings/parser/*.py
+post-build:
+ @(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} libabinit)
+
post-install:
${MKDIR} ${PREFIX}/include ${PREFIX}/lib
.for lf in libabinip.a libabinis.a
@@ -79,4 +85,4 @@ post-install:
regression-test:
cd ${WRKSRC}/tests ; ${GMAKE} tests_min
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/cdf/Makefile b/science/cdf/Makefile
index 304bf8b757ba..ed630287b142 100644
--- a/science/cdf/Makefile
+++ b/science/cdf/Makefile
@@ -21,7 +21,7 @@ MAKE_JOBS_UNSAFE= yes
VER= ${PORTVERSION:S/.//:S/./_/}
-USE_FORTRAN= yes
+USES= fortran
WRKSRC= ${WRKDIR}/cdf${VER}-dist
SUB_FILES= pkg-message
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index c45928ef945e..3db38778cf7a 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -46,7 +46,7 @@ PLIST_SUB= HDF5="@comment "
.endif
.if ${PORT_OPTIONS:MTESTS}
-USE_FORTRAN= yes
+USES+= fortran
CMAKE_ARGS+= -DENABLE_TESTS:BOOL=TRUE -DENABLE_FORTRAN:BOOL=TRUE
TESTSBIN= cgwrite cgread test_partial
.endif
diff --git a/science/dcl/Makefile b/science/dcl/Makefile
index 3c78a28aadbc..4aa7a5de5c00 100644
--- a/science/dcl/Makefile
+++ b/science/dcl/Makefile
@@ -13,9 +13,8 @@ MAINTAINER= murashin@gfd-dennou.org
COMMENT= Scientific graphic library for geoscience
MAKE_JOBS_UNSAFE= yes
-USES= pkgconfig
+USES= fortran pkgconfig
USE_XORG= x11 xext
-USE_FORTRAN= yes
USE_GNOME= gtk20 gdkpixbuf2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --with-x
diff --git a/science/dlpoly-classic/Makefile b/science/dlpoly-classic/Makefile
index 60398be62f14..c0e77086eab7 100644
--- a/science/dlpoly-classic/Makefile
+++ b/science/dlpoly-classic/Makefile
@@ -19,8 +19,7 @@ OPTIONS_DEFINE= GUI DOCS EXAMPLES
OPTIONS_DEFAULT= GUI
GUI_DESC= Install Java GUI
-USE_GMAKE= yes
-USE_FORTRAN= yes
+USES= fortran gmake
SUB_FILES= dlpoly-gui
diff --git a/science/elmer-eio/Makefile b/science/elmer-eio/Makefile
index 75eb8b9a99a3..3050840790b8 100644
--- a/science/elmer-eio/Makefile
+++ b/science/elmer-eio/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= elmer-
MAINTAINER= sylvio@FreeBSD.org
COMMENT= ELMER FEM Package Data base Interface
-USE_FORTRAN= yes
+USES= fortran
GNU_CONFIGURE= yes
ALL_TARGET=
diff --git a/science/elmer-hutiter/Makefile b/science/elmer-hutiter/Makefile
index 98caf36ea5f1..73b0c0df4342 100644
--- a/science/elmer-hutiter/Makefile
+++ b/science/elmer-hutiter/Makefile
@@ -14,7 +14,7 @@ COMMENT= HUTIter library for use in the ELMER FEM package
LIB_DEPENDS= arpack.1:${PORTSDIR}/math/arpack
-USE_FORTRAN= yes
+USES= fortran
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/science/fvcom/Makefile b/science/fvcom/Makefile
index ddfb60ec7e58..d5f0f2665603 100644
--- a/science/fvcom/Makefile
+++ b/science/fvcom/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS+= netcdff:${PORTSDIR}/science/netcdf-ftn \
lapack:${PORTSDIR}/math/lapack \
blas:${PORTSDIR}/math/lapack
-USE_FORTRAN= yes
+USES= fortran
WRKSRC= ${WRKDIR}/FVCOM2.7.1/FVCOM_source
PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}
diff --git a/science/gamess/Makefile b/science/gamess/Makefile
index 17138ef3bbcd..a30e51343059 100644
--- a/science/gamess/Makefile
+++ b/science/gamess/Makefile
@@ -11,12 +11,10 @@ DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= maho@FreeBSD.org
COMMENT= A freely obtainable ab-initio molecular orbital calculation program
-USE_GMAKE= yes
+USES= fortran gmake
WRKSRC= ${WRKDIR}/gamess
SNAPDATE= 20130501.1
-USE_FORTRAN= yes
-
RESTRICTED= NOT DISTRIBUTED FREELY. BUT YOU CAN OBTAIN SOURCE CODE FREELY.
.if !exists(${DISTDIR}/${DISTFILES})
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index 6ae03104525f..61aea8f1a796 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -15,8 +15,7 @@ COMMENT= A rather general finite element solver using mixed finite elements
LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl \
lapack.4:${PORTSDIR}/math/lapack
-USE_GMAKE= yes
-USE_FORTRAN= yes
+USES= fortran gmake
GNU_CONFIGURE= yes
# Using --enable-sparskit instead of math/petsc. The maintainer couldn't get
# the math/petsc to work. This is a bmake/gmake clash.
@@ -29,6 +28,9 @@ MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's/-lgfortran/& $${LDFLAGS}/' ${WRKSRC}/configure
+
post-install:
.if !defined(NOPORTDOCS)
cd ${WRKSRC}/doc && ${FIND} -s ${WRKSRC}/doc/* | ${SED} -e 's#${WRKSRC}/doc/##' | ${CPIO} -pmud -R ${BINOWN}:${BINGRP} ${STAGEDIR}${DOCSDIR}
diff --git a/science/ghemical/Makefile b/science/ghemical/Makefile
index 8cc075034b05..47fc7740c06f 100644
--- a/science/ghemical/Makefile
+++ b/science/ghemical/Makefile
@@ -21,9 +21,7 @@ LIB_DEPENDS= mpqc:${PORTSDIR}/science/mpqc \
oglappth:${PORTSDIR}/science/liboglappth \
mopac7:${PORTSDIR}/biology/mopac
-USES= pkgconfig gettext
-USE_FORTRAN= yes
-USE_GMAKE= yes
+USES= fortran gettext gmake pkgconfig
USE_GNOME= glib20 gtk20 libglade2
USE_GL= glut
GNU_CONFIGURE= yes
diff --git a/science/harminv/Makefile b/science/harminv/Makefile
index 5dba0ecfc8a6..306f548439b2 100644
--- a/science/harminv/Makefile
+++ b/science/harminv/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= http://ab-initio.mit.edu/harminv/
MAINTAINER= devel@stasyan.com
COMMENT= Solver of harmonic inversion
-USE_GMAKE= yes
+USES= fortran gmake
GNU_CONFIGURE= yes
-USE_FORTRAN= yes
USE_GCC= yes
CPPFLAGS+= -I${LOCALBASE}/include
LD_LIBRARY_PATH= -L${LOCALBASE}/lib -L/usr/lib
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index 2c39adad0612..9827872758f0 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ARGS+=--disable-production --enable-debug=all
.endif
.if ${PORT_OPTIONS:MFORTRAN}
-USE_FORTRAN= yes
+USES+= fortran
CONFIGURE_ARGS+=--enable-fortran
CONFIGURE_ENV+= F9X=${FC}
PLIST_SUB+= FORTRAN=""
diff --git a/science/hdf5/Makefile b/science/hdf5/Makefile
index e6f7d465a1f5..6b49ecabc1ce 100644
--- a/science/hdf5/Makefile
+++ b/science/hdf5/Makefile
@@ -36,7 +36,7 @@ NO_STAGE= yes
.if defined(WITH_FORTRAN)
LIBTOOLFILES+= fortran/configure
-USE_FORTRAN= yes
+USES+= fortran
CONFIGURE_ENV+= F9X=${FC}
CONFIGURE_ARGS+= --enable-fortran
PLIST_SUB+= FORTRAN=""
diff --git a/science/libctl/Makefile b/science/libctl/Makefile
index 2ae8f8d81fa1..52590525aed5 100644
--- a/science/libctl/Makefile
+++ b/science/libctl/Makefile
@@ -12,8 +12,8 @@ COMMENT= Control Language Library
LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
+USES= fortran
USE_AUTOTOOLS= libtool
-USE_FORTRAN= yes
USE_LDCONFIG= yes
MAN1= gen-ctl-io.1
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index 3398584bf7b8..ece81e1d9a25 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -17,14 +17,14 @@ BUILD_DEPENDS= obabel:${PORTSDIR}/science/openbabel \
LIB_DEPENDS+= mpqc:${PORTSDIR}/science/mpqc \
f2c:${PORTSDIR}/lang/f2c
-USE_GMAKE= yes
-USES= pathfix pkgconfig gettext
+USES= fortran gettext gmake pathfix pkgconfig
USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_FORTRAN= yes
CONFIGURE_ARGS+= --enable-mpqc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= LIBGHEMICAL_VERSION="${PORTVERSION}"
NO_STAGE= yes
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index b935535d93d6..a7fcf307d40f 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= arpack:${PORTSDIR}/math/arpack \
umfpack:${PORTSDIR}/math/suitesparse
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_FORTRAN= yes
+USES= fortran gmake
MAN1= mbdyn.1
CPPFLAGS+= -fpermissive -I${LOCALBASE}/include/suitesparse
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/science/meep/Makefile b/science/meep/Makefile
index 63bbe293f478..c8b0cb3dddd3 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -19,11 +19,9 @@ LIB_DEPENDS+= guile.21:${PORTSDIR}/lang/guile \
hdf5.7:${PORTSDIR}/science/hdf5-18
RUN_DEPENDS+= harminv:${PORTSDIR}/science/harminv
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_FORTRAN= yes
USE_GCC= yes
-USES= gettext iconv pathfix
+USES= fortran gettext gmake iconv pathfix
USE_AUTOTOOLS+= libltdl
CPPFLAGS+= -I${LOCALBASE}/include
LD_LIBRARY_PATH= -L${LOCALBASE}/lib -L/usr/lib
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index f29953cee0f3..de01e23fb1ec 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -10,10 +10,14 @@ MASTER_SITES= SF
MAINTAINER= maho@FreeBSD.org
COMMENT= The massively parallel quantum computing library and program
-USES= perl5 gmake
+GNU_CONFIGURE= yes
+USES= fortran gmake perl5
+USE_AUTOTOOLS= autoconf
USE_BZIP2= yes
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
NO_STAGE= yes
.include <bsd.port.pre.mk>
@@ -37,7 +41,7 @@ LAPACK= -llapack
LIB_DEPENDS+= mpich:${PORTSDIR}/net/mpich2
.endif
LIB_DEPENDS+= int.1:${PORTSDIR}/science/libint
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
USE_TEX= latex:build
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
BUILD_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
@@ -45,10 +49,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
.endif
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf
-USE_FORTRAN= yes
-
.if defined(WITH_ICC)
CC= ${LOCALBASE}/intel_cc_80/bin/icc
CXX= ${LOCALBASE}/intel_cc_80/bin/icpc
@@ -83,7 +83,7 @@ CONFIGURE_ARGS+=--with-include="-I${WRKDIR} -I${LOCALBASE}/include"
MPQC_COMMAND= ${PREFIX}/bin/mpqc
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
.include "${FILESDIR}/manpages"
.endif
@@ -92,16 +92,12 @@ CFLAGS+= -O2 -ffast-math
CXXFLAGS+= -O2 -ffast-math
.endif
-EXTRARPATH= -Wl,-rpath=`${CAT} ${WRKSRC}/LIBDIR`
-
pre-configure:
@${ECHO} "You can optimize by setting WITH_OPTIMIZED_FLAGS=yes."
- @${DIRNAME} `${CC} -print-file-name=libstdc++.so` > ${WRKSRC}/LIBDIR
- @${REINPLACE_CMD} -e 's|%%EXTRARPATH%%|${EXTRARPATH}|g' ${WRKSRC}/lib/LocalMakefile.in
do-build:
@cd ${WRKSRC} ; ${GMAKE}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC}/doc ; ${GMAKE}
.endif
@@ -113,7 +109,7 @@ do-install:
${TAR} -xf - -C ${PREFIX}/share/mpqc/validate
${FIND} ${PREFIX}/share/mpqc/validate | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
${FIND} ${PREFIX}/share/mpqc/validate -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
rm -f ${WRKSRC}/doc/man/man1/_*mpqc_*.1
rm -f ${WRKSRC}/doc/man/man3/_*mpqc_*.3
rm -f ${WRKSRC}/doc/man/man3/sc_PsiCCSD_T.3* #somehow this file is not generated in tinderbox
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index ec4bdd1df6f8..39f3d24fe02a 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -24,8 +24,7 @@ RUN_DEPENDS= xmgrace:${PORTSDIR}/math/grace \
cs_preprocess:${PORTSDIR}/science/ecs
USE_ZIP= yes
-USE_GMAKE= yes
-USES= gettext iconv
+USES= fortran gettext gmake iconv
USE_GNOME= libxml2
USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -38,7 +37,6 @@ MAKE_ENV= NOM_ARCH=${OPSYS} CS_MPI_PATH=${MPI_HOME}/bin \
MPI_HOME=${MPI_HOME} MPI_LIBS="${MPI_LIBS}"
USE_LDCONFIG= yes
-USE_FORTRAN= yes
FORTRANLIBDIR= `${DIRNAME} \\`${FC} -print-libgcc-file-name\\``
FORTRANLIBDIR2= `${DIRNAME} \\`${FC} -print-libgcc-file-name\\``/../../../
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 86ef2d905292..b09b6d06cc23 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netcdf
PORTVERSION= 3.6.3
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -43,7 +43,7 @@ CPPFLAGS+= -DpgiFortran
CONFLICTS+= netcdf-3.*
MAN3+= netcdf_f77.3 netcdf_f90.3
PLIST_SUB+= FORTRAN=""
-USE_FORTRAN= yes
+USES+= fortran
.else
CONFIGURE_ARGS+=--disable-f77 --disable-f90
CONFLICTS+= netcdf-ftn-3.*
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index ff905cbe209e..4ddc23522ec4 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netcdf
PORTVERSION= 4.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -52,7 +52,7 @@ CONFLICTS+= netcdf-4.*
MAN3+= netcdf_f77.3 netcdf_f90.3
PKGNAMESUFFIX+= -ftn
PLIST_SUB+= FORTRAN=""
-USE_FORTRAN= yes
+USES+= fortran
.else
CONFIGURE_ARGS+=--disable-f77 --disable-f90
CONFLICTS+= netcdf-ftn-4.*
diff --git a/science/netcdf4/files/patch-cxx4-ncGroup.cpp b/science/netcdf4/files/patch-cxx4-ncGroup.cpp
new file mode 100644
index 000000000000..bf0fc7d1bb05
--- /dev/null
+++ b/science/netcdf4/files/patch-cxx4-ncGroup.cpp
@@ -0,0 +1,29 @@
+--- cxx4/ncGroup.cpp.orig
++++ cxx4/ncGroup.cpp
+@@ -218,7 +218,7 @@
+
+ // search in child groups of the children
+ if(location == ChildrenOfChildrenGrps || location == AllChildrenGrps || location == AllGrps ) {
+- map<string,NcGroup>::iterator it;
++ multimap<string,NcGroup>::iterator it;
+ multimap<string,NcGroup> groups(getGroups(ChildrenGrps));
+ for (it=groups.begin();it!=groups.end();it++) {
+ multimap<string,NcGroup> childGroups(it->second.getGroups(AllChildrenGrps));
+@@ -1251,7 +1251,7 @@
+ // search in current group and parent groups.
+ NcGroup tmpGroup(*this);
+ multimap<string,NcDim>::iterator itD;
+- map<string,NcVar>::iterator itV;
++ multimap<string,NcVar>::iterator itV;
+ while(1) {
+ // get the collection of NcDim objects defined in this group.
+ multimap<string,NcDim> dimTmp(tmpGroup.getDims());
+@@ -1289,7 +1289,7 @@
+ // search in current group and parent groups.
+ multimap<string,NcDim>::iterator itD;
+ NcGroup tmpGroup(*this);
+- map<string,NcVar>::iterator itV;
++ multimap<string,NcVar>::iterator itV;
+ while(1) {
+ // get the collection of NcDim objects defined in this group.
+ multimap<string,NcDim> dimTmp(tmpGroup.getDims());
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index ca52f2fba4f9..752e9c76bbbb 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -21,8 +21,7 @@ CFLAGS+= -fPIC -DPIC
CONFIGURE_ENV= M4FLAGS=""
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_FORTRAN= yes
-USES= gmake
+USES= fortran gmake
MAN1= ncmpidiff.1 ncmpidump.1 ncmpigen.1
MAN3= pnetcdf.3
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index b684c1ed9364..2159c78cea71 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= psi3
PORTVERSION= 3.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= SF/psicode/psi/${PORTVERSION} \
http://www.psicode.org/doc/:doc \
@@ -45,17 +45,18 @@ LAPACK= -lalapack -lptcblas
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_FORTRAN= yes
+USES= fortran gmake
CONFIGURE_ARGS= --with-cc=${CC} \
--with-cxx=${CXX} \
--with-fc=${FC} \
+ --with-opt="${CFLAGS}" \
--with-lapack="${LAPACK}" \
--with-blas="${BLAS}" \
--datadir=${PREFIX}/share/psi3 \
--docdir=${WRKSRC}/tmpdoc/ \
--with-libdirs="-L${LOCALBASE}/lib" \
--with-libs="-lcompat"
+CFLAGS+= -Wno-error=return-type
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/science/psi3/files/patch-src-bin-clag-clag.cc b/science/psi3/files/patch-src-bin-clag-clag.cc
new file mode 100644
index 000000000000..936ec5520098
--- /dev/null
+++ b/science/psi3/files/patch-src-bin-clag-clag.cc
@@ -0,0 +1,10 @@
+--- src/bin/clag/clag.cc.orig
++++ src/bin/clag/clag.cc
+@@ -46,6 +46,7 @@
+ /***************************************************************************/
+ using namespace psi::clag;
+
++int
+ main(int argc, char **argv)
+ {
+
diff --git a/science/psi3/files/patch-src-bin-geom-geom.cc b/science/psi3/files/patch-src-bin-geom-geom.cc
new file mode 100644
index 000000000000..12a3a4afde46
--- /dev/null
+++ b/science/psi3/files/patch-src-bin-geom-geom.cc
@@ -0,0 +1,10 @@
+--- src/bin/geom/geom.cc.orig
++++ src/bin/geom/geom.cc
+@@ -115,6 +115,7 @@
+ void fill_sym_matrix(double **A, int size);
+ }} // namespace psi::geom
+
++int
+ main(int argc, char* argv[])
+ {
+ using namespace psi::geom;
diff --git a/science/psi3/files/patch-src-bin-nonbonded-nonbonded.cc b/science/psi3/files/patch-src-bin-nonbonded-nonbonded.cc
new file mode 100644
index 000000000000..c959af29e2f5
--- /dev/null
+++ b/science/psi3/files/patch-src-bin-nonbonded-nonbonded.cc
@@ -0,0 +1,10 @@
+--- src/bin/nonbonded/nonbonded.cc.orig
++++ src/bin/nonbonded/nonbonded.cc
+@@ -32,7 +32,6 @@
+ #include <physconst.h>
+ #include <psifiles.h>
+ #include <masses.h>
+-#include <string>
+
+ #include "globals.h"
+ #include "nonbonded.h"
diff --git a/science/psi3/files/patch-src-bin-transqt2-transqt.cc b/science/psi3/files/patch-src-bin-transqt2-transqt.cc
new file mode 100644
index 000000000000..1dd018025cf9
--- /dev/null
+++ b/science/psi3/files/patch-src-bin-transqt2-transqt.cc
@@ -0,0 +1,10 @@
+--- src/bin/transqt2/transqt.cc.orig
++++ src/bin/transqt2/transqt.cc
+@@ -65,6 +65,7 @@
+
+ using namespace psi::transqt2;
+
++int
+ main(int argc, char *argv[])
+ {
+ int nso, nmo, ntri_so, ntri_mo, nirreps;
diff --git a/science/psi3/files/patch-src-lib-libbasis-combinate.cc b/science/psi3/files/patch-src-lib-libbasis-combinate.cc
new file mode 100644
index 000000000000..3bae2543e928
--- /dev/null
+++ b/science/psi3/files/patch-src-lib-libbasis-combinate.cc
@@ -0,0 +1,12 @@
+--- src/lib/libbasis/combinate.cc.orig
++++ src/lib/libbasis/combinate.cc
+@@ -3,9 +3,7 @@
+ \brief Enter brief description of file here
+ */
+
+-extern "C" {
+ #include <libciomr/libciomr.h>
+-}
+
+ #include <stdexcept>
+ #include "combinate.h"
diff --git a/science/psi3/files/patch-src-lib-libipv1-ip_read.cc b/science/psi3/files/patch-src-lib-libipv1-ip_read.cc
new file mode 100644
index 000000000000..34d6e0b5e0bf
--- /dev/null
+++ b/science/psi3/files/patch-src-lib-libipv1-ip_read.cc
@@ -0,0 +1,20 @@
+--- src/lib/libipv1/ip_read.cc.orig
++++ src/lib/libipv1/ip_read.cc
+@@ -12,7 +12,9 @@
+ #include "ip_types.h"
+ #define _IP_ALLOCATE_GLOBAL_
+ #include "ip_global.h"
++extern "C" {
+ #include "y.tab.h"
++}
+
+ #include "ip_read.gbl"
+ #include "ip_read.lcl"
+@@ -27,7 +29,6 @@
+
+ /* The input for yacc. */
+ extern FILE *yyin;
+-extern void yyparse(void);
+
+ /* Set up static variables. */
+ /*static ip_keyword_tree_t *sub_tree = NULL;*/
diff --git a/science/psi3/files/patch-src-lib-libpsio-psio.hpp b/science/psi3/files/patch-src-lib-libpsio-psio.hpp
new file mode 100644
index 000000000000..789d4bd464fb
--- /dev/null
+++ b/science/psi3/files/patch-src-lib-libpsio-psio.hpp
@@ -0,0 +1,17 @@
+--- src/lib/libpsio/psio.hpp.orig
++++ src/lib/libpsio/psio.hpp
+@@ -157,10 +157,11 @@
+
+ };
+
+-extern "C" {
+- extern int psiopp_ipv1_config(PSIO *psio_obj);
+-}
+ extern PSIO* _default_psio_lib_;
+ }
+
++extern "C" {
++ int psiopp_ipv1_config(psi::PSIO *psio_obj);
++}
++
+ #endif /* header guard */
diff --git a/science/py-obspy/Makefile b/science/py-obspy/Makefile
index 2d3d0d0b7dae..ac915a9b69ff 100644
--- a/science/py-obspy/Makefile
+++ b/science/py-obspy/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0:${PORTSDIR}/databases/py-sqlalchemy
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_FORTRAN= yes
+USES= fortran
USE_ZIP= yes
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
diff --git a/science/py-scikit-learn/Makefile b/science/py-scikit-learn/Makefile
index 9b721eb141ba..43fa8cb3bb46 100644
--- a/science/py-scikit-learn/Makefile
+++ b/science/py-scikit-learn/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libcblas.so:${PORTSDIR}/math/cblas
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0.8.0:${PORTSDIR}/science/py-scipy
-USE_FORTRAN= yes
+USES= fortran
LATEST_LINK= py-${PORTNAME}
USE_PYTHON= yes
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index a0121b9e3b29..b2bcefafd75b 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${PYNUMPY} \
LATEST_LINK= py-${PORTNAME}
OPTIONSFILE= ${PORT_DBDIR}/py-numpy/options
-USE_FORTRAN= yes
+USES= fortran
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index 1d422248e60d..9b54f7f8f987 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -17,9 +17,8 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
-USES= gmake pkgconfig
+USES= fortran gmake pkgconfig
USE_BZIP2= yes
-USE_FORTRAN= yes
USE_GNOME= gtk20
USE_GL= yes
GNU_CONFIGURE= yes