aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-06-18 21:28:21 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-06-18 21:28:21 +0000
commit98807e08be7e890aaaea5710823a192ca318658b (patch)
treeb5eafc62566d24dd91bc595a371df1ffaece1c8c /science
parent8f52533f636733a36dda6f804c4784077da8a7f2 (diff)
downloadports-98807e08be7e890aaaea5710823a192ca318658b.tar.gz
ports-98807e08be7e890aaaea5710823a192ca318658b.zip
science/csvtk: Cross-platform and ultrafast toolkit for CSV/TSV processing
CSV/TSV formats are basic and ubiquitous file formats in both Bioinformatics and data science. People usually use spreadsheet software like MS Excel to process table data. However this is all by clicking and typing, which is not automated and is time-consuming to repeat, especially when you want to apply similar operations with different datasets or purposes. csvtk is convenient for rapid data investigation and also easy to integrate into analysis pipelines. It could save you lots of time in (not) writing Python/R scripts.
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/csvtk/Makefile19
-rw-r--r--science/csvtk/distinfo5
-rw-r--r--science/csvtk/pkg-descr13
4 files changed, 38 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 9e8caadfabb7..17618e77c829 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -55,6 +55,7 @@
SUBDIR += cp2k
SUBDIR += cp2k-data
SUBDIR += crf++
+ SUBDIR += csvtk
SUBDIR += dakota
SUBDIR += dalton
SUBDIR += dcl
diff --git a/science/csvtk/Makefile b/science/csvtk/Makefile
new file mode 100644
index 000000000000..6a7a41f3f99c
--- /dev/null
+++ b/science/csvtk/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= csvtk
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.23.0
+CATEGORIES= science
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Cross-platform and ultrafast toolkit for CSV/TSV processing
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/shenwei356/csvtk
+GO_TARGET= ./${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/science/csvtk/distinfo b/science/csvtk/distinfo
new file mode 100644
index 000000000000..0ff07fd83b5b
--- /dev/null
+++ b/science/csvtk/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1624051618
+SHA256 (go/science_csvtk/csvtk-v0.23.0/v0.23.0.mod) = 7c31a467710c872fa06c3cfce632c6f193b30caefe1d2503115485f9c8e626d2
+SIZE (go/science_csvtk/csvtk-v0.23.0/v0.23.0.mod) = 956
+SHA256 (go/science_csvtk/csvtk-v0.23.0/v0.23.0.zip) = bbaba0de0d95c1f8144dea5927abbfff6e6bdfba87d8c11d2cfefdde4cf9da76
+SIZE (go/science_csvtk/csvtk-v0.23.0/v0.23.0.zip) = 1718316
diff --git a/science/csvtk/pkg-descr b/science/csvtk/pkg-descr
new file mode 100644
index 000000000000..669e30d7b21f
--- /dev/null
+++ b/science/csvtk/pkg-descr
@@ -0,0 +1,13 @@
+CSV/TSV formats are basic and ubiquitous file formats in both Bioinformatics
+and data science.
+
+People usually use spreadsheet software like MS Excel to process table data.
+However this is all by clicking and typing, which is not automated and is
+time-consuming to repeat, especially when you want to apply similar operations
+with different datasets or purposes.
+
+csvtk is convenient for rapid data investigation and also easy to integrate
+into analysis pipelines. It could save you lots of time in (not) writing
+Python/R scripts.
+
+WWW: https://bioinf.shenwei.me/csvtk/