aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-02-12 17:28:11 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-02-12 17:28:11 +0000
commitc410d6e8ce437b2a0de8ba373c0387ed4cd3791c (patch)
tree372ac491f9db9a7f8c05085da0d9eef2e55f80c5 /science
parentde3daa4dbf8570ae3407d2312ccb5781b1ee650e (diff)
Notes
Diffstat (limited to 'science')
-rw-r--r--science/dlib-cpp/Makefile3
-rw-r--r--science/dlib-cpp/distinfo6
-rw-r--r--science/dlib-cpp/pkg-plist9
-rw-r--r--science/py-dlib/Makefile10
-rw-r--r--science/py-dlib/distinfo6
5 files changed, 19 insertions, 15 deletions
diff --git a/science/dlib-cpp/Makefile b/science/dlib-cpp/Makefile
index 7afe2d512d9d..2124eed70ef7 100644
--- a/science/dlib-cpp/Makefile
+++ b/science/dlib-cpp/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= dlib
-DISTVERSION= 19.17
-PORTREVISION= 3
+DISTVERSION= 19.19
CATEGORIES= science devel math
MASTER_SITES= http://dlib.net/files/
PKGNAMESUFFIX= -cpp
diff --git a/science/dlib-cpp/distinfo b/science/dlib-cpp/distinfo
index 1ca023e53b31..b06d88f5a91b 100644
--- a/science/dlib-cpp/distinfo
+++ b/science/dlib-cpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553928906
-SHA256 (dlib-19.17.tar.bz2) = 24772f9b2b99cf59a85fd1243ca1327cbf7340d83395b32a6c16a3a16136327b
-SIZE (dlib-19.17.tar.bz2) = 11271073
+TIMESTAMP = 1581525198
+SHA256 (dlib-19.19.tar.bz2) = 1decfe883635ce51acd72869cebe870ab9b85eb094d417adc8f48aa7b8c60cd7
+SIZE (dlib-19.19.tar.bz2) = 11238085
diff --git a/science/dlib-cpp/pkg-plist b/science/dlib-cpp/pkg-plist
index 67370cc46c52..8fec1b11ae70 100644
--- a/science/dlib-cpp/pkg-plist
+++ b/science/dlib-cpp/pkg-plist
@@ -72,6 +72,8 @@ include/dlib/cmake_utils/check_if_avx_instructions_executable_on_host.cmake
include/dlib/cmake_utils/check_if_neon_available.cmake
include/dlib/cmake_utils/check_if_sse4_instructions_executable_on_host.cmake
include/dlib/cmake_utils/find_blas.cmake
+include/dlib/cmake_utils/find_libjpeg.cmake
+include/dlib/cmake_utils/find_libpng.cmake
include/dlib/cmake_utils/set_compiler_specific_options.cmake
include/dlib/cmake_utils/tell_visual_studio_to_use_static_runtime.cmake
include/dlib/cmake_utils/use_cpp_11.cmake
@@ -209,10 +211,10 @@ include/dlib/entropy_encoder_model/entropy_encoder_model_kernel_c.h
include/dlib/error.h
include/dlib/external/cblas/cblas.h
include/dlib/external/cblas/cblas_f77.h
-include/dlib/external/libjpeg/jchuff.h
+include/dlib/external/libjpeg/cderror.h
+include/dlib/external/libjpeg/cdjpeg.h
include/dlib/external/libjpeg/jconfig.h
include/dlib/external/libjpeg/jdct.h
-include/dlib/external/libjpeg/jdhuff.h
include/dlib/external/libjpeg/jerror.h
include/dlib/external/libjpeg/jinclude.h
include/dlib/external/libjpeg/jmemsys.h
@@ -220,6 +222,7 @@ include/dlib/external/libjpeg/jmorecfg.h
include/dlib/external/libjpeg/jpegint.h
include/dlib/external/libjpeg/jpeglib.h
include/dlib/external/libjpeg/jversion.h
+include/dlib/external/libjpeg/transupp.h
include/dlib/external/libpng/png.h
include/dlib/external/libpng/pngconf.h
include/dlib/external/libpng/pngdebug.h
@@ -1033,6 +1036,8 @@ libdata/pkgconfig/dlib-1.pc
@dir include/dlib/cmake_utils/test_for_cpp11
@dir include/dlib/cmake_utils/test_for_cuda
@dir include/dlib/cmake_utils/test_for_cudnn
+@dir include/dlib/cmake_utils/test_for_libjpeg
+@dir include/dlib/cmake_utils/test_for_libpng
@dir include/dlib/cmake_utils/test_for_neon
@dir include/dlib/cmake_utils/test_for_sse4
@dir include/dlib/external/libpng/arm
diff --git a/science/py-dlib/Makefile b/science/py-dlib/Makefile
index 704beac65971..8ac6e534ea00 100644
--- a/science/py-dlib/Makefile
+++ b/science/py-dlib/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= dlib
-DISTVERSION= 19.17
-PORTREVISION= 5
+DISTVERSION= 19.19
CATEGORIES= science devel math python
MASTER_SITES= http://dlib.net/files/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,15 +13,16 @@ LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/dlib/LICENSE.txt
BUILD_DEPENDS= cmake:devel/cmake
-LIB_DEPENDS= ${PY_BOOST}
+LIB_DEPENDS= ${PY_BOOST} \
+ libpng.so:graphics/png
USES= compiler:c++11-lang pkgconfig python shebangfix \
tar:bzip2
USE_PYTHON= autoplist distutils
SHEBANG_FILES= python_examples/*.py
-OPTIONS_DEFINE= X11 JPEG PNG GIF SQLITE BLASLAPACK AVX
-OPTIONS_DEFAULT= X11 JPEG PNG GIF SQLITE
+OPTIONS_DEFINE= X11 JPEG GIF SQLITE BLASLAPACK AVX
+OPTIONS_DEFAULT= X11 JPEG GIF SQLITE
BLASLAPACK_DESC= Use Blas and Lapack libraries from ports
AVX_DESC= Use AVX instructions if supported by CPU
diff --git a/science/py-dlib/distinfo b/science/py-dlib/distinfo
index 82c7a3822ec8..685f932547b3 100644
--- a/science/py-dlib/distinfo
+++ b/science/py-dlib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553945723
-SHA256 (dlib-19.17.tar.bz2) = 24772f9b2b99cf59a85fd1243ca1327cbf7340d83395b32a6c16a3a16136327b
-SIZE (dlib-19.17.tar.bz2) = 11271073
+TIMESTAMP = 1581526176
+SHA256 (dlib-19.19.tar.bz2) = 1decfe883635ce51acd72869cebe870ab9b85eb094d417adc8f48aa7b8c60cd7
+SIZE (dlib-19.19.tar.bz2) = 11238085