aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-24 09:03:39 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-24 09:03:39 +0000
commit14be7bd191de0d71e48770d90738e82928fad6aa (patch)
tree55c9720bb839ecfb49fdc99ca948c3d8041f2dcd /science
parent8ca43586e1b57397f3b522748b91497f7c61df19 (diff)
downloadports-14be7bd191de0d71e48770d90738e82928fad6aa.tar.gz
ports-14be7bd191de0d71e48770d90738e82928fad6aa.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/dvc/Makefile2
-rw-r--r--science/py-GPy/Makefile2
-rw-r--r--science/py-GPyOpt/Makefile2
-rw-r--r--science/py-paramz/Makefile2
-rw-r--r--science/py-pysal/Makefile2
-rw-r--r--science/py-qspin/Makefile2
-rw-r--r--science/py-rmsd/Makefile2
-rw-r--r--science/py-scikit-sparse/Makefile2
-rw-r--r--science/py-scipy/Makefile2
-rw-r--r--science/py-scoria/Makefile2
-rw-r--r--science/pybrain/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/science/dvc/Makefile b/science/dvc/Makefile
index aa03b69b2ee4..3ee2da1a6edc 100644
--- a/science/dvc/Makefile
+++ b/science/dvc/Makefile
@@ -30,7 +30,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.3:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}schema>=0.6.7:devel/py-schema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zclockfile>0:devel/py-zclockfile@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist noflavors
NO_ARCH= yes
diff --git a/science/py-GPy/Makefile b/science/py-GPy/Makefile
index fd87fb461499..8da71a729b43 100644
--- a/science/py-GPy/Makefile
+++ b/science/py-GPy/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}paramz>=0.9.0:science/py-paramz@${PY_FLAVOR}
-USES= localbase python
+USES= localbase python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-GPyOpt/Makefile b/science/py-GPyOpt/Makefile
index 6c2f8640adfe..e198031cd5a6 100644
--- a/science/py-GPyOpt/Makefile
+++ b/science/py-GPyOpt/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.16:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}GPy>=1.8:science/py-GPy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
diff --git a/science/py-paramz/Makefile b/science/py-paramz/Makefile
index efd90d36e8a9..7267567c29f9 100644
--- a/science/py-paramz/Makefile
+++ b/science/py-paramz/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-pysal/Makefile b/science/py-pysal/Makefile
index db8f7ea434c6..d4c637194ea9 100644
--- a/science/py-pysal/Makefile
+++ b/science/py-pysal/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-qspin/Makefile b/science/py-qspin/Makefile
index 9cc18af7e8cb..ff58050b1bdf 100644
--- a/science/py-qspin/Makefile
+++ b/science/py-qspin/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/science/py-rmsd/Makefile b/science/py-rmsd/Makefile
index e44390cfdbdf..932ed007bb33 100644
--- a/science/py-rmsd/Makefile
+++ b/science/py-rmsd/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist concurrent
.include <bsd.port.mk>
diff --git a/science/py-scikit-sparse/Makefile b/science/py-scikit-sparse/Makefile
index 7092cba38063..bcc25abae422 100644
--- a/science/py-scikit-sparse/Makefile
+++ b/science/py-scikit-sparse/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYNUMPY} \
BUILD_DEPENDS= ${RUN_DEPENDS}
LIB_DEPENDS= libumfpack.so:math/suitesparse
-USES= fortran python
+USES= fortran python:3.6+
USE_PYTHON= distutils cython autoplist
CFLAGS+= -I${LOCALBASE}/include/suitesparse
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 3e666107a0b1..a8f17bcfd2c2 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
LIB_DEPENDS= libblas.so:math/blas
RUN_DEPENDS= ${PYNUMPY}
-USES= blaslapack:openblas fortran python shebangfix
+USES= blaslapack:openblas fortran python:3.6+ shebangfix
USE_PYTHON= autoplist concurrent distutils
FFLAGS+= -std=legacy
diff --git a/science/py-scoria/Makefile b/science/py-scoria/Makefile
index fbcbeec425f1..b907b442456e 100644
--- a/science/py-scoria/Makefile
+++ b/science/py-scoria/Makefile
@@ -14,7 +14,7 @@ LICENSE= APACHE20
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/science/pybrain/Makefile b/science/pybrain/Makefile
index fdc96c83b7e2..4213c5d8763f 100644
--- a/science/pybrain/Makefile
+++ b/science/pybrain/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>=0.7.1:science/py-scipy@${PY_FLAVOR}
USE_GITHUB= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils concurrent optsuffix
.include <bsd.port.mk>