aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-13 15:18:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-13 15:18:32 +0000
commit37b71248f9bb8d49a76dac072e206dfa2238e273 (patch)
treea3b1a32ea9792dfc79e2a58729a696ad2cbf03f6 /science
parentb19d234f125b30193a02dda637041457618aa278 (diff)
downloadports-37b71248f9bb8d49a76dac072e206dfa2238e273.tar.gz
ports-37b71248f9bb8d49a76dac072e206dfa2238e273.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-cdo/Makefile20
-rw-r--r--science/py-cdo/distinfo2
-rw-r--r--science/py-cdo/pkg-descr6
4 files changed, 29 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 6a828c9a0e82..1ad51a8c632c 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -135,6 +135,7 @@
SUBDIR += psychopy
SUBDIR += pulseview
SUBDIR += py-DendroPy
+ SUBDIR += py-cdo
SUBDIR += py-coards
SUBDIR += py-h5py
SUBDIR += py-hcluster
diff --git a/science/py-cdo/Makefile b/science/py-cdo/Makefile
new file mode 100644
index 000000000000..132cdf079ea4
--- /dev/null
+++ b/science/py-cdo/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cdo
+PORTVERSION= 1.2.3
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python binding to CDO (Climate Data Operators)
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${LOCALBASE}/bin/cdo:${PORTSDIR}/science/cdo
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+.include <bsd.port.mk>
diff --git a/science/py-cdo/distinfo b/science/py-cdo/distinfo
new file mode 100644
index 000000000000..f9bf9ac0b585
--- /dev/null
+++ b/science/py-cdo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cdo-1.2.3.tar.gz) = 4d035f3647a17bf6ee7092a07c298c3a1b7e8864242c7cb03b3d546dd381c3ed
+SIZE (cdo-1.2.3.tar.gz) = 8781
diff --git a/science/py-cdo/pkg-descr b/science/py-cdo/pkg-descr
new file mode 100644
index 000000000000..1b84ec9191e4
--- /dev/null
+++ b/science/py-cdo/pkg-descr
@@ -0,0 +1,6 @@
+Python binding to CDO (Climate Data Operators)
+
+GitHub repository at https://github.com/Try2Code/cdo-bindings
+
+WWW: https://code.zmaw.de/projects/cdo/wiki/Cdo%7Brbpy%7D
+WWW: https://pypi.python.org/pypi/cdo