aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
commit9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0 (patch)
tree043d479b1d60668b1d77568d010f6178e25bd6ba /science
parentc4823e883be563337dde9dde23949cde6c3fce0f (diff)
downloadports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.tar.gz
ports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/qcl/Makefile8
-rw-r--r--science/vis5d+/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/science/qcl/Makefile b/science/qcl/Makefile
index bb04b66cfbce..b8b40edb2f35 100644
--- a/science/qcl/Makefile
+++ b/science/qcl/Makefile
@@ -14,9 +14,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= huntting@glarp.com
COMMENT= A quantum computer simulator
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
post-install:
strip ${PREFIX}/bin/qcl
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index 635bb7c229bd..0a6aabe68f71 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -16,6 +16,12 @@ MASTER_SITE_SUBDIR= vis5d
MAINTAINER= ports@FreeBSD.org
COMMENT= An OpenGL-based volumetric visualization program for scientific datasets
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libmix.a:${PORTSDIR}/graphics/qslim \
convert:${PORTSDIR}/graphics/ImageMagick
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
@@ -35,4 +41,4 @@ INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_FLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>