aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2009-11-05 09:16:08 +0000
committerMaho Nakata <maho@FreeBSD.org>2009-11-05 09:16:08 +0000
commitee67784c257c0b8040c08c2b074f3e2fd91456ad (patch)
tree183e8eec03c4160dce1442a0e6032055a9448064 /science
parent6f1017f0c8679bf49d72c3093e9ed5e898e3f0a4 (diff)
downloadports-ee67784c257c0b8040c08c2b074f3e2fd91456ad.tar.gz
ports-ee67784c257c0b8040c08c2b074f3e2fd91456ad.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/libghemical/Makefile24
-rw-r--r--science/libghemical/distinfo6
-rw-r--r--science/libghemical/files/patch-configure.ac37
-rw-r--r--science/libghemical/pkg-plist7
4 files changed, 48 insertions, 26 deletions
diff --git a/science/libghemical/Makefile b/science/libghemical/Makefile
index 52bcfb7b7a8d..36873f19fc98 100644
--- a/science/libghemical/Makefile
+++ b/science/libghemical/Makefile
@@ -5,10 +5,9 @@
# $FreeBSD$
PORTNAME= libghemical
-PORTVERSION= 2.98
-PORTREVISION= 3
+PORTVERSION= 2.99.1
CATEGORIES= science
-MASTER_SITES= http://www.uku.fi/~thassine/projects/download/release20080731/ \
+MASTER_SITES= http://www.uku.fi/~thassine/projects/download/release20090911/ \
http://bioinformatics.org/ghemical/download/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -16,7 +15,9 @@ MAINTAINER= maho@FreeBSD.org
COMMENT= Support libraries of science/ghemical port
BUILD_DEPENDS= openbabel:${PORTSDIR}/science/openbabel \
- mopac7:${PORTSDIR}/biology/mopac
+ mopac7:${PORTSDIR}/biology/mopac \
+ intltool-update:${PORTSDIR}/textproc/intltool \
+ ld:${PORTSDIR}/devel/binutils
LIB_DEPENDS+= mpqc:${PORTSDIR}/science/mpqc \
f2c:${PORTSDIR}/lang/f2c
@@ -26,16 +27,15 @@ USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
USE_FORTRAN= yes
-USE_AUTOTOOLS= autoconf:262
-CONFIGURE_ARGS+= --enable-mpqc --enable-openbabel --enable-mopac7
-
+USE_AUTOTOOLS= autoconf:262 libtool:22 automake:110
+CONFIGURE_ARGS+= --enable-mpqc
PLIST_SUB= LIBGHEMICAL_VERSION="${PORTVERSION}"
-.if ${OSVERSION} >= 700000
-BROKEN= does not configure
-.endif
+.include <bsd.port.pre.mk>
+
+pre-build:
+ ${RM} -f ${WRKSRC}/libtool
+ ${LN} -sf ${LIBTOOL} ${WRKSRC}/libtool
.include <bsd.port.post.mk>
diff --git a/science/libghemical/distinfo b/science/libghemical/distinfo
index c55a9920b849..383c61fb57e7 100644
--- a/science/libghemical/distinfo
+++ b/science/libghemical/distinfo
@@ -1,3 +1,3 @@
-MD5 (libghemical-2.98.tar.gz) = 9ca4a60ba9b98f3c5003ee2e1a0ffeb0
-SHA256 (libghemical-2.98.tar.gz) = b4b0f037ed6632c84c6074badeb65cf52d04cbc5580e258275295b7520bd8bf6
-SIZE (libghemical-2.98.tar.gz) = 716300
+MD5 (libghemical-2.99.1.tar.gz) = d2dae2d7d786d3cba335cb29d85033ea
+SHA256 (libghemical-2.99.1.tar.gz) = f9b6df3c1e98a524f90644ebaaebb804792f391ca383c0f92b609060dc485d9f
+SIZE (libghemical-2.99.1.tar.gz) = 778812
diff --git a/science/libghemical/files/patch-configure.ac b/science/libghemical/files/patch-configure.ac
index be873d184dd0..bede93672d67 100644
--- a/science/libghemical/files/patch-configure.ac
+++ b/science/libghemical/files/patch-configure.ac
@@ -1,13 +1,30 @@
---- configure.ac~ 2008-07-31 19:22:53.000000000 +0900
-+++ configure.ac 2008-08-23 06:17:58.000000000 +0900
-@@ -89,8 +89,8 @@
- AC_CHECK_LIB(m,acos,,[AC_MSG_ERROR([math library missing])])
+--- configure.ac 2009-09-11 21:24:01.000000000 +0900
++++ configure.ac 2009-10-09 10:13:23.000000000 +0900
+@@ -121,15 +121,15 @@
+ AC_CHECK_LIB([m], [acos],, AC_MSG_ERROR([math library missing]))
- if test $WITH_MPQC = yes; then
-- AC_CHECK_LIB([blas], [main], , AC_MSG_ERROR([Cannot find blas library needed for MPQC support]))
-- AC_CHECK_LIB([lapack], [main], , AC_MSG_ERROR([Cannot find lapack library needed for MPQC support]))
-+# AC_CHECK_LIB([blas], [main], , AC_MSG_ERROR([Cannot find blas library needed for MPQC support]))
-+# AC_CHECK_LIB([lapack], [main], , AC_MSG_ERROR([Cannot find lapack library needed for MPQC support]))
+ if test $enable_mpqc = yes; then
+- AC_CHECK_LIB([blas], [main],, AC_MSG_ERROR([Cannot find blas library needed for MPQC support]))
+- AC_CHECK_LIB([lapack], [main],, AC_MSG_ERROR([Cannot find lapack library needed for MPQC support]))
++ #AC_CHECK_LIB([blas], [main],, AC_MSG_ERROR([Cannot find blas library needed for MPQC support]))
++ #AC_CHECK_LIB([lapack], [main],, AC_MSG_ERROR([Cannot find lapack library needed for MPQC support]))
AM_PATH_SC(1.2.5, HAVE_MPQC="yes", HAVE_MPQC="no")
if test "${HAVE_MPQC}" = "yes"; then
- AC_DEFINE([ENABLE_MPQC], [], [Define if you are building a version that interfaces directly with MPQC])
+ AC_DEFINE([ENABLE_MPQC],, [Define if you are building a version that interfaces directly with MPQC])
+ AC_DEFINE_UNQUOTED([SC_MAJOR_VERSION], [$SC_MAJOR_VERSION], [This is the major version of SC (MPQC's underlying library) found by configure])
+ AC_DEFINE_UNQUOTED([SC_MINOR_VERSION], [$SC_MINOR_VERSION], [This is the minor version of SC (MPQC's underlying library) found by configure])
+ AC_DEFINE_UNQUOTED([SC_MICRO_VERSION], [$SC_MICRO_VERSION], [This is the micro version of SC (MPQC's underlying library) found by configure])
+- CPPFLAGS="$CPPFLAGS $SC_CPPFLAGS"
++ CXXFLAGS="$CXXFLAGS $SC_CPPFLAGS"
+ LIBS="$LIBS $SC_LIBS"
+ else AC_MSG_ERROR([Cannot find proper SC version])
+ fi
+@@ -142,7 +142,7 @@
+ ##alt MOPAC7_CFLAGS=`$PKG_CONFIG --cflags libmopac7`
+ ##alt MOPAC7_LIBS=`$PKG_CONFIG --libs libmopac7`
+
+- CPPFLAGS="$CPPFLAGS $MOPAC7_CFLAGS"
++ CXXFLAGS="$CXXLAGS $MOPAC7_CFLAGS"
+ LIBS="$LIBS $MOPAC7_LIBS"
+
+ REQUISITIONS="$REQUISITIONS libmopac7"
diff --git a/science/libghemical/pkg-plist b/science/libghemical/pkg-plist
index b0d626939960..e40537460cd1 100644
--- a/science/libghemical/pkg-plist
+++ b/science/libghemical/pkg-plist
@@ -19,6 +19,7 @@ include/ghemical/geomopt.h
include/ghemical/intcrd.h
include/ghemical/libghemicaldefine.h
include/ghemical/libghemical-features.h
+include/ghemical/local_i18n.h
include/ghemical/mfinder.h
include/ghemical/model.h
include/ghemical/moldyn.h
@@ -36,7 +37,7 @@ include/ghemical/typerule.h
include/ghemical/utility.h
include/ghemical/v3d.h
@dirrm include/ghemical
-lib/libghemical.so.4
+lib/libghemical.so.5
lib/libghemical.so
lib/libghemical.la
lib/libghemical.a
@@ -68,6 +69,10 @@ share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52/parameters5.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default/loopdip.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default/looptor.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default/nonbonded.txt
+share/locale/fi/LC_MESSAGES/libghemical.mo
+share/locale/mk/LC_MESSAGES/libghemical.mo
+share/locale/pt_BR/LC_MESSAGES/libghemical.mo
+share/locale/sq/LC_MESSAGES/libghemical.mo
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52