aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-03 03:17:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-03 03:17:19 +0000
commita63f38bc0640a4068bb75f3a47549443f2934040 (patch)
treec25f16e279d111bbdccec651cfe390f8432326e7 /science
parent095fbe3e1ac5c36839609020469db604066f1593 (diff)
downloadports-a63f38bc0640a4068bb75f3a47549443f2934040.tar.gz
ports-a63f38bc0640a4068bb75f3a47549443f2934040.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile2
-rw-r--r--science/kst2/Makefile2
-rw-r--r--science/minc/Makefile3
-rw-r--r--science/minc2/Makefile4
-rw-r--r--science/netcdf/Makefile82
-rw-r--r--science/netcdf/distinfo4
-rw-r--r--science/netcdf/pkg-descr2
-rw-r--r--science/netcdf/pkg-plist70
-rw-r--r--science/py-netCDF4/Makefile4
-rw-r--r--science/pycdf/Makefile6
-rw-r--r--science/ruby-netcdf/Makefile2
-rw-r--r--science/rubygem-netcdf/Makefile1
-rw-r--r--science/v_sim/Makefile1
-rw-r--r--science/vmd/Makefile9
14 files changed, 78 insertions, 114 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index cf0fabbecc1d..ea67e9859bef 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 73d010bb61aa..c59f935609ed 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kst
DISTVERSION= 2.0.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
diff --git a/science/minc/Makefile b/science/minc/Makefile
index 799a03c7e423..9e90efc3bba2 100644
--- a/science/minc/Makefile
+++ b/science/minc/Makefile
@@ -12,13 +12,14 @@
PORTNAME= minc
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= science biology
MASTER_SITES= http://www.nitrc.org/frs/downloadlink.php/400/
MAINTAINER= jwbacon@tds.net
COMMENT= Medical Imaging NetCDF
-LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
+LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index 7963920933db..672e367e1b5a 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -12,7 +12,7 @@
PORTNAME= minc
PORTVERSION= 2.0.18
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= science biology
MASTER_SITES= http://packages.bic.mni.mcgill.ca/tgz/ \
@@ -24,7 +24,7 @@ COMMENT= Medical Imaging NetCDF
LICENSE= BSD
-LIB_DEPENDS= libnetcdf.so.4:${PORTSDIR}/science/netcdf \
+LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf \
libhdf5.so:${PORTSDIR}/science/hdf5
USE_AUTOTOOLS= libtool
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 19f9e1b9336f..e9c2389584a3 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -1,65 +1,65 @@
-# Created by: Thomas Gellekum <tg@FreeBSD.org>
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
# $FreeBSD$
PORTNAME= netcdf
-PORTVERSION= 3.6.3
-PORTREVISION?= 7
+PORTVERSION= 4.3.2
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
LOCAL/sunpoet
-PKGNAMESUFFIX?= 3
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT?= Library for machine-independent, array-oriented data access
+COMMENT= C library for machine-independent, array-oriented data access
-CONFLICTS= hdf-4.* netcdf-4.*
-PORTSCOUT= limit:^3\.
+LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
-CONFIGURE_ARGS= --enable-shared
-CPPFLAGS+= -I${LOCALBASE}/include -fPIC -DPIC
-GNU_CONFIGURE= yes
-USES= gmake libtool:keepla
+CONFLICTS_INSTALL= hdf-4.[0-9]* netcdf-3.[0-9]* netcdf3-3.[0-9]*
+PORTSCOUT= limit:^4\.
+
+OPTIONS_DEFINE= DAP DOCS DOXYGEN SZIP
+OPTIONS_DEFAULT=DAP SZIP
+DAP_DESC= Build DAP client and remote testing
+SZIP_DESC= SZIP support (required if HDF5 was built with SZIP)
+
+CFLAGS+= -I${WRKSRC}/include -I${LOCALBASE}/include -fPIC -DPIC
+CMAKE_ARGS= -DHDF5_INCLUDE_DIRS=${LOCALBASE} -DUSE_HDF5=ON -DZLIB_INCLUDE_DIRS=/usr
+LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
+USES= cmake pathfix
-INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
- netcdf-install netcdf-tutorial
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+PORTDOCS= *
-OPTIONS_DEFINE= FORTRAN DOCS
-FORTRAN_DESC= Build library for Fortran
+DAP_CMAKE_OFF= -DENABLE_DAP=OFF -DENABLE_DAP_REMOTE_TESTS=OFF
+DAP_CMAKE_ON= -DCURL_INCLUDE_DIRS=${LOCALBASE} -DENABLE_DAP=ON
+DAP_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+DOXYGEN_CMAKE_OFF= -DENABLE_DOXYGEN=OFF
+DOXYGEN_CMAKE_ON= -DENABLE_DOXYGEN=ON
+SZIP_CMAKE_OFF= -DUSE_SZIP=OFF
+SZIP_CMAKE_ON= -DSZIP_DIR=${LOCALBASE} -DSZIP_INCLUDE_DIRS=${LOCALBASE} -DUSE_SZIP=ON
+SZIP_LDFLAGS= -lsz
+SZIP_LIB_DEPENDS= libsz.so:${PORTSDIR}/science/szip
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+=--enable-docs-install
-.else
-CONFIGURE_ARGS+=--disable-docs-install
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/man4/d; s|share/cmake|&/Modules|; s|$${CMAKE_INSTALL_LIBDIR}/pkgconfig|libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/libsrc/CMakeLists.txt ${WRKSRC}/ncdump/CMakeLists.txt ${WRKSRC}/ncgen/CMakeLists.txt ${WRKSRC}/ncgen3/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|mmap|_&|g' ${WRKSRC}/nc_test/tst_diskless.c ${WRKSRC}/nc_test/tst_diskless3.c
-.if ${PORT_OPTIONS:MFORTRAN}
-CPPFLAGS+= -DpgiFortran
-CONFLICTS+= netcdf-3.*
-PLIST_SUB+= FORTRAN=""
-USES+= fortran
-.else
-CONFIGURE_ARGS+=--disable-f77 --disable-f90
-CONFLICTS+= netcdf-ftn-3.*
-PLIST_SUB+= FORTRAN="@comment "
+post-build:
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
+ @cd ${WRKSRC}/man4 && ${LOCALBASE}/bin/doxygen .
.endif
-post-patch:
- @${REINPLACE_CMD} -e \
- '291 s/\(html_docs)\).*/\1/' \
- ${WRKSRC}/man/Makefile.in
- @${REINPLACE_CMD} -e \
- '271 s/\(info_docs\).*/html_docs\)/' \
- ${WRKSRC}/man4/Makefile.in
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '790 s/install-docDATA //' \
- ${WRKSRC}/man/Makefile.in
+post-install:
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/man4/html/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
-regression-test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+regression-test test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
.include <bsd.port.mk>
diff --git a/science/netcdf/distinfo b/science/netcdf/distinfo
index cca29d29a70f..71fc034f6aa7 100644
--- a/science/netcdf/distinfo
+++ b/science/netcdf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netcdf-3.6.3.tar.gz) = afa1a0fa82b9ea33b035257b6e9662b22e135f98b2fd93d5cf030320dfc3ffa1
-SIZE (netcdf-3.6.3.tar.gz) = 11572512
+SHA256 (netcdf-4.3.2.tar.gz) = 57086b4383ce9232f05aad70761c2a6034b1a0c040260577d369b3bbfe6d248e
+SIZE (netcdf-4.3.2.tar.gz) = 5013938
diff --git a/science/netcdf/pkg-descr b/science/netcdf/pkg-descr
index fa18f64fac06..08839b648c08 100644
--- a/science/netcdf/pkg-descr
+++ b/science/netcdf/pkg-descr
@@ -6,4 +6,6 @@ library, and format support the creation, access, and sharing of
scientific data. The netCDF software was developed at the Unidata
Program Center in Boulder, Colorado.
+Git repository: https://github.com/Unidata/netcdf-c
+
WWW: http://www.unidata.ucar.edu/software/netcdf/
diff --git a/science/netcdf/pkg-plist b/science/netcdf/pkg-plist
index 3d67360110f0..a24e0519c3d4 100644
--- a/science/netcdf/pkg-plist
+++ b/science/netcdf/pkg-plist
@@ -1,63 +1,21 @@
+bin/nc-config
+bin/nccopy
bin/ncdump
bin/ncgen
-include/ncvalues.h
+bin/ncgen3
include/netcdf.h
-include/netcdf.hh
-%%FORTRAN%%include/netcdf.inc
-%%FORTRAN%%include/netcdf.mod
-include/netcdfcpp.h
-%%FORTRAN%%include/typesizes.mod
-lib/libnetcdf.a
-lib/libnetcdf.la
lib/libnetcdf.so
-lib/libnetcdf.so.4
-lib/libnetcdf.so.4.0.0
-lib/libnetcdf_c++.a
-lib/libnetcdf_c++.la
-lib/libnetcdf_c++.so
-lib/libnetcdf_c++.so.4
-lib/libnetcdf_c++.so.4.0.0
-%%FORTRAN%%lib/libnetcdff.a
-%%FORTRAN%%lib/libnetcdff.la
-%%FORTRAN%%lib/libnetcdff.so
-%%FORTRAN%%lib/libnetcdff.so.4
-%%FORTRAN%%lib/libnetcdff.so.4.0.0
+lib/libnetcdf.so.%%PORTVERSION%%
+lib/libnetcdf.so.7.2.0
+libdata/pkgconfig/netcdf.pc
+man/man1/nccopy.1.gz
man/man1/ncdump.1.gz
man/man1/ncgen.1.gz
+man/man1/ncgen3.1.gz
man/man3/netcdf.3.gz
-%%FORTRAN%%man/man3/netcdf_f77.3.gz
-%%FORTRAN%%man/man3/netcdf_f90.3.gz
-%%PORTDOCS%%%%DOCSDIR%%/ncgen-man-1.html
-%%PORTDOCS%%%%DOCSDIR%%/ncdump-man-1.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.ps
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-c.txt
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.ps
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-cxx.txt
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.ps
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f77.txt
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.ps
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-f90.txt
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.ps
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-install.txt
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-man-3.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.ps
-%%PORTDOCS%%%%DOCSDIR%%/netcdf-tutorial.txt
-%%PORTDOCS%%%%DOCSDIR%%/netcdf_f77-man.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf_f90-man.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf.html
-%%PORTDOCS%%%%DOCSDIR%%/netcdf.pdf
-%%PORTDOCS%%%%DOCSDIR%%/netcdf.ps
-%%PORTDOCS%%%%DOCSDIR%%/netcdf.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/cmake/Modules/netcdf-config-version.cmake
+share/cmake/Modules/netcdf-config.cmake
+share/cmake/Modules/netcdf-targets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/Modules/netcdf-targets.cmake
+@dirrmtry share/cmake/Modules
+@dirrmtry share/cmake
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
index 97fa148fba0b..098e0f26c7c1 100644
--- a/science/py-netCDF4/Makefile
+++ b/science/py-netCDF4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netCDF4
PORTVERSION= 1.0.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science python
MASTER_SITES= GOOGLE_CODE
PROJECTHOST= netcdf4-python
@@ -16,7 +16,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5 \
- libnetcdf.so:${PORTSDIR}/science/netcdf4
+ libnetcdf.so:${PORTSDIR}/science/netcdf
RUN_DEPENDS= ${PYNUMPY}
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/science/pycdf/Makefile b/science/pycdf/Makefile
index ba994549a14e..7a14f14b273a 100644
--- a/science/pycdf/Makefile
+++ b/science/pycdf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pycdf
PORTVERSION= 0.6.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science python
MASTER_SITES= SF/pysclint/${PORTNAME}/${PORTNAME}-${PORTVERSION}b
DISTNAME= ${PORTNAME}-0.6-3b
@@ -11,8 +11,8 @@ DISTNAME= ${PORTNAME}-0.6-3b
MAINTAINER= wenheping@gmail.com
COMMENT= A Python Interface to the Unidata NetCDF Library
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
- ${LOCALBASE}/lib/libnetcdf.so:${PORTSDIR}/science/netcdf
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
RUN_DEPENDS:= ${BUILD_DEPENDS}
LDFLAGS+= "-L${LOCALBASE}/lib"
diff --git a/science/ruby-netcdf/Makefile b/science/ruby-netcdf/Makefile
index 69c5ad0ccd5a..541d7f153f06 100644
--- a/science/ruby-netcdf/Makefile
+++ b/science/ruby-netcdf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netcdf
PORTVERSION= 0.6.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science ruby
MASTER_SITES= http://ruby.gfd-dennou.org/products/ruby-netcdf/release/ \
http://dennou-h.gfd-dennou.org/library/ruby/products/ruby-netcdf/release/ \
diff --git a/science/rubygem-netcdf/Makefile b/science/rubygem-netcdf/Makefile
index a239c889b827..24b9f31c0897 100644
--- a/science/rubygem-netcdf/Makefile
+++ b/science/rubygem-netcdf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netcdf
PORTVERSION= 0.6.6.1
+PORTREVISION= 1
CATEGORIES= science rubygems
MASTER_SITES= RG
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index ab18ec380e2f..1805a485482c 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= v_sim
PORTVERSION= 3.7.1
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www-drfmc.cea.fr/sp2m/L_Sim/V_Sim/download/
diff --git a/science/vmd/Makefile b/science/vmd/Makefile
index 3a64403fc9da..144e32de106c 100644
--- a/science/vmd/Makefile
+++ b/science/vmd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vmd
DISTVERSION= 1.9.1
+PORTREVISION= 1
CATEGORIES= science graphics python tcl tk
MASTER_SITES= http://jedi.ks.uiuc.edu/~johns/raytracer/files/0.99b2/:tachyon \
http://www.photonlimited.com/~johns/tachyon/files/0.99b2/:tachyon \
@@ -16,10 +17,10 @@ COMMENT= A molecular visualization program
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend \
${PYNUMERIC}
-LIB_DEPENDS= tcl85:${PORTSDIR}/lang/tcl85 \
- tk85:${PORTSDIR}/x11-toolkits/tk85 \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- netcdf:${PORTSDIR}/science/netcdf
+LIB_DEPENDS= libtcl85.so:${PORTSDIR}/lang/tcl85 \
+ libtk85.so:${PORTSDIR}/x11-toolkits/tk85 \
+ libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
+ libnetcdf.so:${PORTSDIR}/science/netcdf
RUN_DEPENDS= ${PYNUMERIC}
USES= gmake perl5