aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-08 00:24:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-08 00:24:55 +0000
commit304021be4a1446c272694406b06f5394acea8235 (patch)
tree2771e7ca300ecea3a901bf9b8c925cd7718f6418 /science
parent518bb5b841de5ad48c59343daf0f60623f59c819 (diff)
downloadports-304021be4a1446c272694406b06f5394acea8235.tar.gz
ports-304021be4a1446c272694406b06f5394acea8235.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/libccp4/Makefile31
-rw-r--r--science/libccp4/distinfo3
-rw-r--r--science/libccp4/pkg-descr12
-rw-r--r--science/libccp4/pkg-plist44
5 files changed, 91 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 985a4e52924a..ca7bd7a274a8 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -89,6 +89,7 @@
SUBDIR += kst2
SUBDIR += lamprop
SUBDIR += libaec
+ SUBDIR += libccp4
SUBDIR += libcint
SUBDIR += libctl
SUBDIR += libefp
diff --git a/science/libccp4/Makefile b/science/libccp4/Makefile
new file mode 100644
index 000000000000..9d00c608b7ff
--- /dev/null
+++ b/science/libccp4/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= libccp4
+DISTVERSION= 6.5.1
+CATEGORIES= science
+MASTER_SITES= ftp://ftp.ccp4.ac.uk/opensource/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Protein X-ray crystallography toolkit
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LESSER
+
+LIB_DEPENDS= libmmdb2.so:science/mmdb2
+
+USES= fortran gmake libtool localbase:ldflags
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared --disable-static
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+CFLAGS+= -fPIC
+FFLAGS+= -fPIC
+
+post-configure:
+ ${REINPLACE_CMD} -e 's| -Wl,--as-needed||; s| -Wl,--no-as-needed||' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^archive_cmds=|wl="-Wl,"; archive_cmds=|' ${WRKSRC}/libtool # wl is missing otherwise for some reason
+
+.include <bsd.port.mk>
diff --git a/science/libccp4/distinfo b/science/libccp4/distinfo
new file mode 100644
index 000000000000..603fa7715ef4
--- /dev/null
+++ b/science/libccp4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531007069
+SHA256 (libccp4-6.5.1.tar.gz) = 280b473d950cdf8837ef66147ec581104298b892399bd856f13b096f2395dbe5
+SIZE (libccp4-6.5.1.tar.gz) = 947521
diff --git a/science/libccp4/pkg-descr b/science/libccp4/pkg-descr
new file mode 100644
index 000000000000..6b560a6582e1
--- /dev/null
+++ b/science/libccp4/pkg-descr
@@ -0,0 +1,12 @@
+CCP4 exists to produce and support a world-leading, integrated suite of programs
+that allows researchers to determine macromolecular structures by X-ray
+crystallography, and other biophysical techniques. CCP4 aims to develop and
+support the development of cutting edge approaches to experimental determination
+and analysis of protein structure, and integrate these approaches into the
+suite. CCP4 is a community based resource that supports the widest possible
+researcher community, embracing academic, not for profit, and for profit
+research. CCP4 aims to play a key role in the education and training of
+scientists in experimental structural biology. It encourages the wide
+dissemination of new ideas, techniques and practice.
+
+WWW: https://www.ccp4.ac.uk/
diff --git a/science/libccp4/pkg-plist b/science/libccp4/pkg-plist
new file mode 100644
index 000000000000..be093c7c61b1
--- /dev/null
+++ b/science/libccp4/pkg-plist
@@ -0,0 +1,44 @@
+include/ccp4/ccp4_array.h
+include/ccp4/ccp4_errno.h
+include/ccp4/ccp4_file_err.h
+include/ccp4/ccp4_fortran.h
+include/ccp4/ccp4_general.h
+include/ccp4/ccp4_parser.h
+include/ccp4/ccp4_program.h
+include/ccp4/ccp4_spg.h
+include/ccp4/ccp4_sysdep.h
+include/ccp4/ccp4_types.h
+include/ccp4/ccp4_unitcell.h
+include/ccp4/ccp4_utils.h
+include/ccp4/ccp4_vars.h
+include/ccp4/cmap_data.h
+include/ccp4/cmap_errno.h
+include/ccp4/cmap_header.h
+include/ccp4/cmap_labels.h
+include/ccp4/cmap_skew.h
+include/ccp4/cmap_stats.h
+include/ccp4/cmaplib.h
+include/ccp4/cmaplib_f.h
+include/ccp4/cmtzlib.h
+include/ccp4/csymlib.h
+include/ccp4/cvecmat.h
+include/ccp4/library_file.h
+include/ccp4/mtzdata.h
+include/ccp4/overview.h
+include/ccp4/pack_c.h
+include/ccp4/w32mvs.h
+lib/libccp4c.so
+lib/libccp4c.so.0
+lib/libccp4c.so.0.0.0
+lib/libccp4f.so
+lib/libccp4f.so.0
+lib/libccp4f.so.0.0.0
+libdata/pkgconfig/libccp4c.pc
+libdata/pkgconfig/libccp4f.pc
+share/atomsf.lib
+share/atomsf_electron.lib
+share/atomsf_neutron.lib
+share/ccp4/ccp4-config.cmake
+share/font84.ascii
+share/syminfo.lib
+share/symop.lib