aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-30 13:29:58 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-30 13:29:58 +0000
commit4aa27da2314f1027b11a5138c0e2aedd03dc7cba (patch)
tree30ea3fe495e40122ec8a96f715869110005d5301 /science
parentaf3595a70d6e9a0bdba311ee5d23cc724c1ba2e8 (diff)
downloadports-4aa27da2314f1027b11a5138c0e2aedd03dc7cba.tar.gz
ports-4aa27da2314f1027b11a5138c0e2aedd03dc7cba.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/abinit/Makefile2
-rw-r--r--science/agrum/Makefile2
-rw-r--r--science/py-MDAnalysisTests/Makefile2
-rw-r--r--science/py-abipy/Makefile2
-rw-r--r--science/py-access/Makefile2
-rw-r--r--science/py-chainer-chemistry/Makefile2
-rw-r--r--science/py-esda/Makefile2
-rw-r--r--science/py-libpysal/Makefile2
-rw-r--r--science/py-lifelines/Makefile2
-rw-r--r--science/py-oddt/Makefile2
-rw-r--r--science/py-pymatgen/Makefile2
-rw-r--r--science/py-segregation/Makefile2
-rw-r--r--science/py-tobler/Makefile2
13 files changed, 13 insertions, 13 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index d03141fe424f..cd3868143ba2 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -35,7 +35,7 @@ TEST_DEPENDS= ${PYNUMPY} \
libyaml>0:textproc/libyaml
USES= autoreconf:build blaslapack:netlib fortran gmake gnome localbase:ldflags \
- python:3.6+ shebangfix
+ python:3.7+ shebangfix
USE_GITHUB= yes
USE_GNOME= libxml2
SHEBANG_FILES= config/scripts/* doc/tutorial/paral_gspw_assets/abinit.sub.*
diff --git a/science/agrum/Makefile b/science/agrum/Makefile
index 6f16730d9b98..55d2a7fe7016 100644
--- a/science/agrum/Makefile
+++ b/science/agrum/Makefile
@@ -35,7 +35,7 @@ ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
OPENMP_CMAKE_BOOL= USE_OPENMP
PYTHON_CMAKE_BOOL= BUILD_PYTHON
-PYTHON_USES= python
+PYTHON_USES= python:3.7+
PYTHON_PLIST_SUB= PYTHON_VER_MAJ=${PYTHON_VER:R}
PYTHON_RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}configparser>0:devel/py-configparser@${PY_FLAVOR} \
diff --git a/science/py-MDAnalysisTests/Makefile b/science/py-MDAnalysisTests/Makefile
index 1f409fb05898..58908bdbb7d5 100644
--- a/science/py-MDAnalysisTests/Makefile
+++ b/science/py-MDAnalysisTests/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}psutil>=4.0.2:sysutils/py-psutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=2.0.0:devel/py-mock@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-abipy/Makefile b/science/py-abipy/Makefile
index 35a77a936ffd..48e4afc9c39b 100644
--- a/science/py-abipy/Makefile
+++ b/science/py-abipy/Makefile
@@ -29,7 +29,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${PY_FLAVOR}
-USES= python:3.6+ shebangfix
+USES= python:3.7+ shebangfix
USE_GITHUB= yes
GH_ACCOUNT= abinit
SHEBANG_GLOB= *.py
diff --git a/science/py-access/Makefile b/science/py-access/Makefile
index 1f8b57bfc288..4a0a0b19a7a7 100644
--- a/science/py-access/Makefile
+++ b/science/py-access/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.3,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=0.23.4,1:math/py-pandas@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-chainer-chemistry/Makefile b/science/py-chainer-chemistry/Makefile
index 3b920fa8a886..94b61c8e7c61 100644
--- a/science/py-chainer-chemistry/Makefile
+++ b/science/py-chainer-chemistry/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scikit-learn>0:science/py-scikit-learn@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.7+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-esda/Makefile b/science/py-esda/Makefile
index 3b81594446dd..4445aafbe6ab 100644
--- a/science/py-esda/Makefile
+++ b/science/py-esda/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libpysal>=0:science/py-libpysal@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}scikit-learn>=0:science/py-scikit-learn@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-libpysal/Makefile b/science/py-libpysal/Makefile
index e9174adb5e7a..8fe42bb9ad95 100644
--- a/science/py-libpysal/Makefile
+++ b/science/py-libpysal/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_F
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-lifelines/Makefile b/science/py-lifelines/Makefile
index 7bd82b0dc488..a7103264540a 100644
--- a/science/py-lifelines/Makefile
+++ b/science/py-lifelines/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}bottleneck>=1.0:math/py-bottleneck@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}autograd>=1.2:math/py-autograd@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/science/py-oddt/Makefile b/science/py-oddt/Makefile
index 2d2f6144a0a6..a08a147e3634 100644
--- a/science/py-oddt/Makefile
+++ b/science/py-oddt/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= python:3.5+
+USES= python:3.7+
USE_GITHUB= yes
USE_PYTHON= distutils concurrent autoplist
diff --git a/science/py-pymatgen/Makefile b/science/py-pymatgen/Makefile
index 948c0ea6a279..6a7fe80dd90c 100644
--- a/science/py-pymatgen/Makefile
+++ b/science/py-pymatgen/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${PY_FLAVOR}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}netCDF4>0:science/py-netCDF4@${PY_FLAVOR} # see https://github.com/materialsproject/pymatgen/issues/1386
-USES= compiler:c++11-lang python:3.5+
+USES= compiler:c++11-lang python:3.7+
USE_PYTHON= distutils concurrent autoplist
.include <bsd.port.mk>
diff --git a/science/py-segregation/Makefile b/science/py-segregation/Makefile
index 85e4a360f47b..e7f7e7fe3b30 100644
--- a/science/py-segregation/Makefile
+++ b/science/py-segregation/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geopandas>=0:graphics/py-geopandas@${PY_FLAV
${PYTHON_PKGNAMEPREFIX}seaborn>=0:math/py-seaborn@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tqdm>=0:misc/py-tqdm@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-tobler/Makefile b/science/py-tobler/Makefile
index 517ec42e4f83..714d15c172bd 100644
--- a/science/py-tobler/Makefile
+++ b/science/py-tobler/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geopandas>=0:graphics/py-geopandas@${PY_FLAV
${PYTHON_PKGNAMEPREFIX}statsmodels>=0:math/py-statsmodels@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tqdm>=0:misc/py-tqdm@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes