aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-10 03:08:59 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-10 03:08:59 +0000
commitdb0bf94b4c6b56150111c95cf6af0fcb2f1b8d06 (patch)
tree3d7b9b3c03997b86c2b05bf4090d5a10a40ce190 /science
parent9c41eb19da2ca97b5a677e56b81fda8d6cfafe29 (diff)
downloadports-db0bf94b4c6b56150111c95cf6af0fcb2f1b8d06.tar.gz
ports-db0bf94b4c6b56150111c95cf6af0fcb2f1b8d06.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/minc/Makefile4
-rw-r--r--science/minc2/Makefile3
-rw-r--r--science/netcdf/Makefile28
-rw-r--r--science/netcdf/distinfo6
-rw-r--r--science/netcdf/files/patch-Makefile20
-rw-r--r--science/netcdf/files/patch-rules.make19
-rw-r--r--science/netcdf/pkg-plist7
-rw-r--r--science/netcdf4/Makefile28
-rw-r--r--science/netcdf4/distinfo6
-rw-r--r--science/netcdf4/files/patch-Makefile20
-rw-r--r--science/netcdf4/files/patch-rules.make19
-rw-r--r--science/netcdf4/pkg-plist7
-rw-r--r--science/ruby-netcdf/Makefile3
-rw-r--r--science/v_sim/Makefile3
-rw-r--r--science/vis5d+/Makefile4
16 files changed, 46 insertions, 135 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index fdd4633a762c..da9bc8892234 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnudatalanguage
PORTVERSION= 0.8.11
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -69,7 +69,7 @@ CONFIGURE_ARGS+=--with-hdf5=no
.endif
.if !defined(WITHOUT_NETCDF)
-LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
+LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
CONFIGURE_ARGS+=--with-netcdf=${LOCALBASE} --with-hdf=no
.else
CONFIGURE_ARGS+=--with-netcdf=no
diff --git a/science/minc/Makefile b/science/minc/Makefile
index cb85517664ec..52a7497bd20b 100644
--- a/science/minc/Makefile
+++ b/science/minc/Makefile
@@ -17,7 +17,7 @@
PORTNAME= minc
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science biology
MASTER_SITES= http://www.bic.mni.mcgill.ca/software/distribution/packages/ \
http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
@@ -25,7 +25,7 @@ MASTER_SITES= http://www.bic.mni.mcgill.ca/software/distribution/packages/ \
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT= Medical Imaging NetCDF
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
+LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index 9fbb9f3dc453..35050f9e13ef 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -17,6 +17,7 @@
PORTNAME= minc
PORTVERSION= 2.0.09
+PORTREVISION= 1
CATEGORIES= science biology
MASTER_SITES= http://www.bic.mni.mcgill.ca/users/bert/ \
http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
@@ -24,7 +25,7 @@ MASTER_SITES= http://www.bic.mni.mcgill.ca/users/bert/ \
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT= Medical Imaging NetCDF
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf \
+LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf \
hdf5.0:${PORTSDIR}/science/hdf5
USE_AUTOTOOLS= libtool:15
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 0b4465af8dad..e93513e47bbb 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netcdf
-PORTVERSION= 3.6.1
+PORTVERSION= 3.6.2
CATEGORIES= science
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/ \
http://sunpoet.net/distfiles/
@@ -15,31 +15,23 @@ MASTER_SITE_SUBDIR= . old
MAINTAINER= sunpoet@sunpoet.net
COMMENT= Library for machine-independent, array-oriented data access
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
CONFLICTS= hdf-4.*
-CONFIGURE_ENV= CPPFLAGS="-fPIC -DPIC -Df2cFortran"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-shared --mandir=${PREFIX}/man --disable-f77
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
+
+USE_BZIP2= YES
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= ncdump.1 ncgen.1
-MAN3= netcdf.3 netcdf.3f
-
-post-build:
- @(cd ${WRKSRC}/libsrc && \
- ${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
- @(cd ${WRKSRC}/cxx && \
- ${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
+MAN3= netcdf.3
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/ncdump
- @${STRIP_CMD} ${PREFIX}/bin/ncgen
- ${INSTALL_DATA} ${WRKSRC}/libsrc/libnetcdf.so ${PREFIX}/lib/libnetcdf.so.1
- ${LN} -sf libnetcdf.so.1 ${PREFIX}/lib/libnetcdf.so
- ${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
- ${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
+ @${STRIP_CMD} ${PREFIX}/bin/ncdump ${PREFIX}/bin/ncgen
+ ${LN} -fs libnetcdf.so.4 ${PREFIX}/lib/libnetcdf.so
+ ${LN} -fs libnetcdf_c++.so.4 ${PREFIX}/lib/libnetcdf_c++.so
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in COPYRIGHT README RELEASE_NOTES
diff --git a/science/netcdf/distinfo b/science/netcdf/distinfo
index fa988c3f6686..63fec67ffd48 100644
--- a/science/netcdf/distinfo
+++ b/science/netcdf/distinfo
@@ -1,3 +1,3 @@
-MD5 (netcdf-3.6.1.tar.gz) = 07a9db424337c5e4833fb84136e09a1e
-SHA256 (netcdf-3.6.1.tar.gz) = 15c42a2c698c4e42ee17720701168711d86e97e97311223015d07853fb09249f
-SIZE (netcdf-3.6.1.tar.gz) = 883888
+MD5 (netcdf-3.6.2.tar.bz2) = 1eca0ea1e81e14ebc5bb93e5dd25c364
+SHA256 (netcdf-3.6.2.tar.bz2) = 0468f1d9ab0fbad6edb957d8fb597010cb5c546c6de6752c9a63b0e0f194e564
+SIZE (netcdf-3.6.2.tar.bz2) = 4580511
diff --git a/science/netcdf/files/patch-Makefile b/science/netcdf/files/patch-Makefile
deleted file mode 100644
index 00d94fb843f1..000000000000
--- a/science/netcdf/files/patch-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig Mon Feb 27 00:43:59 2006
-+++ Makefile Sat Dec 23 05:33:43 2006
-@@ -117,6 +117,8 @@
- ncgen/distclean \
- cxx/clean \
- cxx/distclean \
-+fortran/install \
-+fortran/uninstall \
- :
- @subdir=`echo $@ | sed 's,/.*,,'`; \
- target=`echo $@ | sed 's,.*/,,'`; \
-@@ -124,8 +126,6 @@
-
- fortran/all \
- fortran/test \
--fortran/install \
--fortran/uninstall \
- nf_test/all \
- nf_test/test \
- :
diff --git a/science/netcdf/files/patch-rules.make b/science/netcdf/files/patch-rules.make
deleted file mode 100644
index 4c9e564dc054..000000000000
--- a/science/netcdf/files/patch-rules.make
+++ /dev/null
@@ -1,19 +0,0 @@
---- rules.make.orig Sat Dec 18 05:34:48 2004
-+++ rules.make Thu Jan 6 15:12:59 2005
-@@ -145,14 +145,8 @@
- $(INSTALL) $(MANUAL) $@
- $(MANDIR)/man3/$(MANUAL): $(MANDIR)/man3 $(MANUAL)
- $(INSTALL) $(MANUAL) $@
--$(MANDIR)/man3f/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL) \
-- $(MANDIR)/man3f
-- rm -f $@
-- ln -s $(MANDIR)/man3/$(MANUAL) $@
--$(MANDIR)/man3f90/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL) \
-- $(MANDIR)/man3f90
-- rm -f $@
-- ln -s $(MANDIR)/man3/$(MANUAL) $@
-+$(MANDIR)/man3f/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL)
-+$(MANDIR)/man3f90/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL)
-
- ################################################################################
- # Cleanup:
diff --git a/science/netcdf/pkg-plist b/science/netcdf/pkg-plist
index fcbebdf8999f..ccb8850193b8 100644
--- a/science/netcdf/pkg-plist
+++ b/science/netcdf/pkg-plist
@@ -3,14 +3,15 @@ bin/ncgen
include/ncvalues.h
include/netcdf.h
include/netcdf.hh
-include/netcdf.inc
include/netcdfcpp.h
lib/libnetcdf.a
+lib/libnetcdf.la
lib/libnetcdf.so
-lib/libnetcdf.so.1
+lib/libnetcdf.so.4
lib/libnetcdf_c++.a
+lib/libnetcdf_c++.la
lib/libnetcdf_c++.so
-lib/libnetcdf_c++.so.1
+lib/libnetcdf_c++.so.4
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index 0b4465af8dad..e93513e47bbb 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netcdf
-PORTVERSION= 3.6.1
+PORTVERSION= 3.6.2
CATEGORIES= science
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/ \
http://sunpoet.net/distfiles/
@@ -15,31 +15,23 @@ MASTER_SITE_SUBDIR= . old
MAINTAINER= sunpoet@sunpoet.net
COMMENT= Library for machine-independent, array-oriented data access
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
CONFLICTS= hdf-4.*
-CONFIGURE_ENV= CPPFLAGS="-fPIC -DPIC -Df2cFortran"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-shared --mandir=${PREFIX}/man --disable-f77
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
+
+USE_BZIP2= YES
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= ncdump.1 ncgen.1
-MAN3= netcdf.3 netcdf.3f
-
-post-build:
- @(cd ${WRKSRC}/libsrc && \
- ${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
- @(cd ${WRKSRC}/cxx && \
- ${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
+MAN3= netcdf.3
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/ncdump
- @${STRIP_CMD} ${PREFIX}/bin/ncgen
- ${INSTALL_DATA} ${WRKSRC}/libsrc/libnetcdf.so ${PREFIX}/lib/libnetcdf.so.1
- ${LN} -sf libnetcdf.so.1 ${PREFIX}/lib/libnetcdf.so
- ${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
- ${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
+ @${STRIP_CMD} ${PREFIX}/bin/ncdump ${PREFIX}/bin/ncgen
+ ${LN} -fs libnetcdf.so.4 ${PREFIX}/lib/libnetcdf.so
+ ${LN} -fs libnetcdf_c++.so.4 ${PREFIX}/lib/libnetcdf_c++.so
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in COPYRIGHT README RELEASE_NOTES
diff --git a/science/netcdf4/distinfo b/science/netcdf4/distinfo
index fa988c3f6686..63fec67ffd48 100644
--- a/science/netcdf4/distinfo
+++ b/science/netcdf4/distinfo
@@ -1,3 +1,3 @@
-MD5 (netcdf-3.6.1.tar.gz) = 07a9db424337c5e4833fb84136e09a1e
-SHA256 (netcdf-3.6.1.tar.gz) = 15c42a2c698c4e42ee17720701168711d86e97e97311223015d07853fb09249f
-SIZE (netcdf-3.6.1.tar.gz) = 883888
+MD5 (netcdf-3.6.2.tar.bz2) = 1eca0ea1e81e14ebc5bb93e5dd25c364
+SHA256 (netcdf-3.6.2.tar.bz2) = 0468f1d9ab0fbad6edb957d8fb597010cb5c546c6de6752c9a63b0e0f194e564
+SIZE (netcdf-3.6.2.tar.bz2) = 4580511
diff --git a/science/netcdf4/files/patch-Makefile b/science/netcdf4/files/patch-Makefile
deleted file mode 100644
index 00d94fb843f1..000000000000
--- a/science/netcdf4/files/patch-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig Mon Feb 27 00:43:59 2006
-+++ Makefile Sat Dec 23 05:33:43 2006
-@@ -117,6 +117,8 @@
- ncgen/distclean \
- cxx/clean \
- cxx/distclean \
-+fortran/install \
-+fortran/uninstall \
- :
- @subdir=`echo $@ | sed 's,/.*,,'`; \
- target=`echo $@ | sed 's,.*/,,'`; \
-@@ -124,8 +126,6 @@
-
- fortran/all \
- fortran/test \
--fortran/install \
--fortran/uninstall \
- nf_test/all \
- nf_test/test \
- :
diff --git a/science/netcdf4/files/patch-rules.make b/science/netcdf4/files/patch-rules.make
deleted file mode 100644
index 4c9e564dc054..000000000000
--- a/science/netcdf4/files/patch-rules.make
+++ /dev/null
@@ -1,19 +0,0 @@
---- rules.make.orig Sat Dec 18 05:34:48 2004
-+++ rules.make Thu Jan 6 15:12:59 2005
-@@ -145,14 +145,8 @@
- $(INSTALL) $(MANUAL) $@
- $(MANDIR)/man3/$(MANUAL): $(MANDIR)/man3 $(MANUAL)
- $(INSTALL) $(MANUAL) $@
--$(MANDIR)/man3f/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL) \
-- $(MANDIR)/man3f
-- rm -f $@
-- ln -s $(MANDIR)/man3/$(MANUAL) $@
--$(MANDIR)/man3f90/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL) \
-- $(MANDIR)/man3f90
-- rm -f $@
-- ln -s $(MANDIR)/man3/$(MANUAL) $@
-+$(MANDIR)/man3f/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL)
-+$(MANDIR)/man3f90/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL)
-
- ################################################################################
- # Cleanup:
diff --git a/science/netcdf4/pkg-plist b/science/netcdf4/pkg-plist
index fcbebdf8999f..ccb8850193b8 100644
--- a/science/netcdf4/pkg-plist
+++ b/science/netcdf4/pkg-plist
@@ -3,14 +3,15 @@ bin/ncgen
include/ncvalues.h
include/netcdf.h
include/netcdf.hh
-include/netcdf.inc
include/netcdfcpp.h
lib/libnetcdf.a
+lib/libnetcdf.la
lib/libnetcdf.so
-lib/libnetcdf.so.1
+lib/libnetcdf.so.4
lib/libnetcdf_c++.a
+lib/libnetcdf_c++.la
lib/libnetcdf_c++.so
-lib/libnetcdf_c++.so.1
+lib/libnetcdf_c++.so.4
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
diff --git a/science/ruby-netcdf/Makefile b/science/ruby-netcdf/Makefile
index 542145c820d1..2b240cb04d83 100644
--- a/science/ruby-netcdf/Makefile
+++ b/science/ruby-netcdf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netcdf
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= math ruby
MASTER_SITES= http://ruby.gfd-dennou.org/products/ruby-netcdf/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -17,7 +18,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A Ruby interface to the NetCDF scientific IO library
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
+LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
USE_RUBY= yes
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index 8f5d5cb8b447..86e02723ecb3 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -6,6 +6,7 @@
PORTNAME= v_sim
PORTVERSION= 3.3.0
+PORTREVERSION= 1
CATEGORIES= science
MASTER_SITES= http://www-drfmc.cea.fr/sp2m/L_Sim/V_Sim/download/
@@ -29,7 +30,7 @@ PLIST_SUB+= NLS=""
.endif
.if !defined(WITHOUT_CDF)
-LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
+LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
CONFIGURE_ARGS+=--with-nanoquanta --with-nanoquanta-path=${LOCALBASE}
PLIST_SUB+= CDF=""
.else
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index 8a4ec7faa0cd..960687c0fb49 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -8,7 +8,7 @@
PORTNAME= vis5d+
PORTVERSION= 1.2.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= vis5d
@@ -18,7 +18,7 @@ COMMENT= An OpenGL-based volumetric visualization program for scientific dataset
BUILD_DEPENDS= ${LOCALBASE}/lib/libmix.a:${PORTSDIR}/graphics/qslim \
convert:${PORTSDIR}/graphics/ImageMagick
-LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf \
+LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf \
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick