aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
commit004a7c5ac21475f760354371ae4f8fca5e556acb (patch)
tree47b9539be8bb171263921a641d850025fee218cc /science
parentbcfacab8772c0f3bf72412386eb13f58def6bef2 (diff)
Notes
Diffstat (limited to 'science')
-rw-r--r--science/2dhf/Makefile4
-rw-r--r--science/abinit/Makefile6
-rw-r--r--science/elmer-hutiter/Makefile6
-rw-r--r--science/gamess/Makefile20
-rw-r--r--science/mbdyn/Makefile8
-rw-r--r--science/mpb/Makefile2
-rw-r--r--science/mpqc/Makefile6
-rw-r--r--science/ncs/Makefile4
-rw-r--r--science/psi3/Makefile20
-rw-r--r--science/py-scipy/Makefile2
10 files changed, 39 insertions, 39 deletions
diff --git a/science/2dhf/Makefile b/science/2dhf/Makefile
index 24c098eda3f2..c3b5f5626617 100644
--- a/science/2dhf/Makefile
+++ b/science/2dhf/Makefile
@@ -22,12 +22,12 @@ USE_FORTRAN= ifort
BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas
+BLAS= -lf77blas
.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index e060c59a385c..644c947da830 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -45,13 +45,13 @@ USE_GHOSTSCRIPT_BUILD= yes
MANUAL_PACKAGE_BUILD= takes a tremendous amount of time to build on pointyhat nodes
.endif
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas
-LAPACK= -lalapack
+BLAS= -lf77blas
+LAPACK= -lalapack -lcblas
.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
diff --git a/science/elmer-hutiter/Makefile b/science/elmer-hutiter/Makefile
index d99b3f601720..f3daf4e4651e 100644
--- a/science/elmer-hutiter/Makefile
+++ b/science/elmer-hutiter/Makefile
@@ -22,13 +22,13 @@ USE_FORTRAN= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas
-LAPACK= -lalapack
+BLAS= -lf77blas
+LAPACK= -lalapack -lcblas
.else
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
diff --git a/science/gamess/Makefile b/science/gamess/Makefile
index 7bddda49b399..f11cffc0059b 100644
--- a/science/gamess/Makefile
+++ b/science/gamess/Makefile
@@ -32,27 +32,27 @@ MANUAL_PACKAGE_BUILD=You must manually get the source distribution from master s
.include <bsd.port.pre.mk>
-USE_BLAS?= reference
-
.if exists(${LOCALBASE}/lib/libgoto2.so)
-USE_BLAS= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
LAPACK= -lgoto2p
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas -lptcblas -latlas_r
-LAPACK= -lalapack_r
+BLAS= -lptf77blas
+LAPACK= -lalapack -lptcblas
.endif
MAKE_ENV+= LANG="C"
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index ecb24eb999cb..87b4f36fe46d 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -38,18 +38,18 @@ OPTIONS= MPI "Enable mpich-support" off \
BROKEN= Does not compile on powerpc
.endif
-USE_BLAS?= reference
+WITH_BLAS?= reference
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas \
lapack.4:${PORTSDIR}/math/lapack
CONFIGURE_ARGS+= --with-blas=blas
LAPACK_LIBS= -llapack
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
CONFIGURE_ARGS+= --with-blas=goto --with-goto=goto2
LAPACK_LIBS= -lgoto2
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
CONFIGURE_ARGS+= --with-blas=atlas
LAPACK_LIBS= -lalapack
diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index adb91517ccba..51be6769cde4 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -28,7 +28,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index decad1bf7320..03e2eec0eb81 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -24,13 +24,13 @@ USE_LDCONFIG= yes
.if defined(WITH_ICC)
BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas -lcblas
-LAPACK= -lalapack
+BLAS= -lf77blas
+LAPACK= -lalapack -lcblas
.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index f533a03347e3..738c2f0d74ab 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -78,12 +78,12 @@ DOCS= AUTHORS COMPATIBILITY Changelog TODO
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS) && !defined(WITHOUT_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS_LIB= -lcblas -lf77blas -latlas -L${FORTRANLIBDIR} -L${FORTRANLIBDIR2} -lgfortranbegin -lgfortran
+BLAS_LIB= -lf77blas
.elif !defined(WITHOUT_BLAS)
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS_LIB= -lblas
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index c26d82e52303..107a61b033d6 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -22,28 +22,28 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= maho@FreeBSD.org
COMMENT= An electronic structure programs for high-accuracy computations
-USE_BLAS?= reference
-
.if exists(${LOCALBASE}/lib/libgoto2.so)
-USE_BLAS= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
BLAS= -lgoto2p
LAPACK= -lgoto2p
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas -lptcblas -latlas_r
-LAPACK= -lalapack_r
+BLAS= -lptf77blas
+LAPACK= -lalapack -lptcblas
.endif
USE_BZIP2= yes
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 3d24f8cef036..433ecfbc4cf8 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -41,7 +41,7 @@ BROKEN= ldexpf is missing See http://lists.freebsd.org/pipermail/freebsd-amd64/2
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
.if !exists(${LOCALBASE}/lib/libalapack.a)
-IGNORE= atlas needs to be built with WITH_STATICLIB for scipy to function properly
+IGNORE= atlas needs to be built with WITH_STATIC for scipy to function properly
.endif
.else
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \