aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-13 08:27:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-13 08:27:23 +0000
commit6ce624df42807c6be73de9c1894ccce77555c2c4 (patch)
tree4ee2523b99312546f64e73cd6f44524ed2aeb893 /science
parente2fe2c36f0880e6f916ea5ecd7ea550b0ce66127 (diff)
downloadports-6ce624df42807c6be73de9c1894ccce77555c2c4.tar.gz
ports-6ce624df42807c6be73de9c1894ccce77555c2c4.zip
science/lamprop: Unbreak by fixing the python interpreter in the shebang
While here, added NO_ARCH. Approved by: portmgr (port compliance, infrastructure)
Notes
Notes: svn path=/head/; revision=464350
Diffstat (limited to 'science')
-rw-r--r--science/lamprop/Makefile2
-rw-r--r--science/lamprop/files/patch-build.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/science/lamprop/Makefile b/science/lamprop/Makefile
index d954579af43d..133801c1ce38 100644
--- a/science/lamprop/Makefile
+++ b/science/lamprop/Makefile
@@ -14,9 +14,9 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYNUMPY}
USES= python:3.4+
-
USE_GITHUB= yes
GH_ACCOUNT= rsmith-nl
+NO_ARCH= yes
PLIST_FILES= bin/lamprop \
man/man1/lamprop.1.gz \
diff --git a/science/lamprop/files/patch-build.py b/science/lamprop/files/patch-build.py
new file mode 100644
index 000000000000..c28f7ccca128
--- /dev/null
+++ b/science/lamprop/files/patch-build.py
@@ -0,0 +1,11 @@
+--- build.py.orig 2018-03-13 08:20:32 UTC
++++ build.py
+@@ -28,7 +28,7 @@ def mkarchive(name, modules, main='__mai
+ """
+ std = '__main__.py'
+ vi = sys.version_info
+- shebang = '#!/usr/bin/env python{}\n'.format(vi.major).encode('ascii')
++ shebang = '#!/usr/bin/env python{}.{}\n'.format(vi.major, vi.minor).encode('ascii')
+ if isinstance(modules, str):
+ modules = [modules]
+ if main != std: