aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-22 04:45:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-22 04:45:38 +0000
commitf138c0cebf436f5004169b582b05967b1c1db9a6 (patch)
treed7c91790adf486836c4cb204c5876cd6185032f3 /science
parentb12f95cd58538e6f82003839948120ea921be82e (diff)
downloadports-f138c0cebf436f5004169b582b05967b1c1db9a6.tar.gz
ports-f138c0cebf436f5004169b582b05967b1c1db9a6.zip
science/h5utils: Update to 1.13.1
Port changes: * Change to DISTVERSION * Add USES=compiler:c++11-lang and CXXFLAGS+=-std=c++11 * Remove duplicate GNU_CONFIGURE and unnecessary += * Add the option OCTAVE for Octave integration PR: 226815 Submitted by: Klaus Aehlig <aehlig@linta.de> (maintainer) - sumbitted w/out the OCTAVE option
Notes
Notes: svn path=/head/; revision=465256
Diffstat (limited to 'science')
-rw-r--r--science/h5utils/Makefile26
-rw-r--r--science/h5utils/distinfo6
-rw-r--r--science/h5utils/files/patch-configure.ac11
-rw-r--r--science/h5utils/pkg-plist1
4 files changed, 23 insertions, 21 deletions
diff --git a/science/h5utils/Makefile b/science/h5utils/Makefile
index fe33d82e20a6..9a28d3de798e 100644
--- a/science/h5utils/Makefile
+++ b/science/h5utils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= h5utils
-PORTVERSION= 1.13
+DISTVERSION= 1.13.1
CATEGORIES= science
MAINTAINER= aehlig@linta.de
@@ -12,17 +12,29 @@ LICENSE= MIT GPLv2
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
-GNU_CONFIGURE= yes
-CFLAGS += -L${LOCALBASE}/lib -I${LOCALBASE}/include -lpthread
-
-BUILD_DEPENDS+= gawk:lang/gawk
-LIB_DEPENDS+= libhdf5.so:science/hdf5 \
+BUILD_DEPENDS= gawk:lang/gawk
+LIB_DEPENDS= libhdf5.so:science/hdf5 \
libpng.so:graphics/png \
libmatheval.so:devel/libmatheval
-USES= autoreconf
+USES= autoreconf compiler:c++11-lang
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= stevengj
+CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include -lpthread
+CXXFLAGS+= -std=c++11
+
+OPTIONS_DEFINE= OCTAVE
+OPTIONS_SUB= yes
+
+OCTAVE_DESC= With Octave support
+OCTAVE_CONFIGURE_WITH= octave
+OCTAVE_BUILD_DEPENDS= ${LOCALBASE}/include/octave-${OCTAVE_VERSION}/octave/octave.h:math/octave
+OCTAVE_VARS= PLIST_SUB+="OCTAVE_VERSION=${OCTAVE_VERSION} CONFIGURE_TARGET=${CONFIGURE_TARGET}"
+
+post-install-OCTAVE-on:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/octave/${OCTAVE_VERSION}/site/oct/${CONFIGURE_TARGET}/h5read.oct
+
+.include "../../math/octave/Makefile.version"
.include <bsd.port.mk>
diff --git a/science/h5utils/distinfo b/science/h5utils/distinfo
index 5a39dfdcbe37..957ad6fe8fe4 100644
--- a/science/h5utils/distinfo
+++ b/science/h5utils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500963131
-SHA256 (stevengj-h5utils-1.13_GH0.tar.gz) = 894849f6d107b224bb1694029ad7d469695b0a6f47b564fe16c40f3d20c0b452
-SIZE (stevengj-h5utils-1.13_GH0.tar.gz) = 113735
+TIMESTAMP = 1521616297
+SHA256 (stevengj-h5utils-1.13.1_GH0.tar.gz) = 698941b787dd367d273acf103ff08eb3abd61332d88a6a65055ba65428fa6124
+SIZE (stevengj-h5utils-1.13.1_GH0.tar.gz) = 113754
diff --git a/science/h5utils/files/patch-configure.ac b/science/h5utils/files/patch-configure.ac
deleted file mode 100644
index 82a53a1daa76..000000000000
--- a/science/h5utils/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2017-07-25 06:31:48 UTC
-+++ configure.ac
-@@ -68,7 +68,7 @@ AC_CHECK_LIB(matheval, evaluator_get_var
-
- if test $H5MATH = yes; then
- MORE_H5UTILS="h5math\$(EXEEXT) $MORE_H5UTILS"
-- MORE_H5UTILS_MANS="h5math.1 $MORE_H5UTILS_MANS"
-+ MORE_H5UTILS_MANS="doc/man/h5math.1 $MORE_H5UTILS_MANS"
- else
- AC_MSG_WARN([can't find libmatheval: won't be able to compile h5math])
- fi
diff --git a/science/h5utils/pkg-plist b/science/h5utils/pkg-plist
index f6a4317d49c5..d19d93f1e0d5 100644
--- a/science/h5utils/pkg-plist
+++ b/science/h5utils/pkg-plist
@@ -3,6 +3,7 @@ bin/h5totxt
bin/h5fromtxt
bin/h5tovtk
bin/h5topng
+%%OCTAVE%%lib/octave/%%OCTAVE_VERSION%%/site/oct/%%CONFIGURE_TARGET%%/h5read.oct
man/man1/h5fromtxt.1.gz
man/man1/h5math.1.gz
man/man1/h5topng.1.gz