aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-07-30 09:39:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-07-30 09:39:44 +0000
commitca18c5b1d871a92954334d7e56906b51e1c2d086 (patch)
tree69ab1e6d1c3aa62d8921d89f1d46c51f48b49f3a /science
parent769329177b45b3221adba2ec0ddb4d734343d53e (diff)
Build fixes with glib 2.28. gtk 2.24, gtkmm 2.24 and vala 0.12.
Notes
Notes: svn path=/head/; revision=278564
Diffstat (limited to 'science')
-rw-r--r--science/peekabot/Makefile1
-rw-r--r--science/peekabot/files/patch-src_gui_ScreneViewFrame.cc15
2 files changed, 16 insertions, 0 deletions
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index ef5d2049ec18..0ed11dd14257 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= peekabot
PORTVERSION= 0.8.4
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}.x/
diff --git a/science/peekabot/files/patch-src_gui_ScreneViewFrame.cc b/science/peekabot/files/patch-src_gui_ScreneViewFrame.cc
new file mode 100644
index 000000000000..cd19e2052f91
--- /dev/null
+++ b/science/peekabot/files/patch-src_gui_ScreneViewFrame.cc
@@ -0,0 +1,15 @@
+--- src/gui/SceneViewFrame.cc.orig 2011-06-26 14:46:09.000000000 +0200
++++ src/gui/SceneViewFrame.cc 2011-06-26 14:46:56.000000000 +0200
+@@ -50,10 +50,11 @@
+ m_gui(layout.get_gui()),
+ m_gl_area(m_gui.get_gl_config(), true),
+ m_cameras_model(Gtk::ListStore::create(m_camera_cols)),
+- m_cameras(m_cameras_model),
+ m_cam_id(0xFFFFFFFF),
+ m_layer_table(2, 5, true)
+ {
++ m_cameras.set_model(m_cameras_model);
++
+ for( std::size_t i = 0; i < NUMBER_OF_LAYERS; ++i )
+ m_layers[i] = (i == 0);
+