aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-07 01:12:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-07 01:12:25 +0000
commit556c0d85678a5197e3ae8e4a697f4c3f6a450e8e (patch)
tree04e094b56f5669f3a59ce6b965e900f2c428ac3b /science
parent15abea22d69f47fb1cc319f3d3307b9b1286fc2a (diff)
downloadports-556c0d85678a5197e3ae8e4a697f4c3f6a450e8e.tar.gz
ports-556c0d85678a5197e3ae8e4a697f4c3f6a450e8e.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/mpb/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index 3356f21fd83c..007185cf5ffb 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mpb
PORTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://ab-initio.mit.edu/mpb/
@@ -16,17 +17,21 @@ COMMENT= MIT Photonic-Bands
BUILD_DEPENDS= ${LOCALBASE}/lib/libctl.a:${PORTSDIR}/science/libctl \
bash:${PORTSDIR}/shells/bash2
-LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas \
- lapack.3:${PORTSDIR}/math/lapack \
- atlas.1:${PORTSDIR}/math/atlas \
+LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas \
fftw.2:${PORTSDIR}/math/fftw \
hdf5.0:${PORTSDIR}/graphics/hdf5 \
guile.15:${PORTSDIR}/lang/guile
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --with-lapack=-lalapack
MAN1= mpb.1 mpb-data.1 mpb-split.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lhdf5 |-lhdf5 ${PTHREAD_LIBS} |g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>