aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 15:36:57 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 15:36:57 +0000
commit39ee4157c1aa9e7142e442a5acb88e6f36bc6cb6 (patch)
tree3436de5bcfb77091fe3fb00b6e6e1f83422343dc /science
parent34064a60bb5fffbcbdb89381ad9a1f8d2e50c31c (diff)
downloadports-39ee4157c1aa9e7142e442a5acb88e6f36bc6cb6.tar.gz
ports-39ee4157c1aa9e7142e442a5acb88e6f36bc6cb6.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/ruby-gphys/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/science/ruby-gphys/Makefile b/science/ruby-gphys/Makefile
index 3985ff26e805..1a0f92f5168b 100644
--- a/science/ruby-gphys/Makefile
+++ b/science/ruby-gphys/Makefile
@@ -14,7 +14,9 @@ DIST_SUBDIR= ruby
MAINTAINER= murashin@gfd-dennou.org
COMMENT= A multi-purpose class to handle gridded physical quantities
-LICENSE= BSD
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
@@ -26,34 +28,29 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
${RUBY_SITELIBDIR}/numru/units.rb:${PORTSDIR}/math/ruby-numru_units \
${RUBY_SITEARCHLIBDIR}/rb_gsl.so:${PORTSDIR}/math/ruby-gsl
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
-
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+MAKE_ARGS= INSTALL_PROG="${INSTALL_PROGRAM}" \
+ INSTALL_DATA="${INSTALL_DATA}"
EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
DOCSDIR= ${RUBY_MODDOCDIR}
PORTEXAMPLES= sample* test*
PORTDOCS= ChangeLog LICENSE.txt README TODO_ep_flux doc*
-NO_STAGE= yes
do-install:
- cd ${WRKSRC} && ${MAKE} install
- cd ${WRKSRC} && ${RUBY} install.rb
-
-post-install:
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${MAKE} ${MAKE_ARGS} install
+ cd ${WRKSRC} && ${RUBY} install.rb -d ${STAGEDIR}${RUBY_SITELIBDIR} -b ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in ${PORTEXAMPLES}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${i}" ${EXAMPLESDIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${i}" ${STAGEDIR}${EXAMPLESDIR})
.endfor
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${i}" ${DOCSDIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${i}" ${STAGEDIR}${DOCSDIR})
.endfor
.for i in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
+
.include <bsd.port.mk>