aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-05-05 12:40:59 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-05-05 12:40:59 +0000
commit9f64b86a3affee8065282b992f60457142f87e8c (patch)
tree3bbdb0aef857983ae42b0f0867a32e3a8cdb54b1 /science
parente1286d55cb63e4c375db594f87eeee0ed2f6336d (diff)
downloadports-9f64b86a3affee8065282b992f60457142f87e8c.tar.gz
ports-9f64b86a3affee8065282b992f60457142f87e8c.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/cdo/Makefile27
-rw-r--r--science/cdo/distinfo6
-rw-r--r--science/cdo/files/extra-patch-src-Makefile.in8
-rw-r--r--science/cdo/pkg-descr2
4 files changed, 25 insertions, 18 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index f9d7f3a26783..97de722285f6 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME= cdo
-PORTVERSION= 1.4.1
+PORTVERSION= 1.4.3
CATEGORIES= science
-MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
+MASTER_SITES= https://code.zmaw.de/attachments/download/76/ \
http://sunpoet.net/distfiles/
MAINTAINER= sunpoet@sunpoet.net
@@ -28,9 +28,10 @@ NETCDF_VER?= 4
HDF5_VER?= 18
OPTIONS= HDF5 "HDF5 support" on \
- JASPER "Japser support" on \
+ JASPER "Japser support" off \
NETCDF "NetCDF support" on \
- PROJ "PROJ support" on
+ PROJ "PROJ support" on \
+ SZIP "SZIP support" on
.include <bsd.port.pre.mk>
@@ -38,17 +39,18 @@ OPTIONS= HDF5 "HDF5 support" on \
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -DPTHREAD_MUTEXATTR_CONDATTR"
.endif
-.if (defined(WITH_NETCDF) && defined(WITH_HDF5) && (${NETCDF_VER} == 4) && (${HDF5_VER} == 16))
+.if (!defined(WITHOUT_NETCDF) && !defined(WITHOUT_HDF5) && (${NETCDF_VER} == 4) && (${HDF5_VER} == 16))
IGNORE=netCDF 4 requires HDF5 1.8.
.endif
-.if defined(WITH_NETCDF) && (${NETCDF_VER} == 4)
+.if !defined(WITHOUT_NETCDF) && (${NETCDF_VER} == 4)
HDF5_VER= 18
WITH_HDF5= yes
.endif
-.if defined(WITH_HDF5)
+.if !defined(WITHOUT_HDF5)
CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE} --with-zlib=/usr
+WITH_SZIP= yes
.if (${HDF5_VER} == 18)
LIB_DEPENDS+= hdf5.6:${PORTSDIR}/science/hdf5-18
.else
@@ -63,7 +65,7 @@ PLIST_SUB+= JPEG2000=""
.else
.endif
-.if defined(WITH_NETCDF)
+.if !defined(WITHOUT_NETCDF)
CONFIGURE_ARGS+= --with-netcdf=${LOCALBASE}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-Makefile.in
.if (${NETCDF_VER} == 4)
@@ -74,13 +76,18 @@ LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
PLIST_FILES+= bin/cdotest
.endif
-.if defined(WITH_PROJ)
+.if !defined(WITHOUT_PROJ)
CONFIGURE_ARGS+= --with-proj=${LOCALBASE}
LIB_DEPENDS+= proj.6:${PORTSDIR}/graphics/proj
.endif
+.if !defined(WITHOUT_SZIP)
+CONFIGURE_ARGS+= --with-szlib=${LOCALBASE}
+LIB_DEPENDS+= sz.2:${PORTSDIR}/science/szip
+.endif
+
post-build:
-.if defined(WITH_NETCDF)
+.if !defined(WITHOUT_NETCDF)
@cd "${WRKSRC}/src" && ${SETENV} CDO_PATH="${WRKSRC}/src/cdo" "${WRKSRC}/src/cdotest"
.endif
diff --git a/science/cdo/distinfo b/science/cdo/distinfo
index 56db14c1824c..be2381528d2d 100644
--- a/science/cdo/distinfo
+++ b/science/cdo/distinfo
@@ -1,3 +1,3 @@
-MD5 (cdo-1.4.1.tar.gz) = 774b8de3d537a1049e446ffdb50d55f1
-SHA256 (cdo-1.4.1.tar.gz) = 139de46904890a990879762d14cfdbea4108eb1dfbb859fc745b3eb236747a0c
-SIZE (cdo-1.4.1.tar.gz) = 2652758
+MD5 (cdo-1.4.3.tar.gz) = 5c7928728bd930e7802c516ff099208f
+SHA256 (cdo-1.4.3.tar.gz) = 622def270089bea3ed5045635c8af812049a71ba19790f6509fbceb90a9ea921
+SIZE (cdo-1.4.3.tar.gz) = 2669926
diff --git a/science/cdo/files/extra-patch-src-Makefile.in b/science/cdo/files/extra-patch-src-Makefile.in
index 1559c15d03f5..e89616b13a54 100644
--- a/science/cdo/files/extra-patch-src-Makefile.in
+++ b/science/cdo/files/extra-patch-src-Makefile.in
@@ -1,9 +1,9 @@
---- src/Makefile.in.orig 2008-04-04 15:08:17.000000000 +0800
-+++ src/Makefile.in 2008-04-12 00:44:30.000000000 +0800
-@@ -33,8 +33,8 @@
+--- src/Makefile.in.orig 2010-02-19 18:34:19.000000000 +0800
++++ src/Makefile.in 2010-03-08 16:21:37.000000000 +0800
+@@ -32,8 +32,8 @@
+ POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
- target_triplet = @target@
-bin_PROGRAMS = cdo$(EXEEXT)
-noinst_PROGRAMS = cdotest$(EXEEXT)
+bin_PROGRAMS = cdo$(EXEEXT) cdotest$(EXEEXT)
diff --git a/science/cdo/pkg-descr b/science/cdo/pkg-descr
index ae8e486f05d2..dae65c59303e 100644
--- a/science/cdo/pkg-descr
+++ b/science/cdo/pkg-descr
@@ -20,4 +20,4 @@ overview about the main categories.
* Vertical interpolation (ml2pl, ml2hl)
* Time interpolation (inttime, intyear)
-WWW: http://www.mpimet.mpg.de/fileadmin/software/cdo/
+WWW: https://code.zmaw.de/projects/cdo