aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-09 00:52:24 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-09 00:52:24 +0000
commitb546447892a48bf674cfd0a7b7c85397119d62b4 (patch)
tree507d6c9192afa1cff66f1d9fafc8ca7b0f6028e6 /science
parentafdb557f125766883d5998488d9433ffcde3ce21 (diff)
downloadports-b546447892a48bf674cfd0a7b7c85397119d62b4.tar.gz
ports-b546447892a48bf674cfd0a7b7c85397119d62b4.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/gchempaint/Makefile3
-rw-r--r--science/gchempaint/distinfo2
-rw-r--r--science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-group.c13
-rw-r--r--science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-shape.c17
-rw-r--r--science/gchempaint/pkg-plist2
5 files changed, 33 insertions, 4 deletions
diff --git a/science/gchempaint/Makefile b/science/gchempaint/Makefile
index 9b023a6f9dac..6d68a5326c36 100644
--- a/science/gchempaint/Makefile
+++ b/science/gchempaint/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= gchempaint
-PORTVERSION= 0.3.5
-PORTREVISION= 1
+PORTVERSION= 0.3.6
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}/unstable.pkg/${PORTVERSION}
diff --git a/science/gchempaint/distinfo b/science/gchempaint/distinfo
index 84b7b8529169..5c4cf1a901fb 100644
--- a/science/gchempaint/distinfo
+++ b/science/gchempaint/distinfo
@@ -1 +1 @@
-MD5 (gchempaint-0.3.5.tar.bz2) = 096dafb7aec7437704d8293ba7f3ae01
+MD5 (gchempaint-0.3.6.tar.bz2) = 2e1bf7deba7487e9b5dbef4cfd7e0cd0
diff --git a/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-group.c b/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-group.c
new file mode 100644
index 000000000000..b40e23f04c03
--- /dev/null
+++ b/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-group.c
@@ -0,0 +1,13 @@
+--- libgcpcanvas/gcp-canvas-group.c.orig Sun Oct 12 13:51:42 2003
++++ libgcpcanvas/gcp-canvas-group.c Sun Nov 9 00:51:10 2003
+@@ -92,9 +92,9 @@
+
+ void gnome_canvas_group_ext_print (GPrintable *printable, GnomePrintContext *pc)
+ {
+- g_return_if_fail (GNOME_IS_CANVAS_GROUP_EXT (printable));
+ GList *list;
+ double affine[6];
++ g_return_if_fail (GNOME_IS_CANVAS_GROUP_EXT (printable));
+ for (list = GNOME_CANVAS_GROUP (printable) ->item_list; list; list = list->next) {
+ if (GNOME_IS_CANVAS_GROUP_EXT(list->data))
+ gnome_canvas_group_ext_print (G_PRINTABLE (list->data), pc);
diff --git a/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-shape.c b/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-shape.c
new file mode 100644
index 000000000000..81f313c0b001
--- /dev/null
+++ b/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-shape.c
@@ -0,0 +1,17 @@
+--- libgcpcanvas/gcp-canvas-shape.c.orig Sun Oct 12 13:51:42 2003
++++ libgcpcanvas/gcp-canvas-shape.c Sun Nov 9 00:53:27 2003
+@@ -95,13 +95,13 @@
+
+ void gnome_canvas_shape_ext_print (GPrintable *printable, GnomePrintContext *pc)
+ {
+- g_return_if_fail (GNOME_IS_CANVAS_SHAPE_EXT (printable));
+ GnomeCanvasShape *shape;
+ GnomeCanvasShapePriv * priv;
+ GnomeCanvasPathDef * path;
+ gdouble width;
+ ArtBpath * bpath;
+
++ g_return_if_fail (GNOME_IS_CANVAS_SHAPE_EXT (printable));
+ shape = GNOME_CANVAS_SHAPE (printable);
+ priv = shape->priv;
+ path = priv->path;
diff --git a/science/gchempaint/pkg-plist b/science/gchempaint/pkg-plist
index 9bc94579f7aa..a1b32d9d9544 100644
--- a/science/gchempaint/pkg-plist
+++ b/science/gchempaint/pkg-plist
@@ -29,6 +29,7 @@ share/gnome/gchempaint/glade/text.xpm
share/gnome/gchempaint/glade/tools.glade
share/gnome/gchempaint/glade/upbond.xpm
share/gnome/gchempaint/glade/xbond.xpm
+share/gnome/gnome-2.0/ui/gchempaint.xml
share/gnome/help/gchempaint/C/gchempaint.xml
share/gnome/help/gchempaint/C/legal.xml
share/gnome/help/gchempaint/C/figures/bond.png
@@ -50,7 +51,6 @@ share/gnome/omf/gchempaint/gchempaint-C.omf
share/gnome/pixmaps/gchempaint.png
share/gnome/pixmaps/gchempaint_logo.png
@exec scrollkeeper-install -q %D/share/gnome/omf/gchempaint/gchempaint-C.omf 2>/dev/null || /usr/bin/true
-share/gnome/ui/gchempaint.xml
share/locale/de/LC_MESSAGES/gchempaint.mo
share/locale/fr/LC_MESSAGES/gchempaint.mo
share/locale/it/LC_MESSAGES/gchempaint.mo