aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-10-21 15:13:44 +0000
committerSteve Wills <swills@FreeBSD.org>2012-10-21 15:13:44 +0000
commit256e1796dcef08bbf931394afc6d9ebc41e9b72e (patch)
tree7486f8e2777d4d3a76ccf965c5d91275387880a3 /science
parent7993cd9847dc1d4f27792a49d2f441d7a0f916db (diff)
downloadports-256e1796dcef08bbf931394afc6d9ebc41e9b72e.tar.gz
ports-256e1796dcef08bbf931394afc6d9ebc41e9b72e.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/ruby-gphys/Makefile64
-rw-r--r--science/ruby-gphys/distinfo4
-rw-r--r--science/ruby-gphys/pkg-plist79
3 files changed, 34 insertions, 113 deletions
diff --git a/science/ruby-gphys/Makefile b/science/ruby-gphys/Makefile
index 4bd43f9ff094..7c30c522fe1b 100644
--- a/science/ruby-gphys/Makefile
+++ b/science/ruby-gphys/Makefile
@@ -1,65 +1,57 @@
-# New ports collection makefile for: GPhys
-# Date created: 14 March 2004
-# Whom: Shin'ya Murakami <murakami@ahs.scitec.kobe-u.ac.jp>
-#
+# Created by: Shin'ya Murakami <murakami@ahs.scitec.kobe-u.ac.jp>
# $FreeBSD$
-#
PORTNAME= gphys
-PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTVERSION= 1.2.1
CATEGORIES= science ruby
-MASTER_SITES= http://ruby.gfd-dennou.org/products/gphys/ \
- http://dennou-h.gfd-dennou.org/library/ruby/products/gphys/ \
- http://dennou-q.gfd-dennou.org/library/ruby/products/gphys/
+MASTER_SITES= http://ruby.gfd-dennou.org/products/gphys/release/ \
+ http://dennou-h.gfd-dennou.org/library/ruby/products/gphys/release/ \
+ http://dennou-q.gfd-dennou.org/library/ruby/products/gphys/release/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= murashin@gfd-dennou.org
COMMENT= A multi-purpose class to handle gridded physical quantities
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
${RUBY_SITELIBDIR}/narray_miss.rb:${PORTSDIR}/math/ruby-narray_miss \
${RUBY_SITEARCHLIBDIR}/numru/dcl_raw.so:${PORTSDIR}/science/ruby-dcl \
${RUBY_SITEARCHLIBDIR}/numru/netcdfraw.so:${PORTSDIR}/science/ruby-netcdf \
${RUBY_SITEARCHLIBDIR}/numru/fftw3.so:${PORTSDIR}/math/ruby-fftw3 \
${RUBY_SITELIBDIR}/numru/misc.rb:${PORTSDIR}/math/ruby-numru_misc \
- ${RUBY_SITELIBDIR}/numru/units.rb:${PORTSDIR}/math/ruby-numru_units
+ ${RUBY_SITELIBDIR}/numru/units.rb:${PORTSDIR}/math/ruby-numru_units \
+ ${RUBY_SITEARCHLIBDIR}/rb_gsl.so:${PORTSDIR}/math/ruby-gsl
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
+USE_RUBY_EXTCONF= yes
+
+EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
+DOCSDIR= ${RUBY_MODDOCDIR}
+PORTEXAMPLES= sample* test*
+PORTDOCS= ChangeLog LICENSE.txt README TODO_ep_flux doc*
-DOCS= ChangeLog README TODO_ep_flux doc/*.html
-DOCS_DR= doc/derivative/*.html doc/derivative/math-doc/document.pdf
-DOCS_EP= doc/ep_flux/*.html doc/ep_flux/math-doc/document.pdf
+do-install:
+ cd ${WRKSRC} && ${MAKE} install
+ cd ${WRKSRC} && ${RUBY} install.rb
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${PREFIX}/bin
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/test
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/testdata
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/sample
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/sample/ep_flux
- ${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_MODEXAMPLESDIR}/test
- ${INSTALL_DATA} ${WRKSRC}/testdata/* ${RUBY_MODEXAMPLESDIR}/testdata
- ${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_MODEXAMPLESDIR}/sample
- ${INSTALL_DATA} ${WRKSRC}/sample/ep_flux/* ${RUBY_MODEXAMPLESDIR}/sample/ep_flux
+ @${MKDIR} ${EXAMPLESDIR}
+.for i in ${PORTEXAMPLES}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${i}" ${EXAMPLESDIR})
+.endfor
.endif
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
- ${MKDIR} ${RUBY_MODDOCDIR}/derivative
- ${MKDIR} ${RUBY_MODDOCDIR}/ep_flux
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${i}" ${DOCSDIR})
.endfor
-.for f in ${DOCS_DR}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/derivative
-.endfor
-.for f in ${DOCS_EP}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ep_flux
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-
.include <bsd.port.mk>
diff --git a/science/ruby-gphys/distinfo b/science/ruby-gphys/distinfo
index 89513ec44b3e..0a9ea49d5c48 100644
--- a/science/ruby-gphys/distinfo
+++ b/science/ruby-gphys/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/gphys-1.0.0.tar.gz) = 3486b99c7bacb744e77e86104c2f618b8b94db58724796bdf4255891f2c8dc1a
-SIZE (ruby/gphys-1.0.0.tar.gz) = 1218863
+SHA256 (ruby/gphys-1.2.1.tar.gz) = 4bf23027c91049a26ddce5781642320fbd841c7e92c5977d8d6df3f5410e5a40
+SIZE (ruby/gphys-1.2.1.tar.gz) = 1272044
diff --git a/science/ruby-gphys/pkg-plist b/science/ruby-gphys/pkg-plist
index 0624b4498d24..a466f3c2338b 100644
--- a/science/ruby-gphys/pkg-plist
+++ b/science/ruby-gphys/pkg-plist
@@ -12,8 +12,9 @@ bin/gpvect
bin/gpview
bin/grads2nc_with_gphys
%%RUBY_SITEARCHLIBDIR%%/numru/gphys_ext.so
-%%RUBY_SITELIBDIR%%/numru/dclext_datetime_ax.rb
%%RUBY_SITELIBDIR%%/numru/dcl_mouse.rb
+%%RUBY_SITELIBDIR%%/numru/dclext.rb
+%%RUBY_SITELIBDIR%%/numru/dclext_datetime_ax.rb
%%RUBY_SITELIBDIR%%/numru/derivative.rb
%%RUBY_SITELIBDIR%%/numru/ganalysis.rb
%%RUBY_SITELIBDIR%%/numru/gdir.rb
@@ -25,6 +26,8 @@ bin/grads2nc_with_gphys
%%RUBY_SITELIBDIR%%/numru/ganalysis/covariance.rb
%%RUBY_SITELIBDIR%%/numru/ganalysis/eof.rb
%%RUBY_SITELIBDIR%%/numru/ganalysis/histogram.rb
+%%RUBY_SITELIBDIR%%/numru/ganalysis/met.rb
+%%RUBY_SITELIBDIR%%/numru/ganalysis/planet.rb
%%RUBY_SITELIBDIR%%/numru/gphys/assoccoords.rb
%%RUBY_SITELIBDIR%%/numru/gphys/attribute.rb
%%RUBY_SITELIBDIR%%/numru/gphys/attributenetcdf.rb
@@ -66,77 +69,3 @@ bin/grads2nc_with_gphys
@dirrm %%RUBY_SITELIBDIR%%/numru/ganalysis
@dirrm %%RUBY_SITELIBDIR%%/numru/gphys
@dirrmtry %%RUBY_SITELIBDIR%%/numru
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/cira86_to_nc.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/druby_cli1.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/druby_cli2.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/druby_serv1.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/druby_serv2.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/ggraph_mapfit-axes_dr002687.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/ggraph_latlon_labelling_dr002690.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/map_projection.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/ncep_theta_coord.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/ep_flux/demo_NCEP_1.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/ep_flux/demo_NCEP_2.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/sample/ep_flux/demo_NCEP_3.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test/test_ep_flux.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test/eof_slp.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/T.jan.ctl
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/T.jan.dat
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/T.jan.grib
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/T.jan.nc
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/T.jan.packed.withmiss.nc
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/UV.jan.nc
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/assoc_crds.nc
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/testdata/cira86.dat
-%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%/sample/ep_flux
-%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%/sample
-%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%/test
-%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%/testdata
-%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/TODO_ep_flux
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/attribute.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/attributenetcdf.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/axis.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/coordmapping.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/coordtransform.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gdir.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gdir_client.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gdir_connect_ftp-like.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gdir_server.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ggraph.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gpcat.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gpcut.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gphys.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gphys_fft.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gphys_grads_io.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gphys_grib_io.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gphys_io.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gphys_io_common.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gphys_netcdf_io.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gplist.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gpmath.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gpmaxmin.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gpprint.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/gpview.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/grads2nc_with_gphys.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/grads_gridded.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/grib.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/grid.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/netcdf_convention.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/unumeric.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/varray.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/varraycomposite.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/derivative/gphys-derivative.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/derivative/index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/derivative/numru-derivative.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/derivative/document.pdf
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/derivative
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ep_flux/ep_flux.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ep_flux/index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ep_flux/ggraph_on_merdional_section.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ep_flux/document.pdf
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ep_flux
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%