aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-16 16:45:46 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-16 16:46:15 +0000
commit91e83b602bda9ae19170597966f7d0d977f80f72 (patch)
tree66d16d30e374cad00dce454d4ca23b8b2bb83ac4 /science
parent86c14f087e381efec0fd2530debb130c432fc393 (diff)
downloadports-91e83b602bda9ae19170597966f7d0d977f80f72.tar.gz
ports-91e83b602bda9ae19170597966f7d0d977f80f72.zip
science/ascent: New port: Visualization and analysis runtime for multi-physics HPC simulations
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/ascent/Makefile34
-rw-r--r--science/ascent/distinfo9
-rw-r--r--science/ascent/pkg-descr11
-rw-r--r--science/ascent/pkg-plist103
5 files changed, 158 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index ce30460b050e..3019d3e97cd6 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -25,6 +25,7 @@
SUBDIR += aircraft-datcom
SUBDIR += antioch
SUBDIR += apbs
+ SUBDIR += ascent
SUBDIR += atompaw
SUBDIR += avogadro2
SUBDIR += avogadrolibs
diff --git a/science/ascent/Makefile b/science/ascent/Makefile
new file mode 100644
index 000000000000..d88f613ddd7f
--- /dev/null
+++ b/science/ascent/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= ascent
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.7.1
+CATEGORIES= science
+PKGNAMESUFFIX= -visualizer
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Visualization and analysis runtime for multi-physics HPC simulations
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+LIB_DEPENDS= libconduit.so:science/conduit \
+ libsysinfo.so:devel/libsysinfo
+
+USES= cmake:testing compiler:c++11-lang fortran localbase:ldflags
+
+USE_GITHUB= yes
+GH_ACCOUNT= Alpine-DAV
+GH_TUPLE= Alpine-DAV:spack_configs:2ea6c17:spack_configs/../scripts/uberenv_configs/spack_configs \
+ LLNL:blt:86a7d6b:blt/blt \
+ llnl:uberenv:105e384:uberenv/../scripts/uberenv
+
+CMAKE_OFF= ENABLE_PYTHON ENABLE_DOCS ENABLE_TESTS ENABLE_EXAMPLES
+CMAKE_OFF+= ENABLE_UTILS # utils are installed into a non-standard path, see https://github.com/Alpine-DAV/ascent/issues/814
+CMAKE_OFF+= ENABLE_MPI # MPI fails to link, see https://github.com/Alpine-DAV/ascent/issues/813
+CMAKE_ARGS= -DCONDUIT_DIR=${LOCALBASE}
+CMAKE_TESTING_ON= ENABLE_TESTS # one testcase fails because conduit lacks HDF5, see https://github.com/LLNL/conduit/issues/840
+
+LDFLAGS+= -lsysinfo
+
+WRKSRC_SUBDIR= src
+
+.include <bsd.port.mk>
diff --git a/science/ascent/distinfo b/science/ascent/distinfo
new file mode 100644
index 000000000000..0750c85222d9
--- /dev/null
+++ b/science/ascent/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1631778391
+SHA256 (Alpine-DAV-ascent-v0.7.1_GH0.tar.gz) = 9fd9ab3a54e9684b60c86021a261a4ddab084fff9857f9641e86527bf776ad95
+SIZE (Alpine-DAV-ascent-v0.7.1_GH0.tar.gz) = 60538314
+SHA256 (Alpine-DAV-spack_configs-2ea6c17_GH0.tar.gz) = 133b7d189ab336a28a6f8d6fcdbd82fa6f5c9f3997da8515a1f19252b8680775
+SIZE (Alpine-DAV-spack_configs-2ea6c17_GH0.tar.gz) = 11559
+SHA256 (LLNL-blt-86a7d6b_GH0.tar.gz) = 4298f150e0397367d75795598f4a63cf8c6e29578f9dc907160118fc556d6a3e
+SIZE (LLNL-blt-86a7d6b_GH0.tar.gz) = 1180289
+SHA256 (llnl-uberenv-105e384_GH0.tar.gz) = a47a418e53e571a60ef37318e377597b6b2827b38a9eafabca13b8053b50b95a
+SIZE (llnl-uberenv-105e384_GH0.tar.gz) = 21667
diff --git a/science/ascent/pkg-descr b/science/ascent/pkg-descr
new file mode 100644
index 000000000000..4f5d6b4896bd
--- /dev/null
+++ b/science/ascent/pkg-descr
@@ -0,0 +1,11 @@
+Ascent is an easy-to-use flyweight in situ visualization and analysis library
+for HPC simulations.
+
+It supports:
+* Supports: Making Pictures, Transforming Data, and Capturing Data for use
+ outside of Ascent
+* Young effort, yet already includes most common visualization operations
+* Provides a simple infrastructure to integrate custom analysis
+* Provides C++, C, Python, and Fortran APIs
+
+WWW: https://ascent.readthedocs.io/en/latest/
diff --git a/science/ascent/pkg-plist b/science/ascent/pkg-plist
new file mode 100644
index 000000000000..ee46cc24c314
--- /dev/null
+++ b/science/ascent/pkg-plist
@@ -0,0 +1,103 @@
+include/ascent/ascent.h
+include/ascent/ascent.hpp
+include/ascent/ascent.mod
+include/ascent/ascent_actions_utils.hpp
+include/ascent/ascent_block_timer.hpp
+include/ascent/ascent_blueprint_architect.hpp
+include/ascent/ascent_conduit_reductions.hpp
+include/ascent/ascent_config.h
+include/ascent/ascent_data_object.hpp
+include/ascent/ascent_empty_runtime.hpp
+include/ascent/ascent_exports.h
+include/ascent/ascent_expression_eval.hpp
+include/ascent/ascent_expression_filters.hpp
+include/ascent/ascent_expressions_ast.hpp
+include/ascent/ascent_expressions_parser.hpp
+include/ascent/ascent_expressions_tokens.hpp
+include/ascent/ascent_file_system.hpp
+include/ascent/ascent_flow_runtime.hpp
+include/ascent/ascent_hola.hpp
+include/ascent/ascent_logging.hpp
+include/ascent/ascent_main_runtime.hpp
+include/ascent/ascent_metadata.hpp
+include/ascent/ascent_mpi_utils.hpp
+include/ascent/ascent_png_compare.hpp
+include/ascent/ascent_png_decoder.hpp
+include/ascent/ascent_png_encoder.hpp
+include/ascent/ascent_resources.hpp
+include/ascent/ascent_resources_cinema_web.hpp
+include/ascent/ascent_runtime.hpp
+include/ascent/ascent_runtime_blueprint_filters.hpp
+include/ascent/ascent_runtime_filters.hpp
+include/ascent/ascent_runtime_param_check.hpp
+include/ascent/ascent_runtime_query_filters.hpp
+include/ascent/ascent_runtime_relay_filters.hpp
+include/ascent/ascent_runtime_trigger_filters.hpp
+include/ascent/ascent_runtime_utils.hpp
+include/ascent/ascent_runtime_vtkh_utils.hpp
+include/ascent/ascent_string_utils.hpp
+include/ascent/ascent_transmogrifier.hpp
+include/ascent/ascent_web_interface.hpp
+include/ascent/flow.hpp
+include/ascent/flow_builtin_filters.hpp
+include/ascent/flow_config.h
+include/ascent/flow_data.hpp
+include/ascent/flow_exports.h
+include/ascent/flow_filter.hpp
+include/ascent/flow_filters.hpp
+include/ascent/flow_graph.hpp
+include/ascent/flow_registry.hpp
+include/ascent/flow_timer.hpp
+include/ascent/flow_workspace.hpp
+lib/cmake/ascent/AscentConfig.cmake
+lib/cmake/ascent/AscentConfigVersion.cmake
+lib/cmake/ascent/ascent-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ascent/ascent.cmake
+lib/cmake/ascent/ascent_setup_deps.cmake
+lib/cmake/ascent/ascent_setup_targets.cmake
+lib/libascent.so
+lib/libascent_flow.so
+lib/libascent_lodepng.so
+%%DATADIR%%/ascent_config.mk
+%%DATADIR%%/web_clients/ascent/index.html
+%%DATADIR%%/web_clients/ascent/resources/ascent_style.css
+%%DATADIR%%/web_clients/ascent/resources/ascent_wsock.js
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-grid.css
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-grid.css.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-grid.min.css
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-grid.min.css.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-reboot.css
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-reboot.css.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-reboot.min.css
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap-reboot.min.css.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap.css
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap.css.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap.min.css
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/css/bootstrap.min.css.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.bundle.js
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.bundle.js.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.bundle.min.js
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.bundle.min.js.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.js
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.js.map
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.min.js
+%%DATADIR%%/web_clients/ascent/resources/bootstrap-4.0.0-beta.2-dist/js/bootstrap.min.js.map
+%%DATADIR%%/web_clients/ascent/resources/jquery-2.1.4.min.js
+%%DATADIR%%/web_clients/cinema/cvlib/ASCENT_README.md
+%%DATADIR%%/web_clients/cinema/cvlib/README.md
+%%DATADIR%%/web_clients/cinema/cvlib/copyright.md
+%%DATADIR%%/web_clients/cinema/cvlib/css/cvlib.css
+%%DATADIR%%/web_clients/cinema/cvlib/js/ControlsBasic.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/ControlsPhiTheta.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/Database.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/DatabaseSpecA.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/DatabaseSpecA_NoAJAX.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/Parameter.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/QuerySet.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/Renderer.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/RendererSpecA.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/ResultSet.js
+%%DATADIR%%/web_clients/cinema/cvlib/js/UIFactory.js
+%%DATADIR%%/web_clients/cinema/cvlib/lib/jquery-3.1.1.min.js
+%%DATADIR%%/web_clients/cinema/cvlib/license.md
+%%DATADIR%%/web_clients/cinema/index.html