aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-11 07:12:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-11 07:13:16 +0000
commitdfc0238640429f5d381a17d2d1196f9f9461312e (patch)
tree2cb46ebb257772021b115e0190f0c06ff4473077 /science
parent8246f2da9c5948b1b750a0afeb7438d609032827 (diff)
downloadports-dfc0238640429f5d381a17d2d1196f9f9461312e.tar.gz
ports-dfc0238640429f5d381a17d2d1196f9f9461312e.zip
science/py-pyked: New port: Package for manipulating Chemical Kinetics Experimental Data files
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-pyked/Makefile31
-rw-r--r--science/py-pyked/distinfo3
-rw-r--r--science/py-pyked/pkg-descr6
4 files changed, 41 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 0d094c356ee6..9cbe4c3e8c10 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -290,6 +290,7 @@
SUBDIR += py-pygeodesy
SUBDIR += py-pygeometa
SUBDIR += py-pygmo2
+ SUBDIR += py-pyked
SUBDIR += py-pymatgen
SUBDIR += py-pymol
SUBDIR += py-pyosf
diff --git a/science/py-pyked/Makefile b/science/py-pyked/Makefile
new file mode 100644
index 000000000000..79080cc0b709
--- /dev/null
+++ b/science/py-pyked/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= pyked
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.1-16
+DISTVERSIONSUFFIX= -gfcccaf8
+CATEGORIES= science python
+#MASTER_SITES= CHEESESHOP 0.4.1 is broken there
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Package for manipulating Chemical Kinetics Experimental Data files
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}Cerberus>=1.0.0:devel/py-cerberus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}habanero>=0.6.0:www/py-habanero@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pint>=0.7.2:devel/py-pint@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uncertainties>=3.0.1:math/py-uncertainties@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.12:devel/py-yaml@${PY_FLAVOR} \
+
+USES= python:3.6+
+USE_PYTHON= distutils concurrent autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= pr-omethe-us
+GH_PROJECT= PyKED
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-pyked/distinfo b/science/py-pyked/distinfo
new file mode 100644
index 000000000000..b53ec61ea989
--- /dev/null
+++ b/science/py-pyked/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631341782
+SHA256 (pr-omethe-us-PyKED-v0.4.1-16-gfcccaf8_GH0.tar.gz) = 63fda19c9f9ab41e4e8234928f5c3977e7465cca1dd1ac1a8af4fe7458861b80
+SIZE (pr-omethe-us-PyKED-v0.4.1-16-gfcccaf8_GH0.tar.gz) = 384834
diff --git a/science/py-pyked/pkg-descr b/science/py-pyked/pkg-descr
new file mode 100644
index 000000000000..0fb162b5db5f
--- /dev/null
+++ b/science/py-pyked/pkg-descr
@@ -0,0 +1,6 @@
+PyKED is a Python package that provides the reference implementation of the
+interface to ChemKED files. PyKED reads ChemKED files, validates their structure
+and content, and allows the user to interact with the data contained in the
+ChemKED file.
+
+WWW: https://pr-omethe-us.github.io/PyKED/