aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-04-17 00:30:58 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-04-17 00:30:58 +0000
commitdd47a49a591779a2173d31bfb7a7a71381ea1b30 (patch)
tree62c6b05cf0a8c244d989dbc4bc1f523b36ce15a5 /science
parent146d46b7875e8678f338985e1fe5f07420da245d (diff)
downloadports-dd47a49a591779a2173d31bfb7a7a71381ea1b30.tar.gz
ports-dd47a49a591779a2173d31bfb7a7a71381ea1b30.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/hdf/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 80eb1792709a..8f755469edff 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hdf
PORTVERSION= 4.2r1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science archivers graphics
MASTER_SITES= ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF${PORTVERSION}/src/:src \
ftp://ftp.ncsa.uiuc.edu/HDF/HDF/Documentation/HDF4.2r0/:doc \
@@ -26,9 +26,16 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
CONFLICTS= netcdf-*
+WANT_FORTRAN= yes
+#USE_GCC=4.2+
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS+=--with-jpeg="${LOCALBASE}" \
--with-szlib="${LOCALBASE}"
+CONFIGURE_ENV+= F77="${F77}" FFLAGS="${FFLAGS}"
DOCFILES= HDF41r5_SpecDG.pdf \
HDF42r0_RefMan.pdf \
HDF42r0_UserGd.pdf
@@ -37,12 +44,12 @@ SZIP_DOCFILE= SZIP_HDF4_2r1.pdf
MAN1= hdf.1 hdfunpac.1 ncdump.1 ncgen.1
MANCOMPRESSED= no
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${ARCH} != "alpha" && ${ARCH} != "amd64"
-BROKEN= "Does not compile on !i386, !amd64 and !alpha"
+BROKEN= Does not compile on !i386, !amd64 and !alpha
.endif
post-patch: