aboutsummaryrefslogtreecommitdiff
path: root/security/ADMsnmp/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-05-08 05:07:22 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-05-08 05:07:22 +0000
commit7656cb1993623bfd13dc776db5c9756bc32b5e2e (patch)
treeb166ea8c61ac3ceb8173634732bcfc42f201040b /security/ADMsnmp/Makefile
parent968af1073d874a7c1937ccc94fc6ac3e532cdbc1 (diff)
downloadports-7656cb1993623bfd13dc776db5c9756bc32b5e2e.tar.gz
ports-7656cb1993623bfd13dc776db5c9756bc32b5e2e.zip
Notes
Diffstat (limited to 'security/ADMsnmp/Makefile')
-rw-r--r--security/ADMsnmp/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/ADMsnmp/Makefile b/security/ADMsnmp/Makefile
new file mode 100644
index 000000000000..7a3164355667
--- /dev/null
+++ b/security/ADMsnmp/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: ADMsnmp
+# Date created: 16 Apr 2003
+# Whom: Yonatan@xpert.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= ADMsnmp
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= ftp://adm.freelsd.net/pub/ADM/ \
+ http://adm.freelsd.net/ADM/ \
+ ${MASTER_SITE_PACKETSTORM:=groups/ADM/}
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= Yonatan@xpert.com
+COMMENT= SNMP audit scanner
+
+WRKSRC= ${WRKDIR}/ADMsnmp
+
+do-build:
+ ${CC} ${CFLAGS} -DPORTSHAREDIR="${PREFIX}/share/ADMsnmp" \
+ -o ${WRKSRC}/ADMsnmp ${WRKSRC}/snmp.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ADMsnmp ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/ADMsnmp
+ ${MKDIR} ${PREFIX}/share/doc/ADMsnmp
+ ${INSTALL_DATA} ${WRKSRC}/snmp.passwd ${PREFIX}/share/ADMsnmp
+ ${INSTALL_DATA} ${WRKSRC}/ADMsnmp.README ${PREFIX}/share/doc/ADMsnmp
+
+.include <bsd.port.mk>