aboutsummaryrefslogtreecommitdiff
path: root/security/R-cran-ROAuth/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-09-04 13:05:23 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-09-04 13:05:23 +0000
commited9b6828f5fc1e298d735e3a2ab44ea57682c01e (patch)
tree2536010c7e9ac806f02104b03155cb0ecddca882 /security/R-cran-ROAuth/Makefile
parent5925e7f3da754cf772e4f7ebc38e28704108de3e (diff)
- Add a new port: security/R-cran-ROAuth
This package provides an interface to the OAuth 1.0 specification, allowing users to authenticate via OAuth to the server of their choice. WWW: http://cran.r-project.org/web/packages/ROAuth/
Notes
Notes: svn path=/head/; revision=281151
Diffstat (limited to 'security/R-cran-ROAuth/Makefile')
-rw-r--r--security/R-cran-ROAuth/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/R-cran-ROAuth/Makefile b/security/R-cran-ROAuth/Makefile
new file mode 100644
index 000000000000..fbf5bce4aac7
--- /dev/null
+++ b/security/R-cran-ROAuth/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: R-cran-ROAuth
+# Date created: 2011-09-04
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ROAuth
+PORTVERSION= 0.9.0
+CATEGORIES= security
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= R interface for OAuth
+
+LICENSE= ART20
+
+RUN_DEPENDS= R-cran-RCurl>=1.6.4:${PORTSDIR}/ftp/R-cran-RCurl \
+ R-cran-digest>0:${PORTSDIR}/security/R-cran-digest
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>