aboutsummaryrefslogtreecommitdiff
path: root/security/acme.sh
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-09-13 15:11:04 +0000
committerDan Langille <dvl@FreeBSD.org>2017-09-13 15:11:04 +0000
commit66b723af7f552f073be11737ed495d9a51db840f (patch)
tree426c0806582e41bd8493b467298ee63b9108651c /security/acme.sh
parent5b9c91a08f94fc56d0b025cac333f9679ad701cd (diff)
Provide a sample cronjob
Notes
Notes: svn path=/head/; revision=449799
Diffstat (limited to 'security/acme.sh')
-rw-r--r--security/acme.sh/Makefile1
-rw-r--r--security/acme.sh/files/pkg-message.in13
2 files changed, 14 insertions, 0 deletions
diff --git a/security/acme.sh/Makefile b/security/acme.sh/Makefile
index f95f03fce78b..ae8367b5a19b 100644
--- a/security/acme.sh/Makefile
+++ b/security/acme.sh/Makefile
@@ -2,6 +2,7 @@
PORTNAME= acme.sh
PORTVERSION= 2.7.4
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= dvl@FreeBSD.org
diff --git a/security/acme.sh/files/pkg-message.in b/security/acme.sh/files/pkg-message.in
index 55c67e8b571d..65228ba5c30a 100644
--- a/security/acme.sh/files/pkg-message.in
+++ b/security/acme.sh/files/pkg-message.in
@@ -16,4 +16,17 @@ included are the deploy scripts.
A newsyslog.conf sample file is provided at %%EXAMPLESDIR%%/acme.sh
and you could create a symlink from that to %%PREFIX%%/etc/newsyslog.conf.d/
+Your sample cronjob looks like this:
+
+############################################################################
+$ sudo crontab -l -u acme
+# use /bin/sh to run commands, overriding the default set by cron
+SHELL=/bin/sh
+# mail any output to here, no matter whose crontab this is
+MAILTO=dan@example.org
+
+7 22 * * * /usr/local/sbin/acme.sh --cron --home /var/db/acme/.acme.sh > /dev/null
+############################################################################
+
+Change x & y to some minute and hour of the day.