aboutsummaryrefslogtreecommitdiff
path: root/security/acme.sh
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-05-20 02:27:45 +0000
committerDan Langille <dvl@FreeBSD.org>2017-05-20 02:27:45 +0000
commit89e9977d0c5ee2cc8fef42368e4f91a039de179d (patch)
tree84357ac2d921b45cd5cf844c1c973cd46511cf5c /security/acme.sh
parent1e89d592f648c9d4819604204ffd490c780d2be0 (diff)
Notes
Diffstat (limited to 'security/acme.sh')
-rw-r--r--security/acme.sh/Makefile42
-rw-r--r--security/acme.sh/distinfo3
-rw-r--r--security/acme.sh/pkg-descr13
3 files changed, 58 insertions, 0 deletions
diff --git a/security/acme.sh/Makefile b/security/acme.sh/Makefile
new file mode 100644
index 000000000000..fdd87af4848c
--- /dev/null
+++ b/security/acme.sh/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= acme.sh
+PORTVERSION= 2.6.9
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= ACME protocol client written in shell
+
+LICENSE= GPLv3+
+
+RUN_DEPENDS= curl:ftp/curl
+
+USE_GITHUB= yes
+GH_ACCOUNT= Neilpang
+
+USERS= acme
+GROUPS= acme
+
+OPTIONS_DEFINE= CURL DOCS WGET
+OPTIONS_DEFAULT= CURL
+CURL_DESC= Add ftp/curl as a run-time dependency
+WGET_DESC= Add ftp/wget as a run-time dependency
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+CURL_RUN_DEPENDS= curl:ftp/curl
+WGET_RUN_DEPENDS= wget:ftp/wget
+
+PLIST_FILES= sbin/${PORTNAME}
+PORTDOCS= README.md
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/acme.sh/distinfo b/security/acme.sh/distinfo
new file mode 100644
index 000000000000..4003f834ca30
--- /dev/null
+++ b/security/acme.sh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1495240079
+SHA256 (Neilpang-acme.sh-v2.6.9_GH0.tar.gz) = 7e366872c716af42dbeaaf6fcec46e2bffb5af90ecaebd812ddeb253113a93c9
+SIZE (Neilpang-acme.sh-v2.6.9_GH0.tar.gz) = 74338
diff --git a/security/acme.sh/pkg-descr b/security/acme.sh/pkg-descr
new file mode 100644
index 000000000000..c5e83e96eb72
--- /dev/null
+++ b/security/acme.sh/pkg-descr
@@ -0,0 +1,13 @@
+ACME protocol client written in shell
+
+- Full ACME protocol implementation.
+- Simple, powerful and very easy to use. You only need 3 minutes to learn it.
+- Bash, dash and sh compatible.
+- Simplest shell script for Let's Encrypt free certificate client.
+- Purely written in Shell with no dependencies on python or the official Let's
+ Encrypt client.
+- Just one script to issue, renew and install your certificates automatically.
+- DOES NOT require root/sudoer access.
+- Docker friendly.
+
+WWW: https://github.com/Neilpang/acme.sh/